]> git.pld-linux.org Git - packages/lilv.git/blame - lilv.spec
don't require doxygen without apidocs
[packages/lilv.git] / lilv.spec
CommitLineData
5e1ce647
JB
1#
2# Conditional build:
3%bcond_with apidocs # API documentation
4
1aa9ade6
JB
5Summary: LV2 host library to make LV2 plugin use as simple as possible
6Summary(pl.UTF-8): Biblioteka hosta LV2 ułatwiająca korzystanie z wtyczek LV2
7Name: lilv
40cbf1ce 8Version: 0.24.20
5e1ce647 9Release: 1
1aa9ade6
JB
10License: ISC
11Group: Libraries
5e1ce647 12Source0: http://download.drobilla.net/%{name}-%{version}.tar.xz
40cbf1ce 13# Source0-md5: 561ff65228b54e58744a7ae6e2141741
1aa9ade6 14URL: http://drobilla.net/software/lilv/
ac55eab6 15BuildRequires: libsndfile-devel >= 1.0.0
1aa9ade6 16BuildRequires: libstdc++-devel
5e1ce647
JB
17BuildRequires: lv2-devel >= 1.18.2
18BuildRequires: meson >= 0.56.0
19BuildRequires: ninja >= 1.5
1aa9ade6 20BuildRequires: pkgconfig
50afd6bb
JB
21# or python 2.6+, but no sense to introduce in 2020
22BuildRequires: python3 >= 1:3.4
23BuildRequires: python3-modules >= 1:3.4
24BuildRequires: rpmbuild(macros) >= 1.507
40cbf1ce
JB
25BuildRequires: serd-devel >= 0.30.10
26BuildRequires: sord-devel >= 0.16.10
27BuildRequires: sratom-devel >= 0.6.10
5e1ce647
JB
28BuildRequires: tar >= 1:1.22
29BuildRequires: xz
30%if %{with apidocs}
31BuildRequires: doxygen
32BuildRequires: sphinx-pdg
33%endif
34Requires: lv2 >= 1.18.2
40cbf1ce
JB
35Requires: serd >= 0.30.10
36Requires: sord >= 0.16.10
37Requires: sratom >= 0.6.10
1aa9ade6
JB
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41Lilv is a library to make the use of LV2 plugins as simple as possible
42for applications. Lilv is the successor to SLV2, rewritten to be
43significantly faster and have minimal dependencies.
44
45%description -l pl.UTF-8
46Lilv to biblioteka ułatwiająca korzystanie z wtyczek LV2 w
47aplikacjach. Jest następczynią SLV2; została przepisana tak, aby była
48znacznie szybsza i miała minimalne zależności.
49
50%package devel
51Summary: Header files for Lilv library
52Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Lilv
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
5e1ce647 55Requires: lv2-devel >= 1.18.2
40cbf1ce
JB
56Requires: serd-devel >= 0.30.10
57Requires: sord-devel >= 0.16.10
58Requires: sratom-devel >= 0.6.10
1aa9ade6
JB
59
60%description devel
61Header files for Lilv library.
62
63%description devel -l pl.UTF-8
64Pliki nagłówkowe biblioteki Lilv.
65
66%package -n bash-completion-lilv
67Summary: Bash auto-completion for lilv commands
68Summary(pl.UTF-8): Bashowe dopełnianie składni dla poleceń lilv
69Group: Applications/Shells
70Requires: bash-completion
71
72%description -n bash-completion-lilv
73Bash auto-completion script for lv2info and lv2jack commands.
74
75%description -n bash-completion-lilv -l pl.UTF-8
76Skrypt bashowego dopełniania parametrów dla poleceń lv2info i lv2jack.
77
50afd6bb
JB
78%package -n python3-lilv
79Summary: Python binding for lilv
80Summary(pl.UTF-8): Wiązania Pythona do lilv
81Group: Libraries/Python
82Requires: %{name} = %{version}-%{release}
83Requires: python3-modules >= 1:3.4
84
85%description -n python3-lilv
86Python binding for lilv.
87
88%description -n python3-lilv -l pl.UTF-8
89Wiązania Pythona do lilv.
90
1aa9ade6
JB
91%prep
92%setup -q
93
94%build
5e1ce647
JB
95%meson build \
96 --default-library=shared \
97 %{!?with_apidocs:-Ddocs=disabled}
1aa9ade6 98
5e1ce647 99%ninja_build -C build
1aa9ade6
JB
100
101%install
102rm -rf $RPM_BUILD_ROOT
103
5e1ce647 104%ninja_install -C build
1aa9ade6 105
50afd6bb
JB
106%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
107%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
108
1aa9ade6
JB
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post -p /sbin/ldconfig
113%postun -p /sbin/ldconfig
114
115%files
116%defattr(644,root,root,755)
50afd6bb 117%doc AUTHORS COPYING NEWS README.md
ac55eab6 118%attr(755,root,root) %{_bindir}/lv2apply
a3e8a303 119%attr(755,root,root) %{_bindir}/lv2bench
1aa9ade6
JB
120%attr(755,root,root) %{_bindir}/lv2info
121%attr(755,root,root) %{_bindir}/lv2ls
122%attr(755,root,root) %{_libdir}/liblilv-0.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/liblilv-0.so.0
ac55eab6 124%{_mandir}/man1/lv2apply.1*
5e1ce647 125%{_mandir}/man1/lv2bench.1*
1aa9ade6
JB
126%{_mandir}/man1/lv2info.1*
127%{_mandir}/man1/lv2ls.1*
128
129%files devel
130%defattr(644,root,root,755)
131%attr(755,root,root) %{_libdir}/liblilv-0.so
132%{_includedir}/lilv-0
133%{_pkgconfigdir}/lilv-0.pc
134
135%files -n bash-completion-lilv
136%defattr(644,root,root,755)
137/etc/bash_completion.d/lilv
50afd6bb
JB
138
139%files -n python3-lilv
140%defattr(644,root,root,755)
141%{py3_sitescriptdir}/lilv.py
142%{py3_sitescriptdir}/__pycache__/lilv.cpython-*.py[co]
This page took 0.192477 seconds and 4 git commands to generate.