]> git.pld-linux.org Git - packages/lilv.git/blame - lilv.spec
rebuild with python 3.10
[packages/lilv.git] / lilv.spec
CommitLineData
1aa9ade6
JB
1Summary: LV2 host library to make LV2 plugin use as simple as possible
2Summary(pl.UTF-8): Biblioteka hosta LV2 ułatwiająca korzystanie z wtyczek LV2
3Name: lilv
1c8ed40c 4Version: 0.24.12
bf83f4b3 5Release: 4
1aa9ade6
JB
6License: ISC
7Group: Libraries
8Source0: http://download.drobilla.net/%{name}-%{version}.tar.bz2
1c8ed40c 9# Source0-md5: d4ca22730509c59359e01ef58d238dd1
1aa9ade6
JB
10URL: http://drobilla.net/software/lilv/
11BuildRequires: doxygen
ac55eab6 12BuildRequires: libsndfile-devel >= 1.0.0
1aa9ade6 13BuildRequires: libstdc++-devel
10a652ba 14BuildRequires: lv2-devel >= 1.18.0
1aa9ade6 15BuildRequires: pkgconfig
50afd6bb
JB
16# or python 2.6+, but no sense to introduce in 2020
17BuildRequires: python3 >= 1:3.4
18BuildRequires: python3-modules >= 1:3.4
19BuildRequires: rpmbuild(macros) >= 1.507
20BuildRequires: serd-devel >= 0.30.0
3a693a76 21BuildRequires: sord-devel >= 0.14.0
ddbd4e4c 22BuildRequires: sratom-devel >= 0.4.0
10a652ba 23Requires: lv2 >= 1.18.0
50afd6bb 24Requires: serd >= 0.30.0
3a693a76 25Requires: sord >= 0.14.0
ddbd4e4c 26Requires: sratom >= 0.4.0
1aa9ade6
JB
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Lilv is a library to make the use of LV2 plugins as simple as possible
31for applications. Lilv is the successor to SLV2, rewritten to be
32significantly faster and have minimal dependencies.
33
34%description -l pl.UTF-8
35Lilv to biblioteka ułatwiająca korzystanie z wtyczek LV2 w
36aplikacjach. Jest następczynią SLV2; została przepisana tak, aby była
37znacznie szybsza i miała minimalne zależności.
38
39%package devel
40Summary: Header files for Lilv library
41Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Lilv
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
10a652ba 44Requires: lv2-devel >= 1.18.0
50afd6bb 45Requires: serd-devel >= 0.30.0
3a693a76 46Requires: sord-devel >= 0.14.0
ddbd4e4c 47Requires: sratom-devel >= 0.4.0
1aa9ade6
JB
48
49%description devel
50Header files for Lilv library.
51
52%description devel -l pl.UTF-8
53Pliki nagłówkowe biblioteki Lilv.
54
55%package -n bash-completion-lilv
56Summary: Bash auto-completion for lilv commands
57Summary(pl.UTF-8): Bashowe dopełnianie składni dla poleceń lilv
58Group: Applications/Shells
59Requires: bash-completion
60
61%description -n bash-completion-lilv
62Bash auto-completion script for lv2info and lv2jack commands.
63
64%description -n bash-completion-lilv -l pl.UTF-8
65Skrypt bashowego dopełniania parametrów dla poleceń lv2info i lv2jack.
66
50afd6bb
JB
67%package -n python3-lilv
68Summary: Python binding for lilv
69Summary(pl.UTF-8): Wiązania Pythona do lilv
70Group: Libraries/Python
71Requires: %{name} = %{version}-%{release}
72Requires: python3-modules >= 1:3.4
73
74%description -n python3-lilv
75Python binding for lilv.
76
77%description -n python3-lilv -l pl.UTF-8
78Wiązania Pythona do lilv.
79
1aa9ade6
JB
80%prep
81%setup -q
82
83%build
84CC="%{__cc}" \
85CFLAGS="%{rpmcflags}" \
50afd6bb 86%{__python3} ./waf configure \
1aa9ade6
JB
87 --prefix=%{_prefix} \
88 --libdir=%{_libdir} \
89 --configdir=/etc \
90 --strict
91
50afd6bb 92%{__python3} ./waf -v
1aa9ade6
JB
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
50afd6bb 97%{__python3} ./waf install \
1aa9ade6
JB
98 --destdir=$RPM_BUILD_ROOT
99
50afd6bb
JB
100%py3_comp $RPM_BUILD_ROOT%{py3_sitescriptdir}
101%py3_ocomp $RPM_BUILD_ROOT%{py3_sitescriptdir}
102
1aa9ade6
JB
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107%postun -p /sbin/ldconfig
108
109%files
110%defattr(644,root,root,755)
50afd6bb 111%doc AUTHORS COPYING NEWS README.md
1aa9ade6 112%attr(755,root,root) %{_bindir}/lilv-bench
ac55eab6 113%attr(755,root,root) %{_bindir}/lv2apply
a3e8a303 114%attr(755,root,root) %{_bindir}/lv2bench
1aa9ade6
JB
115%attr(755,root,root) %{_bindir}/lv2info
116%attr(755,root,root) %{_bindir}/lv2ls
117%attr(755,root,root) %{_libdir}/liblilv-0.so.*.*.*
118%attr(755,root,root) %ghost %{_libdir}/liblilv-0.so.0
ac55eab6 119%{_mandir}/man1/lv2apply.1*
1aa9ade6
JB
120%{_mandir}/man1/lv2info.1*
121%{_mandir}/man1/lv2ls.1*
122
123%files devel
124%defattr(644,root,root,755)
125%attr(755,root,root) %{_libdir}/liblilv-0.so
126%{_includedir}/lilv-0
127%{_pkgconfigdir}/lilv-0.pc
128
129%files -n bash-completion-lilv
130%defattr(644,root,root,755)
131/etc/bash_completion.d/lilv
50afd6bb
JB
132
133%files -n python3-lilv
134%defattr(644,root,root,755)
135%{py3_sitescriptdir}/lilv.py
136%{py3_sitescriptdir}/__pycache__/lilv.cpython-*.py[co]
This page took 0.078833 seconds and 4 git commands to generate.