]> git.pld-linux.org Git - packages/liferea.git/blame - liferea.spec
- release 2
[packages/liferea.git] / liferea.spec
CommitLineData
b0ffa6a4
MB
1# TODO:
2# - create subpackage -lua (?)
3# - webkit support
93a9f7c2 4#
ce065e76 5# Conditional build:
c6d083e2 6%bcond_without dbus # without DBUS support
cfb7ca5b 7%bcond_without gtkhtml # without GtkHTML
5d157e09 8%bcond_without xulrunner # without XULRunner backend
beed1c1e 9%bcond_without lua # without LUA scripting support
a0630dd8 10%bcond_with nm # with NetworkManager support
f6d80c17 11#
5d157e09
MB
12%ifarch %{x8664}
13%undefine with_gtkhtml # GtkHTML backend disabled on x86_64
14%endif
c3a7ac07 15Summary: A RSS feed reader
94e05515 16Summary(pl.UTF-8): Program do pobierania informacji w formacie RSS
7d878c33 17Name: liferea
afefaa5b 18Version: 1.4.15
7b422ce3 19Release: 2
d61c977e 20License: GPL v2
057d358d 21Group: X11/Applications/Networking
becf6e61 22Source0: http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
afefaa5b 23# Source0-md5: e4ae96a0d41d94c31271ba791caec922
923f28f9 24Patch0: %{name}-desktop.patch
5d157e09 25Patch1: %{name}-xulrunner.patch
beed1c1e 26Patch2: %{name}-lua51.patch
7d878c33 27URL: http://liferea.sourceforge.net/
f6d80c17 28BuildRequires: GConf2-devel >= 2.10.0
b0ffa6a4 29%{?with_nm:BuildRequires: NetworkManager-devel}
c53f3073 30BuildRequires: autoconf >= 2.59
c678d658 31BuildRequires: automake
7500482a 32%{?with_dbus:BuildRequires: dbus-glib-devel >= 0.33}
199241d0 33BuildRequires: gettext-devel
b0ffa6a4 34BuildRequires: gnutls-devel
8c6ef9d1 35BuildRequires: gtk+2-devel >= 2:2.8.0
97d7d603 36BuildRequires: intltool >= 0.35.5
b0ffa6a4 37BuildRequires: libglade2-devel >= 2.0.0
cfb7ca5b 38%{?with_gtkhtml:BuildRequires: libgtkhtml-devel >= 2.6.3}
8c6ef9d1 39BuildRequires: libnotify-devel >= 0.3.2
d87234a1 40BuildRequires: libstdc++-devel
c678d658 41BuildRequires: libtool
b0ffa6a4 42BuildRequires: libxml2-devel >= 1:2.6.27
33391785 43BuildRequires: libxslt-devel >= 1.1.19
beed1c1e 44%{?with_lua:BuildRequires: lua51-devel}
21efbadf 45BuildRequires: pkgconfig
a7124b62 46BuildRequires: rpmbuild(macros) >= 1.311
6cb7f467 47BuildRequires: sqlite3-devel
1c3e70a7 48%{?with_xulrunner:BuildRequires: xulrunner-devel}
8c6ef9d1
MB
49Requires(post,postun): gtk+2
50Requires(post,postun): hicolor-icon-theme
a7124b62 51Requires(post,preun): GConf2
f7f46e7a 52Requires: %{name}-backend = %{version}-%{release}
5d157e09
MB
53%ifarch %{x8664}
54Obsoletes: liferea-gtkhtml
55%endif
7d878c33 56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
d87234a1 58%define _noautoreqdep libgtkembedmoz.so libxpcom.so
60b02ea2
MB
59# we have strict deps for it
60%define _noautoreq libxpcom.so
d87234a1 61
7d878c33 62%description
c3a7ac07 63Liferea is a GTK+ clone of FeedReader.
e3a76882 64
abc7ef2a
JR
65%description -l pl.UTF-8
66Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
c3a7ac07 67FeedReader.
7d878c33 68
f7f46e7a 69%package gtkhtml
70Summary: GtkHTML module for Liferea
94e05515 71Summary(pl.UTF-8): Moduł GtkHTML dla Liferea
f7f46e7a 72Group: X11/Applications/Networking
73Requires: %{name} = %{version}-%{release}
74Provides: %{name}-backend = %{version}-%{release}
75
76%description gtkhtml
77GtkHTML module for Liferea.
78
abc7ef2a
JR
79%description gtkhtml -l pl.UTF-8
80Moduł GtkHTML dla Liferea.
f7f46e7a 81
d87234a1
JB
82%package mozilla
83Summary: Mozilla HTML browser module for Liferea
94e05515 84Summary(pl.UTF-8): Moduł przeglądarki HTML dla Liferea oparty na Mozilli
d87234a1
JB
85Group: X11/Applications/Networking
86Requires: %{name} = %{version}-%{release}
5d157e09 87%requires_eq_to xulrunner xulrunner-devel
f7f46e7a 88Provides: %{name}-backend = %{version}-%{release}
d87234a1
JB
89
90%description mozilla
91Mozilla HTML browser module for Liferea.
92
abc7ef2a
JR
93%description mozilla -l pl.UTF-8
94Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
d87234a1 95
7d878c33 96%prep
84e0b8d3 97%setup -q
923f28f9 98%patch0 -p1
5d157e09 99%patch1 -p1
beed1c1e 100%patch2 -p1
4998f7bb 101
7d878c33 102%build
97d7d603
MB
103%{__glib_gettextize}
104%{__intltoolize}
07652b7c 105%{__aclocal}
106%{__libtoolize}
107%{__autoheader}
108%{__automake}
109%{__autoconf}
4575ec8b 110%configure \
ce065e76 111 --disable-schemas-install \
cfb7ca5b 112 %{!?with_dbus: --disable-dbus} \
113 %{!?with_gtkhtml: --disable-gtkhtml2} \
beed1c1e 114 %{!?with_lua: --disable-lua} \
a0630dd8 115 %{!?with_nm: --disable-nm} \
5d157e09 116 %{!?with_xulrunner: --disable-xulrunner}
7d878c33 117%{__make}
118
119%install
120rm -rf $RPM_BUILD_ROOT
121
122%{__make} install \
123 DESTDIR=$RPM_BUILD_ROOT \
87a534e2 124 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
7d878c33 125
d87234a1
JB
126rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
127
deb1b71a 128%find_lang %{name}
129
4575ec8b 130%post
e9666971 131%gconf_schema_install liferea.schemas
dca7406c 132%update_icon_cache hicolor
f6d80c17 133
134%preun
e9666971 135%gconf_schema_uninstall liferea.schemas
4575ec8b 136
dca7406c 137%postun
138%update_icon_cache hicolor
139
7d878c33 140%clean
141rm -rf $RPM_BUILD_ROOT
142
deb1b71a 143%files -f %{name}.lang
7d878c33 144%defattr(644,root,root,755)
14552208 145%doc AUTHORS ChangeLog NEWS README
69d12f62
MB
146%attr(755,root,root) %{_bindir}/liferea
147%attr(755,root,root) %{_bindir}/liferea-add-feed
148%attr(755,root,root) %{_bindir}/liferea-bin
d87234a1 149%dir %{_libdir}/%{name}
69d12f62 150%attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
dca7406c 151%{_iconsdir}/hicolor/48x48/apps/liferea.png
d8954fa2 152%{_sysconfdir}/gconf/schemas/liferea.schemas
7d878c33 153%{_datadir}/%{name}
8e447246 154%{_desktopdir}/*.desktop
b0c9bbae 155%{_mandir}/man1/liferea.1*
69d12f62 156%{_mandir}/pl/man1/liferea.1*
31d6b4ba 157%if %{with lua}
a7307aee 158%attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
31d6b4ba 159%endif
d87234a1 160
cfb7ca5b 161%if %{with gtkhtml}
f7f46e7a 162%files gtkhtml
163%defattr(644,root,root,755)
69d12f62 164%attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
cfb7ca5b 165%endif
f7f46e7a 166
5d157e09 167%if %{with xulrunner}
d87234a1
JB
168%files mozilla
169%defattr(644,root,root,755)
69d12f62 170%attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
ce065e76 171%endif
This page took 0.060802 seconds and 4 git commands to generate.