]> git.pld-linux.org Git - packages/libvpx.git/blame - libvpx.spec
add ppc/ppc64 targets. enable shared does not work on generic target
[packages/libvpx.git] / libvpx.spec
CommitLineData
c9ee805b
ER
1#
2# Conditional build:
d5d82930 3%bcond_without asm # x86 assembler
3c828a1d 4
bccc9f86 5Summary: VP8, a high-quality video codec
d5d82930 6Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
bccc9f86 7Name: libvpx
7fb20346 8Version: 1.1.0
1c3357c1 9Release: 1
bccc9f86
AM
10License: BSD
11Group: Libraries
3c828a1d 12# Source0Download: http://code.google.com/p/webm/downloads/list
1c3357c1 13Source0: https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
7fb20346 14# Source0-md5: 7ae163ac3196c79ec2f0904280078a45
bccc9f86 15URL: http://www.webmproject.org/
13542557 16BuildRequires: /usr/bin/php
a28e5963 17BuildRequires: doxygen
47f853c3 18BuildRequires: php-common >= 4:5.0.0
13542557 19BuildRequires: php-pcre
9026bd8c 20BuildRequires: sed >= 4.0
d5d82930 21%ifarch %{ix86} %{x8664}
3c828a1d 22%{?with_asm:BuildRequires: yasm >= 0.8}
d5d82930 23%endif
bccc9f86
AM
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
e1331b3a
ER
26%define generic_target generic-gnu
27%define vpxtarget %{generic_target}
28%ifarch %{x8664}
29%define vpxtarget x86_64-linux-gcc
30%endif
31%ifarch %{ix86}
32%define vpxtarget x86-linux-gcc
33%endif
34%ifarch ppc
35%define vpxtarget ppc32-linux-gcc
36%endif
37%ifarch ppc64
38%define vpxtarget ppc64-linux-gcc
39%endif
40
bccc9f86
AM
41%description
42VP8, a high-quality video codec.
43
d5d82930
JB
44%description -l pl.UTF-8
45VP8 - kodek obrazu wysokiej jakości.
46
bccc9f86 47%package devel
d5d82930
JB
48Summary: Header files for libvpx
49Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
bccc9f86 50Group: Development/Libraries
d5d82930 51Requires: %{name} = %{version}-%{release}
bccc9f86
AM
52
53%description devel
d5d82930
JB
54Header files for libvpx library.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe biblioteki libvpx.
bccc9f86
AM
58
59%package static
60Summary: Static libvpx library
d5d82930 61Summary(pl.UTF-8): Statyczna biblioteka libvpx
bccc9f86 62Group: Development/Libraries
d5d82930 63Requires: %{name}-devel = %{version}-%{release}
bccc9f86
AM
64
65%description static
66Static libvpx library.
67
d5d82930
JB
68%description static -l pl.UTF-8
69Statyczna biblioteka libvpx.
70
bccc9f86 71%prep
1c3357c1 72%setup -q -n %{name}-v%{version}
bccc9f86
AM
73
74%build
d5d82930
JB
75install -d obj
76cd obj
bccc9f86 77# not autoconf configure
d5d82930 78CFLAGS="%{rpmcflags} %{rpmcppflags}" \
bccc9f86 79../configure \
7b991969 80%if %{with asm}
dcde509e 81 --as=yasm \
e1331b3a
ER
82 --target=%{vpxtarget} \
83%if "%{vpxtarget}" != "%{generic_target}"
6c7c0f8b 84 --enable-shared \
e1331b3a 85%endif
0257ab6e 86 --disable-optimizations \
bccc9f86
AM
87 --enable-vp8 \
88 --enable-postproc \
89 --enable-runtime-cpu-detect
0257ab6e 90
0257ab6e 91%{__make} verbose=true target=libs \
938aec6f 92 HAVE_GNU_STRIP=no \
6c7c0f8b 93 CC="%{__cc}" \
7fb20346 94 LD="%{__cc}" \
6c7c0f8b 95 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
96
97%{__make} verbose=true target=examples \
6c7c0f8b 98 CC="%{__cc}" \
7fb20346 99 LD="%{__cc}" \
dcde509e 100 LDFLAGS="%{rpmldflags} -L."
0257ab6e
AM
101%{__make} verbose=true target=docs
102
bccc9f86
AM
103%install
104rm -rf $RPM_BUILD_ROOT
464fefd2 105install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
0257ab6e 106
6c7c0f8b 107%{__make} -C obj verbose=true install \
938aec6f
ER
108 LIBSUBDIR=%{_lib} \
109 DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
0257ab6e 110
7fb20346 111%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.1
9026bd8c
JB
112
113# adjust prefix and libdir
3c828a1d 114%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%files
123%defattr(644,root,root,755)
d5d82930 124%doc AUTHORS CHANGELOG LICENSE PATENTS README
1c3357c1 125%attr(755,root,root) %{_bindir}/vp8_scalable_patterns
d5d82930
JB
126%attr(755,root,root) %{_bindir}/vpxdec
127%attr(755,root,root) %{_bindir}/vpxenc
47f853c3 128%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
1c3357c1 129%attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
bccc9f86
AM
130
131%files devel
132%defattr(644,root,root,755)
47f853c3 133%attr(755,root,root) %{_libdir}/libvpx.so
464fefd2 134%{_includedir}/vpx
9026bd8c 135%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
136
137%files static
138%defattr(644,root,root,755)
0257ab6e 139%{_libdir}/libvpx.a
This page took 0.103304 seconds and 4 git commands to generate.