]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blame - libtorrent-rasterbar.spec
- release 2
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
CommitLineData
2e00201e
ZU
1Summary: A C++ BitTorrent library
2Summary(hu.UTF-8): C++ BitTorrent könyvtár
3Summary(pl.UTF-8): Biblioteka BitTorrenta napisana w C++
4Name: libtorrent-rasterbar
5Version: 0.13.1
3643fce7 6Release: 2
2e00201e
ZU
7License: BSD
8Group: Libraries
9Source0: http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
10# Source0-md5: 9d6b112fedc5861402647ff72e95dba0
11Patch0: %{name}-examples.patch
12## fix the build error with newest boost -- it will be fixed in the next libtorrent version
13Patch1: %{name}-boost.patch
14Patch2: %{name}-condition.patch
15URL: http://www.rasterbar.com/products/libtorrent/
16BuildRequires: autoconf
17BuildRequires: automake
18BuildRequires: boost-devel >= 1.35.0
19BuildRequires: libstdc++-devel
20BuildRequires: sed >= 4.0
21BuildRequires: zlib-devel
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25libtorrent-rasterbar is a C++ library that aims to be a good
26alternative to all the other BitTorrent implementations around. It is
27a library and not a full featured client, although it comes with a
28working example client.
29
30Its main goals are to be very efficient (in terms of CPU and memory
31usage) as well as being very easy to use both as a user and developer.
32
33%description -l hu.UTF-8
34libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
35kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
36egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
37működő példa-klienst.
38
39A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
40könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
41
42%description -l pl.UTF-8
43libtorrent-rasterbar jest biblioteką napisaną w C++ która aspiruje do
44bycia dobrą alternatywą dla wszystkich innych implementacji
45BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, jakkolwiek
46pakiet zawiera działającego przykładowego klienta.
47
48Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
49wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
50dla użytkownika, jak i programisty.
51
52%package devel
53Summary: Header files for %{name} library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
55License: BSD, zlib/libpng License, Boost Software License
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58Requires: boost-devel
59Requires: openssl-devel
60## Same pkgconfig file, and unsuffixed shared library symlink.:(
61Conflicts: libtorrent-devel
62
63%description devel
64The libtorrent-rasterbar-devel package contains libraries and header
65files for developing applications that use libtorrent-rasterbar.
66
67The various source and header files included in this package are
68licensed under the revised BSD, zlib/libpng, and Boost Public
69licenses.
70
71%description devel -l hu.UTF-8
72A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
73fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
74alkalmazásokat fejleszthetsz.
75
76%description devel -l pl.UTF-8
77Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
78rozwijania aplikacji używających libtorrent-rasterbar.
79
80Różne pliki źródłowe i nagłówki dostarcozne z tym pakietem są
81licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public.
82
83%package static
84Summary: Static %{name} library
85Summary(pl.UTF-8): Statyczna biblioteka %{name}
86Group: Development/Libraries
87Requires: %{name}-devel = %{version}-%{release}
88
89%description static
90Static libtorrent-rasterbar library.
91
92%description static -l hu.UTF-8
93Statikus libtorrent-rasterbar könyvtár.
94
95%description static -l pl.UTF-8
96Statyczna biblioteka libtorrent-rasterbar.
97
98%prep
99%setup -q
100%patch0 -p1
101%patch1 -p1
102%patch2 -p1
103## Some of the sources and docs are executable, which makes rpmlint against
104## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
105find src docs -type f | xargs chmod a-x
106find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
107## The RST files are the sources used to create the final HTML files; and are
108## not needed.
109rm -f docs/*.rst
2e00201e
ZU
110
111%build
112%{__aclocal} -I m4
113%{__libtoolize}
114%{__autoconf}
115%{__automake}
116%configure \
117 --with-boost-system=boost_system\
118 --with-boost-date-time=boost_date_time\
119 --with-boost-filesystem=boost_filesystem\
120 --with-boost-thread=boost_thread\
121 --with-boost-regex=boost_regex\
122 --with-boost-program-options=boost_program_options\
123 --with-{asio,zlib}=system
124
086e6387 125%{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
2e00201e
ZU
126
127%install
128rm -rf $RPM_BUILD_ROOT
129## Ensure that we preserve our timestamps properly.
130#export CPPROG="%{__cp} -p"
131#make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
132%{__make} install \
133 DESTDIR=$RPM_BUILD_ROOT
134
135## Do the renaming due to the somewhat limited %{_bindir} namespace.
136rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
143
144%files
145%defattr(644,root,root,755)
146%doc AUTHORS ChangeLog COPYING README
147%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
148
149%files devel
150%defattr(644,root,root,755)
151%doc docs/
152%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
153%{_libdir}/libtorrent-rasterbar.la
154%{_pkgconfigdir}/libtorrent-rasterbar.pc
155%{_includedir}/libtorrent
156
157%files static
158%defattr(644,root,root,755)
159%{_libdir}/libtorrent-rasterbar.a
This page took 0.167433 seconds and 4 git commands to generate.