]> git.pld-linux.org Git - packages/libimobiledevice.git/blame - libimobiledevice.spec
- up to 1.1.4
[packages/libimobiledevice.git] / libimobiledevice.spec
CommitLineData
e229af96
ER
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
42e766e1
ER
4%bcond_without cython # build with Cython based Python bindings
5%bcond_without openssl # build with openssl for SSL support
6%bcond_with gnutls # build with GnuTLS for SSL support
7
8%if %{with gnutls}
9%undefine with_openssl
10%endif
e229af96 11
6b6a2331
MB
12Summary: Library for connecting to mobile devices
13Summary(pl.UTF-8): Biblioteka do łączenia się z urządzeniami mobilnymi
14Name: libimobiledevice
d5146124 15Version: 1.1.4
42e766e1 16Release: 1
6b6a2331
MB
17License: LGPL v2+
18Group: Libraries
5f4040a2 19Source0: http://www.libimobiledevice.org/downloads/%{name}-%{version}.tar.bz2
d5146124 20# Source0-md5: 3f28cbc6a2e30d34685049c0abde5183
5f4040a2 21URL: http://www.libimobiledevice.org/
6b6a2331
MB
22BuildRequires: autoconf >= 2.61
23BuildRequires: automake
42e766e1 24%{?with_gnutls:BuildRequires: gnutls-devel >= 2.2.0}
6b6a2331 25BuildRequires: libgcrypt-devel
42e766e1 26BuildRequires: libplist-devel >= 1.8
7e9f6afa 27BuildRequires: libstdc++-devel
42e766e1 28%{?with_gnutls:BuildRequires: libtasn1-devel >= 1.1}
6b6a2331 29BuildRequires: libtool
42e766e1 30%{?with_openssl:BuildRequires: openssl-devel >= 0.9.8}
6b6a2331 31BuildRequires: pkgconfig
42e766e1 32%{?with_cython:BuildRequires: python-Cython >= 0.13.0}
7e9f6afa 33BuildRequires: python-devel
34BuildRequires: python-modules
35BuildRequires: rpm-pythonprov
d5146124 36BuildRequires: usbmuxd-devel >= 1.0.8
6b6a2331
MB
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40libimobiledevice is a library for connecting to mobile devices.
41
42%description -l pl.UTF-8
43libimobiledevice jest biblioteką do łączenia się z urządzeniami
44mobilnymi.
45
46%package devel
47Summary: Header files for libimobiledevice library
48Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libimobiledevice
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
42e766e1
ER
51%{?with_gnutls:Requires: gnutls-devel >= 2.2.0}
52Requires: libplist-devel >= 1.8
53%{?with_gnutls:Requires: libtasn1-devel >= 1.1}
54%{?with_openssl:Requires: openssl-devel >= 0.9.8}
d5146124 55Requires: usbmuxd-devel >= 1.0.8
6b6a2331
MB
56
57%description devel
58Header files for libimobiledevice library.
59
60%description devel -l pl.UTF-8
61Pliki nagłówkowe biblioteki libimobiledevice.
62
63%package static
64Summary: Static libimobiledevice library
65Summary(pl.UTF-8): Statyczna biblioteka libimobiledevice
66Group: Development/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68
69%description static
70Static libimobiledevice library.
71
72%description static -l pl.UTF-8
73Statyczna biblioteka libimobiledevice.
74
75%package -n python-imobiledevice
76Summary: libimobiledevice Python bindings
77Summary(pl.UTF-8): Wiązania libimobiledevice dla Pythona
78Group: Development/Languages/Python
79Requires: %{name} = %{version}-%{release}
80
81%description -n python-imobiledevice
82libimobiledevice Python bindings.
83
84%description -n python-imobiledevice -l pl.UTF-8
85Wiązania libimobiledevice dla Pythona.
86
87%prep
88%setup -q
89
90%build
91%{__libtoolize}
92%{__aclocal} -I m4
93%{__autoconf}
94%{__autoheader}
95%{__automake}
5f4040a2 96%configure \
20b1646b 97 %{!?with_static_libs:--disable-static} \
42e766e1
ER
98 %{!?with_cython:--without-cython} \
99 %{!?with_openssl:--disable-openssl} \
5f4040a2 100 --disable-silent-rules
6b6a2331
MB
101%{__make}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
108
42e766e1 109%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
c4321516 110%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
6b6a2331
MB
111
112%py_comp $RPM_BUILD_ROOT%{py_sitedir}
113%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
114%py_postclean
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%files
123%defattr(644,root,root,755)
124%doc AUTHORS NEWS README
6b6a2331 125%attr(755,root,root) %{_bindir}/idevicebackup
481c45a6
ER
126%attr(755,root,root) %{_bindir}/idevicebackup2
127%attr(755,root,root) %{_bindir}/idevicedate
d4da4e3f 128%attr(755,root,root) %{_bindir}/ideviceenterrecovery
e229af96 129%attr(755,root,root) %{_bindir}/idevice_id
5f4040a2 130%attr(755,root,root) %{_bindir}/ideviceimagemounter
6b6a2331 131%attr(755,root,root) %{_bindir}/ideviceinfo
e229af96 132%attr(755,root,root) %{_bindir}/idevicepair
5f4040a2 133%attr(755,root,root) %{_bindir}/idevicescreenshot
6b6a2331
MB
134%attr(755,root,root) %{_bindir}/idevicesyslog
135%attr(755,root,root) %{_libdir}/libimobiledevice.so.*.*.*
42e766e1 136%attr(755,root,root) %ghost %{_libdir}/libimobiledevice.so.3
5f4040a2 137%{_mandir}/man1/idevicebackup.1*
481c45a6
ER
138%{_mandir}/man1/idevicebackup2.1*
139%{_mandir}/man1/idevicedate.1*
140%{_mandir}/man1/ideviceenterrecovery.1*
d4da4e3f 141%{_mandir}/man1/idevice_id.1*
5f4040a2
MB
142%{_mandir}/man1/ideviceimagemounter.1*
143%{_mandir}/man1/ideviceinfo.1*
481c45a6 144%{_mandir}/man1/idevicepair.1*
5f4040a2
MB
145%{_mandir}/man1/idevicescreenshot.1*
146%{_mandir}/man1/idevicesyslog.1*
6b6a2331
MB
147
148%files devel
149%defattr(644,root,root,755)
150%doc docs/html/
151%attr(755,root,root) %{_libdir}/libimobiledevice.so
6b6a2331
MB
152%{_includedir}/libimobiledevice
153%{_pkgconfigdir}/libimobiledevice-1.0.pc
154
e229af96 155%if %{with static_libs}
6b6a2331
MB
156%files static
157%defattr(644,root,root,755)
158%{_libdir}/libimobiledevice.a
e229af96 159%endif
6b6a2331 160
42e766e1 161%if %{with cython}
6b6a2331
MB
162%files -n python-imobiledevice
163%defattr(644,root,root,755)
42e766e1
ER
164%attr(755,root,root) %{py_sitedir}/imobiledevice.so
165%endif
This page took 0.118054 seconds and 4 git commands to generate.