]> git.pld-linux.org Git - packages/libglvnd.git/blame - libglvnd.spec
up to 1.3.1
[packages/libglvnd.git] / libglvnd.spec
CommitLineData
778c937e
JB
1#
2# Conditional build:
3%bcond_with default_gl # build dispatcher as default libGL/libGLX/libGLESv1_CM/libGLESv2 provider
4#
5Summary: Vendor-neutral OpenGL dispatch library
6Summary(pl.UTF-8): Niezależna od producenta biblioteka przekazująca wywołania OpenGL
7Name: libglvnd
627707dc 8Version: 1.3.1
778c937e
JB
9Release: 1
10License: MIT-like
11Group: Libraries
12#Source0Download: https://github.com/NVIDIA/libglvnd/releases
627707dc
JP
13Source0: https://github.com/NVIDIA/libglvnd/archive/v%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: f413526865e776688f3c0e031a7a71c1
778c937e
JB
15URL: https://github.com/NVIDIA/libglvnd
16BuildRequires: autoconf >= 2.63
17BuildRequires: automake >= 1:1.11
18BuildRequires: libtool
f41190f9 19BuildRequires: pkgconfig
dd91cdd5
JB
20BuildRequires: python >= 1:2.7
21BuildRequires: python-modules >= 1:2.7
778c937e
JB
22BuildRequires: xorg-lib-libX11-devel
23BuildRequires: xorg-lib-libXext-devel
24BuildRequires: xorg-proto-glproto-devel
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%if %{with default_gl}
aa879125 28%define gl_incdir %{_includedir}
778c937e 29%define gl_libdir %{_libdir}
aa879125
JB
30%define gl_pcdir %{_pkgconfigdir}
31%define solink %ghost
778c937e 32%else
aa879125 33%define gl_incdir %{_includedir}/%{name}
778c937e 34%define gl_libdir %{_libdir}/%{name}
aa879125
JB
35%define gl_pcdir %{_libdir}/%{name}/pkgconfig
36%define solink %{nil}
778c937e
JB
37%define noautoprov_files %{_libdir}/%{name}
38%endif
74413a1d
JB
39# _glapi_tls_Current symbol
40%define skip_post_check_so libOpenGL.so.* libGL.so.* libGLESv1_CM.so.* libGLESv2.so.*
778c937e
JB
41
42%description
43This is a work-in-progress implementation of the vendor-neutral
44dispatch layer for arbitrating OpenGL API calls between multiple
45vendors on a per-screen basis, as described by Andy Ritger's OpenGL
46ABI proposal:
47<https://github.com/aritger/linux-opengl-abi-proposal/blob/master/linux-opengl-abi-proposal.txt>.
48
49Currently, only the GLX window-system API and OpenGL are supported,
50but in the future this library may support EGL and OpenGL ES as well.
51
52%description -l pl.UTF-8
53Ten pakiet to (będąca w trakcie tworzenia) implementacja warstwy
54przekazującej wywołania dowolnych wywołań API OpenGL między różnymi
55producentami w zależności od ekranu, zgodnie z propozycją opisaną
56przez Andy Ritgera:
57<https://github.com/aritger/linux-opengl-abi-proposal/blob/master/linux-opengl-abi-proposal.txt>.
58
59Obecnie obsługiwane jest tylko API systemu okienek GLX oraz OpenGL, w
60przyszłości biblioteka może obsługiwać także EGL i OpenGL ES.
61
62%package devel
63Summary: Header files for libglvnd interface
64Summary(pl.UTF-8): Pliki nagłówkowe interfejsu libglvnd
65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67# <GL/gl.h>
68Requires: OpenGL-devel
69# <GL/glx.h>
70Requires: OpenGL-GLX-devel
71
72%description devel
73Header files for libglvnd interface.
74
75%description devel -l pl.UTF-8
76Pliki nagłówkowe interfejsu libglvnd.
77
aa879125
JB
78%package khrplatform-devel
79Summary: Khronos platform header file
80Summary(pl.UTF-8): Plik nagłówkowy platformy Khronos
81Group: Development/Libraries
82
83%description khrplatform-devel
84Khronos platform header file.
85
86%description khrplatform-devel -l pl.UTF-8
87Plik nagłówkowy platformy Khronos.
88
74413a1d
JB
89%package libEGL
90Summary: EGL interface glvnd libraries
91Summary(pl.UTF-8): Biblioteki glvnd interfejsu EGL
92Group: Libraries
93Requires: %{name} = %{version}-%{release}
94
95%description libEGL
96EGL interface glvnd libraries.
97
98%description libEGL -l pl.UTF-8
99Biblioteki glvnd interfejsu EGL.
100
101%package libEGL-devel
102Summary: Development files for glvnd EGL interface
103Summary(pl.UTF-8): Pliki programistyczne glvnd interfejsu EGL
104Group: Development/Libraries
105Requires: %{name}-libEGL = %{version}-%{release}
aa879125
JB
106Requires: %{name}-khrplatform-devel = %{version}-%{release}
107%{?with_default_gl:Provides: EGL-devel = 1.5}
74413a1d
JB
108
109%description libEGL-devel
110Development files for glvnd EGL interface.
111
112%description libEGL-devel -l pl.UTF-8
113Pliki programistyczne glvnd interfejsu EGL.
114
778c937e
JB
115%package libGL
116Summary: OpenGL 4.x interface glvnd libraries
117Summary(pl.UTF-8): Biblioteki glvnd interfejsu OpenGL 4.x
118Group: Libraries
119Requires: %{name} = %{version}-%{release}
120
121%description libGL
122OpenGL 4.x interface glvnd libraries.
123
124%description libGL -l pl.UTF-8
125Biblioteki glvnd interfejsu OpenGL 4.x.
126
127%package libGL-devel
128Summary: Development files for glvnd OpenGL 4.x interface
129Summary(pl.UTF-8): Pliki programistyczne glvnd interfejsu OpenGL 4.x
130Group: Development/Libraries
aa879125 131Requires: %{name}-khrplatform-devel = %{version}-%{release}
778c937e 132Requires: %{name}-libGL = %{version}-%{release}
aa879125
JB
133%if %{with default_gl}
134Provides: OpenGL-devel = 4.6
135Provides: OpenGL-GLX-devel = 1.4
136%endif
778c937e
JB
137
138%description libGL-devel
139Development files for glvnd OpenGL 4.x interface.
140
141%description libGL-devel -l pl.UTF-8
142Pliki programistyczne glvnd interfejsu OpenGL 4.x.
143
144%package libGLES
145Summary: OpenGL ES 1, 2, 3 interface glvnd libraries
146Summary(pl.UTF-8): Biblioteki glvnd interfejsów OpenGL ES 1, 2, 3
147Group: Libraries
148Requires: %{name} = %{version}-%{release}
149
150%description libGLES
151OpenGL ES 1, 2, 3 interface glvnd libraries.
152
153%description libGLES -l pl.UTF-8
154Biblioteki glvnd interfejsów OpenGL ES 1, 2, 3.
155
156%package libGLES-devel
157Summary: Development files for glvnd OpenGL ES 1, 2, 3 interfaces
158Summary(pl.UTF-8): Pliki programistyczne glvnd interfejsów OpenGL ES 1, 2, 3
159Group: Development/Libraries
aa879125 160Requires: %{name}-khrplatform-devel = %{version}-%{release}
778c937e 161Requires: %{name}-libGLES = %{version}-%{release}
aa879125
JB
162%if %{with default_gl}
163Provides: OpenGLES-devel = 3.2
164Provides: OpenGLESv1-devel = 1.1
165Provides: OpenGLESv2-devel = 2.0
166Provides: OpenGLESv3-devel = 3.2
778c937e
JB
167%endif
168
169%description libGLES-devel
170Development files for glvnd OpenGL ES 1, 2, 3 interfaces.
171
172%description libGLES-devel -l pl.UTF-8
173Pliki programistyczne glvnd interfejsów OpenGL ES 1, 2, 3.
174
175%prep
176%setup -q
177
178%build
179%{__libtoolize}
180%{__aclocal} -I m4
181%{__autoconf}
182%{__autoheader}
183%{__automake}
184%configure \
ab280d27 185 CFLAGS="%{rpmcflags} -O1" \
778c937e
JB
186 --disable-silent-rules \
187 %{!?with_static_libs:--disable-static}
188%{__make}
189
190%install
191rm -rf $RPM_BUILD_ROOT
192
193%{__make} install \
194 DESTDIR=$RPM_BUILD_ROOT
195
196%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
197
198%if %{without default_gl}
aa879125 199install -d $RPM_BUILD_ROOT{%{gl_libdir},%{gl_incdir},%{gl_pcdir}}
74413a1d 200%{__mv} $RPM_BUILD_ROOT%{_libdir}/lib{EGL,GL,GLESv1_CM,GLESv2}.* $RPM_BUILD_ROOT%{gl_libdir}
aa879125
JB
201%{__mv} $RPM_BUILD_ROOT%{_includedir}/{EGL,GL,GLES,GLES2,GLES3,KHR} $RPM_BUILD_ROOT%{gl_incdir}
202%{__mv} $RPM_BUILD_ROOT%{_pkgconfigdir}/{egl,gl,glesv1_cm,glesv2}.pc $RPM_BUILD_ROOT%{gl_pcdir}
778c937e
JB
203%endif
204
aad86521
JP
205install -d $RPM_BUILD_ROOT%{_datadir}/glvnd/egl_vendor.d
206
778c937e
JB
207%clean
208rm -rf $RPM_BUILD_ROOT
209
210%post -p /sbin/ldconfig
211%postun -p /sbin/ldconfig
212
74413a1d
JB
213%if %{with default_gl}
214%post libEGL -p /sbin/ldconfig
215%postun libEGL -p /sbin/ldconfig
216
778c937e
JB
217%post libGL -p /sbin/ldconfig
218%postun libGL -p /sbin/ldconfig
219
220%post libGLES -p /sbin/ldconfig
221%postun libGLES -p /sbin/ldconfig
74413a1d 222%endif
778c937e
JB
223
224%files
225%defattr(644,root,root,755)
226%doc README.md
227%attr(755,root,root) %{_libdir}/libGLdispatch.so.*.*.*
228%attr(755,root,root) %ghost %{_libdir}/libGLdispatch.so.0
229%if %{without default_gl}
aa879125 230%dir %{gl_libdir}
778c937e 231%endif
aad86521 232%dir %{_datadir}/glvnd
778c937e
JB
233
234%files devel
235%defattr(644,root,root,755)
236%attr(755,root,root) %{_libdir}/libGLdispatch.so
237%{_includedir}/glvnd
238%{_pkgconfigdir}/libglvnd.pc
239
aa879125
JB
240%files khrplatform-devel
241%defattr(644,root,root,755)
242%if %{without default_gl}
243%dir %{gl_incdir}
244%dir %{gl_pcdir}
245%endif
246%{gl_incdir}/KHR
247
74413a1d
JB
248%files libEGL
249%defattr(644,root,root,755)
74413a1d 250%attr(755,root,root) %{gl_libdir}/libEGL.so.*.*.*
aa879125 251%attr(755,root,root) %solink %{gl_libdir}/libEGL.so.1
aad86521 252%dir %{_datadir}/glvnd/egl_vendor.d
74413a1d
JB
253
254%files libEGL-devel
255%defattr(644,root,root,755)
256%attr(755,root,root) %{gl_libdir}/libEGL.so
aa879125
JB
257%{gl_incdir}/EGL
258%{gl_pcdir}/egl.pc
74413a1d 259
778c937e
JB
260%files libGL
261%defattr(644,root,root,755)
778c937e 262%attr(755,root,root) %{gl_libdir}/libGL.so.*.*.*
aa879125 263%attr(755,root,root) %solink %{gl_libdir}/libGL.so.1
778c937e 264%attr(755,root,root) %{gl_libdir}/libGL.so
778c937e
JB
265
266%attr(755,root,root) %{_libdir}/libGLX.so.*.*.*
267%attr(755,root,root) %ghost %{_libdir}/libGLX.so.0
268
269%attr(755,root,root) %{_libdir}/libOpenGL.so.*.*.*
270%attr(755,root,root) %ghost %{_libdir}/libOpenGL.so.0
271
272%files libGL-devel
273%defattr(644,root,root,755)
274%attr(755,root,root) %{_libdir}/libGLX.so
275%attr(755,root,root) %{_libdir}/libOpenGL.so
aa879125
JB
276%{gl_incdir}/GL
277%{gl_pcdir}/gl.pc
278%{_pkgconfigdir}/glx.pc
279%{_pkgconfigdir}/opengl.pc
778c937e
JB
280
281%files libGLES
282%defattr(644,root,root,755)
778c937e 283%attr(755,root,root) %{gl_libdir}/libGLESv1_CM.so.*.*.*
aa879125 284%attr(755,root,root) %solink %{gl_libdir}/libGLESv1_CM.so.1
778c937e 285%attr(755,root,root) %{gl_libdir}/libGLESv2.so.*.*.*
aa879125 286%attr(755,root,root) %solink %{gl_libdir}/libGLESv2.so.2
778c937e
JB
287
288%files libGLES-devel
289%defattr(644,root,root,755)
290%attr(755,root,root) %{gl_libdir}/libGLESv1_CM.so
291%attr(755,root,root) %{gl_libdir}/libGLESv2.so
aa879125
JB
292%{gl_incdir}/GLES
293%{gl_incdir}/GLES2
294%{gl_incdir}/GLES3
295%{gl_pcdir}/glesv1_cm.pc
296%{gl_pcdir}/glesv2.pc
This page took 0.098623 seconds and 4 git commands to generate.