]> git.pld-linux.org Git - packages/libgda3.git/blame - libgda3.spec
- added oracle provider, cleaned up/unified with libgda[45]
[packages/libgda3.git] / libgda3.spec
CommitLineData
6698215c 1# TODO: ibmdb2 provider
b4cae6aa 2#
b4cae6aa 3# Conditional build:
6698215c
JB
4%bcond_without apidocs # API documentation build
5%bcond_without static_libs # static libraries build
b4cae6aa 6%bcond_with gamin # use gamin instead of fam library
6698215c
JB
7%bcond_without gnomevfs # gnome-vfs support
8%bcond_without gnome # (convenience alias for gnomevfs)
6f64b75f 9# - database plugins:
6698215c
JB
10%bcond_without firebird # Firebird plugin
11%bcond_with freetds # FreeTDS plugin
12%bcond_without ldap # LDAP plugin
13%bcond_without mdb # MDB plugin
14%bcond_without mysql # MySQL plugin
15%bcond_with oci # Oracle DB plugin
16%bcond_without odbc # unixODBC plugin
17%bcond_without pgsql # PostgreSQL plugin
18%bcond_without sqlite # SQLite plugin
19%bcond_without sybase # sybase plugin
20%bcond_without xbase # xbase plugin
b4cae6aa 21#
6f64b75f
JB
22%if %{without gnome}
23%undefine with_gnomevfs
24%endif
b4cae6aa
JB
25%ifnarch %{ix86} sparc sparcv9 alpha
26%undefine with_firebird
27%endif
28Summary: GNU Data Access library
6f64b75f 29Summary(pl.UTF-8): Biblioteka GNU Data Access
b4cae6aa 30Name: libgda3
ed4aa3ff 31Version: 3.1.5
d9043a3c 32Release: 18
2c13119c 33License: LGPL v2+/GPL v2+
6f64b75f 34Group: Libraries
6698215c 35Source0: http://ftp.gnome.org/pub/GNOME/sources/libgda/3.1/libgda-%{version}.tar.bz2
ed4aa3ff 36# Source0-md5: eb7da5286a112e7cff3111c89fba4456
e9a8c49e 37Patch0: %{name}-configure.patch
4d1d7fc7 38Patch1: %{name}-am.patch
af5560b9 39Patch2: glib232.patch
00eee7f2 40Patch3: format-security.patch
d9153d00 41Patch4: mdb-0.7.patch
fd278e0c 42URL: http://www.gnome-db.org/
b4cae6aa
JB
43%{?with_firebird:BuildRequires: Firebird-devel}
44BuildRequires: autoconf >= 2.59
45BuildRequires: automake >= 1:1.8
46BuildRequires: bison
47BuildRequires: db-devel
169c4908 48BuildRequires: docbook-dtd412-xml
b4cae6aa
JB
49%{!?with_gamin:BuildRequires: fam-devel}
50BuildRequires: flex
687a3c3a 51%{?with_freetds:BuildRequires: freetds-devel = 0.64}
169c4908 52%{?with_sybase:BuildRequires: freetds-devel >= 0.82}
cdc6be99 53%{?with_gamin:BuildRequires: gamin-devel >= 0.1.8}
169c4908 54BuildRequires: gettext-devel
b4cae6aa
JB
55BuildRequires: glib2-devel >= 1:2.12.0
56BuildRequires: gnome-common >= 2.12.0
69656563 57%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.20}
b4cae6aa 58BuildRequires: gtk-doc >= 1.6
6f64b75f
JB
59BuildRequires: intltool >= 0.35.5
60BuildRequires: libgcrypt-devel >= 1.1.42
b4cae6aa 61BuildRequires: libtool
6f64b75f 62BuildRequires: libxml2-devel >= 1:2.6.26
b4cae6aa 63BuildRequires: libxslt-devel >= 1.1.17
69628b45 64%{?with_mdb:BuildRequires: mdbtools-devel >= 0.6}
b4cae6aa 65%{?with_mysql:BuildRequires: mysql-devel}
ae0d41e4 66%{?with_ldap:BuildRequires: openldap-devel >= 2.4.6}
6698215c 67%{?with_oci:BuildRequires: oracle-instantclient-devel}
b4cae6aa 68BuildRequires: perl-base
169c4908 69BuildRequires: pkgconfig
b4cae6aa
JB
70BuildRequires: popt-devel
71%{?with_pgsql:BuildRequires: postgresql-devel}
72BuildRequires: readline-devel >= 5.0
73BuildRequires: rpmbuild(macros) >= 1.213
5d9ee9dd 74%{?with_sqlite:BuildRequires: sqlite3-devel >= 3.5.0-2}
b4cae6aa
JB
75%{?with_odbc:BuildRequires: unixODBC-devel}
76%{?with_xbase:BuildRequires: xbase-devel >= 2.0.0}
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
6698215c
JB
79%define libgdadir libgda-3.0
80%define providersdir %{_libdir}/%{libgdadir}/providers
b4cae6aa
JB
81
82%description
83GNU Data Access is an attempt to provide uniform access to different
84kinds of data sources (databases, information servers, mail spools,
85etc). It is a complete architecture that provides all you need to
86access your data.
87
88libgda was part of the GNOME-DB project but has been separated from it
89to allow non-GNOME applications to be developed based on it.
90
91%description -l pl.UTF-8
92GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
93źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
94itp.). Jest kompletną architekturą dostarczającą wszystko, czego
95potrzebujesz do dostępu do danych.
96
97libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
98pozwolić na używanie przez niegnomowe aplikacje.
99
100%package devel
6f64b75f
JB
101Summary: GNU Data Access development files
102Summary(pl.UTF-8): Pliki programistyczne biblioteki GNU Data Access
b4cae6aa
JB
103Group: Development/Libraries
104Requires: %{name} = %{version}-%{release}
105%{!?with_gamin:Requires: fam-devel}
cdc6be99 106%{?with_gamin:Requires: gamin-devel >= 0.1.8}
b4cae6aa 107Requires: glib2-devel >= 1:2.12.0
69656563 108%{?with_gnomevfs:Requires: gnome-vfs2-devel >= 2.20}
b4cae6aa 109Requires: gtk-doc-common
6f64b75f 110Requires: libgcrypt-devel >= 1.1.42
b4cae6aa
JB
111Requires: libxml2-devel >= 1:2.6.26
112Requires: libxslt-devel >= 1.1.17
113Obsoletes: libgda0-devel
114
115%description devel
116GNU Data Access is an attempt to provide uniform access to different
117kinds of data sources (databases, information servers, mail spools,
118etc). It is a complete architecture that provides all you need to
119access your data. This subpackage contains development files.
120
121%description devel -l pl.UTF-8
122GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
123źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
124itp.). Jest kompletną architekturą dostarczającą wszystko, czego
125potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
126programistów używających libgda.
127
128%package static
129Summary: GNU Data Access static libraries
6f64b75f 130Summary(pl.UTF-8): Statyczne biblioteki GNU Data Access
b4cae6aa
JB
131Group: Development/Libraries
132Requires: %{name}-devel = %{version}-%{release}
133
134%description static
135GNU Data Access static libraries.
136
137%description static -l pl.UTF-8
138Statyczne biblioteki GNU Data Access.
139
6698215c
JB
140%package apidocs
141Summary: GNU Data Access API documentation
142Summary(pl.UTF-8): Dokumentacja API GNU Data Access
143Group: Documentation
144Requires: gtk-doc-common
145
146%description apidocs
147GNU Data Access API documentation.
148
149%description apidocs -l pl.UTF-8
150Dokumentacja API GNU Data Access.
151
b4cae6aa
JB
152%package provider-db
153Summary: GDA Berkeley DB provider
6f64b75f
JB
154Summary(pl.UTF-8): Źródło danych Berkeley DB dla GDA
155Group: Libraries
b4cae6aa
JB
156Requires: %{name} = %{version}-%{release}
157
158%description provider-db
159This package contains the GDA Berkeley DB provider.
160
161%description provider-db -l pl.UTF-8
6698215c 162Pakiet dostarczający dane z Berkeley DB dla GDA.
b4cae6aa
JB
163
164%package provider-firebird
165Summary: GDA Firebird provider
6f64b75f
JB
166Summary(pl.UTF-8): Źródło danych Firebird dla GDA
167Group: Libraries
b4cae6aa
JB
168Requires: %{name} = %{version}-%{release}
169
170%description provider-firebird
171This package contains the GDA Firebird provider.
172
173%description provider-firebird -l pl.UTF-8
174Pakiet dostarczający dane z Firebird dla GDA.
175
176%package provider-freetds
177Summary: GDA FreeTDS provider
6f64b75f
JB
178Summary(pl.UTF-8): Źródło danych FreeTDS dla GDA
179Group: Libraries
b4cae6aa
JB
180Requires: %{name} = %{version}-%{release}
181
182%description provider-freetds
183This package contains the GDA FreeTDS provider.
184
185%description provider-freetds -l pl.UTF-8
186Pakiet dostarczający dane z FreeTDS dla GDA.
187
188%package provider-ldap
189Summary: GDA LDAP provider
6f64b75f
JB
190Summary(pl.UTF-8): Źródło danych LDAP dla GDA
191Group: Libraries
b4cae6aa
JB
192Requires: %{name} = %{version}-%{release}
193
194%description provider-ldap
195This package contains the GDA LDAP provider.
196
197%description provider-ldap -l pl.UTF-8
6698215c 198Pakiet dostarczający dane z LDAP dla GDA.
b4cae6aa
JB
199
200%package provider-mdb
201Summary: GDA MDB provider
6f64b75f
JB
202Summary(pl.UTF-8): Źródło danych MDB
203Group: Libraries
b4cae6aa 204Requires: %{name} = %{version}-%{release}
69628b45 205Requires: mdbtools-libs >= 0.6
b4cae6aa
JB
206
207%description provider-mdb
208This package contains the GDA MDB provider.
209
210%description provider-mdb -l pl.UTF-8
211Pakiet dostarczający dane z MDB dla GDA.
212
213%package provider-mysql
214Summary: GDA MySQL provider
6f64b75f
JB
215Summary(pl.UTF-8): Źródło danych MySQL dla GDA
216Group: Libraries
b4cae6aa
JB
217Requires: %{name} = %{version}-%{release}
218Obsoletes: libgda-mysql0
219
220%description provider-mysql
221This package contains the GDA MySQL provider.
222
223%description provider-mysql -l pl.UTF-8
224Pakiet dostarczający dane z MySQL dla GDA.
225
226%package provider-odbc
227Summary: GDA ODBC provider
6f64b75f
JB
228Summary(pl.UTF-8): Źródło danych ODBC dla GDA
229Group: Libraries
b4cae6aa
JB
230Requires: %{name} = %{version}-%{release}
231
232%description provider-odbc
233This package contains the GDA ODBC provider.
234
235%description provider-odbc -l pl.UTF-8
236Pakiet dostarczający dane z ODBC dla GDA.
237
6698215c
JB
238%package provider-oracle
239Summary: GDA Oracle provider
240Summary(pl.UTF-8): Źródło danych Oracle dla GDA
241Group: Libraries
242Requires: %{name} = %{version}-%{release}
243
244%description provider-oracle
245This package contains the GDA Oracle provider.
246
247%description provider-oracle -l pl.UTF-8
248Pakiet dostarczający dane z bazy Oracle dla GDA.
249
b4cae6aa
JB
250%package provider-postgres
251Summary: GDA PostgreSQL provider
6f64b75f
JB
252Summary(pl.UTF-8): Źródło danych PostgreSQL dla GDA
253Group: Libraries
b4cae6aa
JB
254Requires: %{name} = %{version}-%{release}
255Obsoletes: libgda-postgres0
256
257%description provider-postgres
258This package contains the GDA PostgreSQL provider.
259
260%description provider-postgres -l pl.UTF-8
261Pakiet dostarczający dane z PostgreSQL dla GDA.
262
263%package provider-sqlite
264Summary: GDA SQLite provider
6f64b75f
JB
265Summary(pl.UTF-8): Źródło danych SQLite dla GDA
266Group: Libraries
b4cae6aa
JB
267Requires: %{name} = %{version}-%{release}
268
269%description provider-sqlite
270This package contains the GDA SQLite provider.
271
272%description provider-sqlite -l pl.UTF-8
273Pakiet dostarczający dane z SQLite dla GDA.
274
69656563
JB
275%package provider-sybase
276Summary: GDA Sybase provider
277Summary(pl.UTF-8): Źródło danych Sybase dla GDA
278Group: Libraries
279Requires: %{name} = %{version}-%{release}
280
281%description provider-sybase
282This package contains the GDA Sybase provider.
283
284%description provider-sybase -l pl.UTF-8
285Pakiet dostarczający dane z Sybase dla GDA.
286
b4cae6aa
JB
287%package provider-xbase
288Summary: GDA xBase provider
6f64b75f
JB
289Summary(pl.UTF-8): Źródło danych xBase dla GDA
290Group: Libraries
b4cae6aa
JB
291Requires: %{name} = %{version}-%{release}
292
293%description provider-xbase
294This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
295
296%description provider-xbase -l pl.UTF-8
297Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
298
299%prep
300%setup -q -n libgda-%{version}
e9a8c49e 301%patch0 -p1
4d1d7fc7 302%patch1 -p1
af5560b9 303%patch2 -p1
00eee7f2 304%patch3 -p1
d9153d00 305%patch4 -p1
b4cae6aa 306
6f64b75f 307%if %{without gamin}
6698215c 308%{__sed} -i -e 's#PKG_CHECK_MODULES(GAMIN.*)#have_fam=no#g' configure.in
6f64b75f
JB
309%endif
310%if %{without gnomevfs}
6698215c 311%{__sed} -i -e 's#PKG_CHECK_MODULES(GNOMEVFS.*)#have_gnomevfs=no#g' configure.in
b4cae6aa
JB
312%endif
313
314%build
315CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
316%{__intltoolize}
317%{__libtoolize}
318%{__aclocal}
319%{__autoconf}
320%{__automake}
321%configure \
69656563 322 %{!?with_static_libs:--disable-static} \
6698215c 323 %{?with_apidocs:--enable-gtk-doc} \
b4cae6aa 324 --with-html-dir=%{_gtkdocdir} \
6698215c
JB
325 --with-firebird%{!?with_firebird:=no} \
326 --with-ldap%{!?with_ldap:=no} \
327 --with-mdb%{!?with_mdb:=no} \
328 --with-mysql%{!?with_mysql:=no} \
329 --with-odbc%{!?with_odbc:=no} \
330 --with-oracle%{!?with_oci:=no} \
331 --with-postgres%{!?with_pgsql:=no} \
332 --with-sqlite%{!?with_sqlite:=no} \
333 --with-tds%{!?with_freetds:=no} \
334 --with-xbase%{!?with_xbase:=no} \
335 %{?with_sybase:--with-sybase=/usr}
b4cae6aa
JB
336%{__make} -j1
337
338%install
339rm -rf $RPM_BUILD_ROOT
340
341%{__make} install \
342 DESTDIR=$RPM_BUILD_ROOT \
343 HTML_DIR=%{_gtkdocdir}
344
345# modules dlopened by *.so through libgmodule
b43c427d 346%if %{with static_libs}
6698215c 347%{__rm} $RPM_BUILD_ROOT%{providersdir}/*.a
b43c427d 348%endif
6698215c 349%{__rm} $RPM_BUILD_ROOT{%{providersdir},%{_libdir}}/*.la
b4cae6aa 350
5174964e
JB
351mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{sr@Latn,sr@latin}
352
b4cae6aa
JB
353%find_lang libgda-3.0
354
355%clean
356rm -rf $RPM_BUILD_ROOT
357
358%post -p /sbin/ldconfig
359%postun -p /sbin/ldconfig
360
361%files -f libgda-3.0.lang
362%defattr(644,root,root,755)
363%doc AUTHORS ChangeLog NEWS README
364%attr(755,root,root) %{_bindir}/gda-config-tool-3.0
db567452 365%attr(755,root,root) %{_bindir}/gda-list-server-op-3.0
b4cae6aa 366%attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
6f64b75f 367%attr(755,root,root) %ghost %{_libdir}/libgda-3.0.so.3
b4cae6aa 368%attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
6f64b75f 369%attr(755,root,root) %ghost %{_libdir}/libgda-report-3.0.so.3
350ed337 370%attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so.*.*.*
6f64b75f 371%attr(755,root,root) %ghost %{_libdir}/libgda-xslt-3.0.so.0
b4cae6aa 372%attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
6f64b75f 373%attr(755,root,root) %ghost %{_libdir}/libgdasql-3.0.so.3
6698215c
JB
374%dir %{_libdir}/%{libgdadir}
375%dir %{providersdir}
376%dir %{_datadir}/libgda-3.0
377%{_datadir}/libgda-3.0/dtd
b4cae6aa
JB
378%dir %{_sysconfdir}/libgda-3.0
379%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
380%{_mandir}/man1/gda-config-tool-3.0.1*
381%{_mandir}/man5/gda-config-3.0.5*
382
383%files devel
384%defattr(644,root,root,755)
385%attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
b883b2db 386%attr(755,root,root) %{_bindir}/gda-bdb-test
b4cae6aa
JB
387%attr(755,root,root) %{_bindir}/gda-diagnose-3.0
388%attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
389%attr(755,root,root) %{_bindir}/gda-list-config-3.0
b883b2db 390%attr(755,root,root) %{_bindir}/gda-sql-3.0
b4cae6aa
JB
391%attr(755,root,root) %{_bindir}/gda-test-connection-3.0
392%attr(755,root,root) %{_libdir}/libgda-3.0.so
393%attr(755,root,root) %{_libdir}/libgda-report-3.0.so
6f64b75f 394%attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so
b4cae6aa 395%attr(755,root,root) %{_libdir}/libgdasql-3.0.so
b4cae6aa
JB
396%{_includedir}/libgda-3.0
397%{_pkgconfigdir}/libgda-3.0.pc
398%{_pkgconfigdir}/libgda-*-3.0.pc
b883b2db 399%{_sysconfdir}/libgda-3.0/sales_test.db
b4cae6aa
JB
400
401%if %{with static_libs}
402%files static
403%defattr(644,root,root,755)
404%{_libdir}/libgda-3.0.a
405%{_libdir}/libgda-report-3.0.a
350ed337 406%{_libdir}/libgda-xslt-3.0.a
b4cae6aa
JB
407%{_libdir}/libgdasql-3.0.a
408%endif
409
6698215c
JB
410%if %{with apidocs}
411%files apidocs
412%defattr(644,root,root,755)
413%{_gtkdocdir}/libgda-3.0
414%endif
415
b4cae6aa
JB
416%files provider-db
417%defattr(644,root,root,755)
6698215c
JB
418%attr(755,root,root) %{providersdir}/libgda-bdb.so
419%{_datadir}/libgda-3.0/bdb_specs_*.xml
b4cae6aa
JB
420
421%if %{with firebird}
422%files provider-firebird
423%defattr(644,root,root,755)
6698215c
JB
424%attr(755,root,root) %{providersdir}/libgda-firebird.so
425%{_datadir}/libgda-3.0/firebird_specs_*.xml
b4cae6aa
JB
426%endif
427
428%if %{with freetds}
429%files provider-freetds
430%defattr(644,root,root,755)
6698215c
JB
431%attr(755,root,root) %{providersdir}/libgda-freetds.so
432%{_datadir}/libgda-3.0/freetds_specs_*.xml
b4cae6aa
JB
433%endif
434
435%if %{with ldap}
436%files provider-ldap
437%defattr(644,root,root,755)
6698215c
JB
438%attr(755,root,root) %{providersdir}/libgda-ldap.so
439%{_datadir}/libgda-3.0/ldap_specs_*.xml
b4cae6aa
JB
440%endif
441
442%if %{with mdb}
443%files provider-mdb
444%defattr(644,root,root,755)
6698215c
JB
445%attr(755,root,root) %{providersdir}/libgda-mdb.so
446%{_datadir}/libgda-3.0/mdb_specs_*.xml
b4cae6aa
JB
447%endif
448
449%if %{with mysql}
450%files provider-mysql
451%defattr(644,root,root,755)
6698215c
JB
452%attr(755,root,root) %{providersdir}/libgda-mysql.so
453%{_datadir}/libgda-3.0/mysql_specs_*.xml
b4cae6aa
JB
454%endif
455
456%if %{with odbc}
457%files provider-odbc
458%defattr(644,root,root,755)
6698215c
JB
459%attr(755,root,root) %{providersdir}/libgda-odbc.so
460%{_datadir}/libgda-3.0/odbc_specs_*.xml
461%endif
462
463%if %{with oci}
464%files provider-oracle
465%defattr(644,root,root,755)
466%attr(755,root,root) %{providersdir}/libgda-oracle.so
467%{_datadir}/libgda-3.0/oracle_specs_*.xml
b4cae6aa
JB
468%endif
469
470%if %{with pgsql}
471%files provider-postgres
472%defattr(644,root,root,755)
6698215c
JB
473%attr(755,root,root) %{providersdir}/libgda-postgres.so
474%{_datadir}/libgda-3.0/postgres_specs_*.xml
b4cae6aa
JB
475%endif
476
477%if %{with sqlite}
478%files provider-sqlite
479%defattr(644,root,root,755)
6698215c
JB
480%attr(755,root,root) %{providersdir}/libgda-sqlite.so
481%{_datadir}/libgda-3.0/sqlite_specs_*.xml
b4cae6aa
JB
482%endif
483
69656563
JB
484%if %{with sybase}
485%files provider-sybase
486%defattr(644,root,root,755)
6698215c
JB
487%attr(755,root,root) %{providersdir}/libgda-sybase.so
488%{_datadir}/libgda-3.0/sybase_specs_*.xml
69656563
JB
489%endif
490
b4cae6aa
JB
491%if %{with xbase}
492%files provider-xbase
493%defattr(644,root,root,755)
6698215c
JB
494%attr(755,root,root) %{providersdir}/libgda-xbase.so
495%{_datadir}/libgda-3.0/xbase_specs_*.xml
b4cae6aa 496%endif
This page took 0.136649 seconds and 4 git commands to generate.