]> git.pld-linux.org Git - packages/libfuse.git/blame - libfuse.spec
- groupadd exits successfully if group exists
[packages/libfuse.git] / libfuse.spec
CommitLineData
1c836eba
ER
1# TODO:
2# - unpackaged:
3# /etc/init.d/fuse
4# /etc/udev/rules.d/99-fuse.rules
c28e4405
PS
5#
6# Condtional build:
7%bcond_without dist_kernel # without distribution kernel
bc819d7f 8%bcond_with kernel # build kernel modules
4965dc0c 9%bcond_without userspace # don't build userspace tools
a35003d8 10%bcond_with verbose # verbose build (V=1)
127ee08d 11%bcond_without selinux # build without SELinux support
49bc7a47
ER
12
13%ifarch sparc
14%undefine with_smp
441a6a89 15%endif
49bc7a47
ER
16
17%if %{without kernel}
18%undefine with_dist_kernel
19%endif
20%if "%{_alt_kernel}" != "%{nil}"
21%undefine with_userspace
22%endif
23
24%define pname libfuse
9f8074df 25%define _rel 3
9c73f04f 26Summary: Filesystem in Userspace
8bb117ff 27Summary(pl.UTF-8): System plików w przestrzeni użytkownika
49bc7a47 28Name: %{pname}%{_alt_kernel}
c8322647 29Version: 2.7.3
d6263038 30Release: %{_rel}
c02bbc70 31Epoch: 0
e1541708 32License: GPL v2
fb76d4f3 33Group: Applications/System
c02bbc70 34Source0: http://dl.sourceforge.net/fuse/fuse-%{version}.tar.gz
c8322647 35# Source0-md5: 98563fc7b265b7479a3178181cbcf59a
f10c5dbc 36Source1: fuse.conf
d6263038 37Patch0: kernel-misc-fuse-Makefile.am.patch
49bc7a47 38Patch1: %{pname}-link.patch
498c72b7 39URL: http://fuse.sourceforge.net/
5bf8c553 40BuildRequires: autoconf
41BuildRequires: automake
4d1cfd58 42BuildRequires: libtool
1ad71c20 43BuildRequires: cpp
4d1cfd58 44BuildRequires: sed >= 4.0
498c72b7 45%if %{with kernel}
3aa68fea 46%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
2f81dc21 47BuildRequires: rpmbuild(macros) >= 1.379
002758f1 48%endif
4d1cfd58 49%if %{with userspace}
efd7a38f 50%{?with_selinux:BuildRequires: libselinux-devel}
4d1cfd58 51%endif
b066fee7 52Requires(pre): /usr/bin/getgid
53Requires(pre): /usr/sbin/groupadd
6e29bdf4 54Provides: group(fuse)
9c73f04f 55Buildroot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
c28e4405 56
9c73f04f 57%description
58FUSE (Filesystem in Userspace) is a simple interface for userspace
544fbe9d 59programs to export a virtual filesystem to the Linux kernel. FUSE also
9c73f04f 60aims to provide a secure method for non privileged users to create and
61mount their own filesystem implementations.
62
d6263038
JB
63This package contains a shared library.
64
fa7f9ca7
JR
65%description -l pl.UTF-8
66FUSE stanowi prosty interfejs dla programów działających w przestrzeni
67użytkownika eksportujący wirtualny system plików do jądra Linuksa.
68FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
69montowania własnych implementacji systemów plików przez zwykłych
70(nieuprzywilejowanych) użytkowników.
9c73f04f 71
fa7f9ca7 72Ten pakiet zawiera bibliotekę współdzieloną.
d6263038
JB
73
74%package devel
75Summary: Filesytem in Userspace - Development header files
8bb117ff 76Summary(pl.UTF-8): System plików w przestrzeni użytkownika - pliki nagłówkowe
d6263038 77Group: Development/Libraries
49bc7a47 78Requires: %{pname} = %{epoch}:%{version}-%{_rel}
d6263038
JB
79
80%description devel
81Libfuse library header files.
82
fa7f9ca7
JR
83%description devel -l pl.UTF-8
84Pliki nagłówkowe biblioteki libfuse.
d6263038
JB
85
86%package static
87Summary: Filesytem in Userspace - static library
8bb117ff 88Summary(pl.UTF-8): System plików w przestrzeni użytkownika - biblioteka statyczna
2d1d7461 89Group: Development/Libraries
d6263038
JB
90Requires: libfuse-devel = %{epoch}:%{version}-%{_rel}
91
92%description static
93Static libfuse libraries.
94
fa7f9ca7 95%description static -l pl.UTF-8
d6263038
JB
96Statyczna biblioteka libfuse.
97
0612e680 98%package -n kernel%{_alt_kernel}-misc-fuse
d6263038 99Summary: Filesystem in Userspace
8bb117ff 100Summary(pl.UTF-8): System plików w przestrzeni użytkownika
d6263038
JB
101Release: %{_rel}@%{_kernel_ver_str}
102License: GPL v2
103Group: Base/Kernel
d6263038 104Requires(post,postun): /sbin/depmod
8bfc0885 105%if %{with dist_kernel}
2f81dc21 106%requires_releq_kernel
107Requires(postun): %releq_kernel
8bfc0885 108%endif
0612e680 109%if "%{_alt_kernel}" != "%{nil}"
110Provides: kernel-misc-fuse
111%endif
d6263038 112
0612e680 113%description -n kernel%{_alt_kernel}-misc-fuse
d6263038
JB
114FUSE (Filesystem in Userspace) is a simple interface for userspace
115programs to export a virtual filesystem to the Linux kernel. FUSE also
116aims to provide a secure method for non privileged users to create and
117mount their own filesystem implementations.
118
fa7f9ca7
JR
119%description -n kernel%{_alt_kernel}-misc-fuse -l pl.UTF-8
120FUSE stanowi prosty interfejs dla programów działających w przestrzeni
121użytkownika eksportujący wirtualny system plików do jądra Linuksa.
122FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
123montowania własnych implementacji systemów plików przez zwykłych
124(nieuprzywilejowanych) użytkowników.
d6263038 125
9c73f04f 126%prep
4965dc0c 127%setup -q -n fuse-%{version}
3d2362f9 128%patch0 -p1
4d1cfd58 129%patch1 -p1
d6263038 130
202ebc3b 131sed -i '/FUSERMOUNT_PROG/s,fusermount,%{_bindir}/fusermount,' lib/mount.c
9c73f04f 132
133%build
496fbb04 134%{__libtoolize}
a35003d8 135%{__aclocal}
496fbb04 136%{__autoheader}
a35003d8
PS
137%{__autoconf}
138%{__automake}
c660eb4c 139%configure \
127ee08d 140 %{!?with_selinux:ac_cv_header_selinux_selinux_h=no} \
2e74d96c 141 --%{?with_kernel:en}%{!?with_kernel:dis}able-kernel-module \
d6263038
JB
142 --enable-lib \
143 --enable-util \
2e74d96c 144 %{?with_kernel:--with-kernel=%{_kernelsrcdir}}
7fb6785c 145
8bfc0885
PS
146%if %{with userspace}
147cp kernel/fuse_kernel.h include/
148for DIR in include lib util; do
149%{__make} -C $DIR
150done
151%endif
152
a35003d8 153%if %{with kernel}
9e146969 154%build_kernel_modules -m fuse -C kernel
a35003d8 155%endif
9c73f04f 156
9c73f04f 157%install
158rm -rf $RPM_BUILD_ROOT
3af001c7 159install -d $RPM_BUILD_ROOT{%{_pkgconfigdir},%{_sysconfdir}}
9c73f04f 160
8413d3ec 161%if %{with userspace}
496fbb04 162for DIR in include lib util; do
163%{__make} -C $DIR install \
164 DESTDIR=$RPM_BUILD_ROOT
165done
166
167install fuse.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
3af001c7 168install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
8413d3ec 169%endif
9c73f04f 170
8413d3ec 171%if %{with kernel}
0612e680 172%install_kernel_modules -m kernel/fuse -d kernel/fs
8413d3ec
PS
173%endif
174
c02bbc70
JB
175%clean
176rm -rf $RPM_BUILD_ROOT
177
b066fee7 178%pre
a270b1b1 179%groupadd -g 84 fuse
b066fee7 180
d6263038 181%post -p /sbin/ldconfig
cefe4f98 182%postun -p /sbin/ldconfig
d6263038 183
0612e680 184%post -n kernel%{_alt_kernel}-misc-fuse
e1541708 185%depmod %{_kernel_ver}
9c73f04f 186
0612e680 187%postun -n kernel%{_alt_kernel}-misc-fuse
e1541708
PS
188%depmod %{_kernel_ver}
189
d6263038 190%if %{with userspace}
9c73f04f 191%files
192%defattr(644,root,root,755)
496fbb04 193%doc README NEWS ChangeLog AUTHORS doc/*
f5e4370a 194%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fuse.conf
93034210 195%attr(4754,root,fuse) %{_bindir}/fusermount
80df11a9 196%attr(755,root,root) %{_bindir}/ulockmgr_server
f5e4370a 197%attr(755,root,root) /sbin/mount.fuse
c6e9eee0
JB
198%attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
199%attr(755,root,root) %ghost %{_libdir}/libfuse.so.2
200%attr(755,root,root) %{_libdir}/libulockmgr.so.*.*.*
201%attr(755,root,root) %ghost %{_libdir}/libulockmgr.so.1
4965dc0c 202
d6263038 203%files devel
4965dc0c 204%defattr(644,root,root,755)
c6e9eee0
JB
205%attr(755,root,root) %{_libdir}/libfuse.so
206%attr(755,root,root) %{_libdir}/libulockmgr.so
207%{_libdir}/libfuse.la
208%{_libdir}/libulockmgr.la
209%{_includedir}/fuse
210%{_includedir}/fuse.h
80df11a9 211%{_includedir}/ulockmgr.h
496fbb04 212%{_pkgconfigdir}/fuse.pc
9c73f04f 213
d6263038 214%files static
4965dc0c 215%defattr(644,root,root,755)
c6e9eee0
JB
216%{_libdir}/libfuse.a
217%{_libdir}/libulockmgr.a
f981350a 218%endif
d6263038
JB
219
220%if %{with kernel}
0612e680 221%files -n kernel%{_alt_kernel}-misc-fuse
d6263038
JB
222%defattr(644,root,root,755)
223/lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
6895341f 224%endif
This page took 0.156623 seconds and 4 git commands to generate.