]> git.pld-linux.org Git - packages/libArcus.git/blame - libArcus.spec
- release 2 (by relup.sh)
[packages/libArcus.git] / libArcus.spec
CommitLineData
d8d3c612
JR
1Summary: Communication library between internal components for Ultimaker software
2Name: libArcus
3Version: 2.5.0
eda9713c 4Release: 2
d8d3c612
JR
5License: AGPLv3+
6Group: Libraries
7URL: https://github.com/Ultimaker/libArcus
8Source0: https://github.com/Ultimaker/libArcus/archive/%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: a8f83c896793262967971b7a94fe3082
10BuildRequires: cmake
11BuildRequires: libstdc++-devel
12BuildRequires: protobuf-devel
13BuildRequires: python3-devel
14BuildRequires: python3-protobuf
15BuildRequires: python3-sip-devel
16BuildRequires: sip
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20Arcus library contains C++ code and Python 3 bindings for creating a
21socket in a thread and using this socket to send and receive messages
22based on the Protocol Buffers library. It is designed to facilitate
23the communication between Cura and its backend and similar code.
24
25%package devel
26Summary: Development files for libArcus
27License: AGPLv3+ and BSD
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30
31%description devel
32Arcus library contains C++ code and Python 3 bindings for creating a
33socket in a thread and using this socket to send and receive messages
34based on the Protocol Buffers library. It is designed to facilitate
35the communication between Cura and its backend and similar code.
36
37Development files.
38
39%package -n python3-Arcus
40Summary: Python 3 libArcus bindings
41Group: Libraries/Python
42Requires: %{name} = %{version}-%{release}
43
44%description -n python3-Arcus
45Arcus Python 3 bindings for creating a socket in a thread and using
46this socket to send and receive messages based on the Protocol Buffers
47library. It is designed to facilitate the communication between Cura
48and its backend and similar code.
49
50%prep
51%setup -q
52
53%build
54mkdir build
55cd build
56%{cmake} .. \
57 -DPYTHON_SITE_PACKAGES_DIR:PATH=%{py3_sitedir} \
58 -DBUILD_EXAMPLES:BOOL=OFF \
59 -DCMAKE_SKIP_RPATH:BOOL=ON
60
61%{__make}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65%{__make} -C build install DESTDIR=$RPM_BUILD_ROOT
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%post -p /sbin/ldconfig
71%postun -p /sbin/ldconfig
72
73%files
74%defattr(644,root,root,755)
75%doc README.md
76%attr(755, root, root) %{_libdir}/libArcus.so.*.*.*
77%attr(755, root, root) %ghost %{_libdir}/libArcus.so.3
78
79%files devel
80%defattr(644,root,root,755)
81%doc examples/example.cpp examples/example.proto
82%attr(755, root, root) %{_libdir}/libArcus.so
83%{_includedir}/Arcus
84%{_libdir}/cmake/Arcus
85
86%files -n python3-Arcus
87%defattr(644,root,root,755)
88%doc TODO.md
89%doc examples/example.py
90%attr(755, root, root) %{py3_sitedir}/Arcus.so
This page took 0.056163 seconds and 4 git commands to generate.