]> git.pld-linux.org Git - packages/dehydrated.git/blame - letsencrypt.sh.spec
patching for pld usage
[packages/dehydrated.git] / letsencrypt.sh.spec
CommitLineData
1780cc1f
ER
1Summary: letsencrypt/acme client implemented as a shell-script
2Name: letsencrypt.sh
3Version: 0.1.0
f5fc6721 4Release: 0.4
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
7Source0: https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
eb6aa75d
ER
8# Source0-md5: eadd134cc5365753c03929dd70db341d
9Source1: apache.conf
10Source2: lighttpd.conf
3c33d40b 11Source3: config.sh
f5fc6721 12Patch0: pld.patch
1780cc1f
ER
13URL: https://github.com/lukas2511/letsencrypt.sh
14BuildRequires: rpmbuild(macros) >= 1.713
15Requires: curl
16Requires: grep
17Requires: mktemp
18Requires: openssl
19Requires: sed
eb6aa75d
ER
20Requires: webapps
21Requires: webserver(access)
22Requires: webserver(alias)
1780cc1f
ER
23BuildArch: noarch
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
eb6aa75d
ER
26%define _webapps /etc/webapps
27%define _webapp %{name}
28%define _sysconfdir %{_webapps}/%{_webapp}
29%define _appdir %{_datadir}/%{_webapp}
30
1780cc1f
ER
31%description
32This is a client for signing certificates with an ACME-server
33(currently only provided by letsencrypt) implemented as a relatively
34simple bash-script.
35
36Current features:
37- Signing of a list of domains
38- Signing of a CSR
39- Renewal if a certificate is about to expire or SAN (subdomains)
40 changed
41- Certificate revocation
42
43%prep
44%setup -q
f5fc6721 45%patch0 -p1
1780cc1f
ER
46
47%install
48rm -rf $RPM_BUILD_ROOT
eb6aa75d
ER
49install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/acme-challenges}
50
51install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
52
53cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
54cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
3c33d40b 55cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 56cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f
ER
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
eb6aa75d
ER
61%triggerin -- apache1 < 1.3.37-3, apache1-base
62%webapp_register apache %{_webapp}
63
64%triggerun -- apache1 < 1.3.37-3, apache1-base
65%webapp_unregister apache %{_webapp}
66
67%triggerin -- apache < 2.2.0, apache-base
68%webapp_register httpd %{_webapp}
69
70%triggerun -- apache < 2.2.0, apache-base
71%webapp_unregister httpd %{_webapp}
72
73%triggerin -- lighttpd
74%webapp_register lighttpd %{_webapp}
75
76%triggerun -- lighttpd
77%webapp_unregister lighttpd %{_webapp}
78
1780cc1f
ER
79%files
80%defattr(644,root,root,755)
81%doc README.md CHANGELOG LICENSE
7410a329 82%dir %attr(750,root,http) %{_sysconfdir}
eb6aa75d
ER
83%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
84%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
85%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
3c33d40b 86%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
eb6aa75d
ER
87# challenges written here from letsencrypt.sh, need to be readable by webserver
88%dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
7410a329
ER
89
90%attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.040968 seconds and 4 git commands to generate.