]> git.pld-linux.org Git - packages/ldb.git/blame - ldb.spec
- force ld.bfd via -fuse-ld=bfd (option since gcc-6:4.6.1-5)
[packages/ldb.git] / ldb.spec
CommitLineData
7f41620a 1# TODO
88ce4cc5 2# - ld.bfd enforced because gold does not understand '!' in version script (binutils-3:2.21.53.0.1-1)
2a1bfbb9
ER
3%define talloc_version 2.0.5
4%define tdb_version 1.2.9
5%define tevent_version 0.9.12
6Summary: A schema-less, ldap like, API and database
7Name: libldb
8Version: 1.1.0
88ce4cc5 9Release: 2
2a1bfbb9
ER
10License: LGPL v3+
11Group: Development/Libraries
12URL: http://ldb.samba.org/
13Source0: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
14# Source0-md5: 61145ad9cfe017ce4fca5cbc77b9552b
15BuildRequires: autoconf
16BuildRequires: docbook-style-xsl
17BuildRequires: libtalloc-devel >= %{talloc_version}
18BuildRequires: libxslt
19BuildRequires: popt-devel
20BuildRequires: python-devel
21BuildRequires: python-talloc-devel
22BuildRequires: python-tdb
23BuildRequires: tdb-devel >= %{tdb_version}
24BuildRequires: tevent-devel >= %{tevent_version}
25Requires: libtalloc >= %{talloc_version}
26Requires: tdb >= %{tdb_version}
27Requires: tevent >= %{tevent_version}
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31An extensible library that implements an LDAP like API to access
32remote LDAP servers, or use local tdb databases.
33
34%package -n ldb-tools
35Summary: Tools to manage LDB files
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38
39%description -n ldb-tools
40Tools to manage LDB files.
41
42%package devel
43Summary: Developer tools for the LDB library
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: libtalloc-devel >= %{talloc_version}
47Requires: pkgconfig
48Requires: tdb-devel >= %{tdb_version}
49Requires: tevent-devel >= %{tevent_version}
50
51%description devel
52Header files needed to develop programs that link against the LDB
53library.
54
55%package -n python-ldb
56Summary: Python bindings for the LDB library
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: python-tdb = %{tdb_version}
60Obsoletes: pyldb
61
62%description -n python-ldb
63Python bindings for the LDB library.
64
65%package -n python-ldb-devel
66Summary: Development files for the Python bindings for the LDB library
67Group: Development/Libraries
68Requires: pyldb = %{version}-%{release}
69
70%description -n python-ldb-devel
71Development files for the Python bindings for the LDB library
72
73%prep
74%setup -q -n ldb-%{version}
75
76%build
2a1bfbb9
ER
77CC="%{__cc}" \
78CFLAGS="%{rpmcflags}" \
88ce4cc5 79LDFLAGS="%{rpmldflags} -fuse-ld=bfd" \
2a1bfbb9
ER
80PYTHONDIR=%{py_sitedir} \
81./configure \
82 --prefix=%{_prefix} \
83 --libdir=%{_libdir} \
84 --with-modulesdir=%{_libdir}/ldb/modules \
85 --with-privatelibdir=%{_libdir}/ldb \
86 --bundled-libraries=NONE \
87 --disable-rpath \
88 --disable-rpath-install
89
90%{__make} \
91 V=1
92
93%install
94rm -rf $RPM_BUILD_ROOT
95%{__make} install \
96 DESTDIR=$RPM_BUILD_ROOT
97
98# Remove _tevent.so (it's managed by python-tevent)
99%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_tevent.so
100
101# Shared libraries need to be marked executable for
102# rpmbuild to strip them and include them in debuginfo
88ce4cc5 103find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} ';'
2a1bfbb9
ER
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
111%post -n python-ldb -p /sbin/ldconfig
112%postun -n python-ldb -p /sbin/ldconfig
113
114%files
115%defattr(644,root,root,755)
116%dir %{_libdir}/ldb
117%{_libdir}/libldb.so.*
118%dir %{_libdir}/ldb/modules
119%dir %{_libdir}/ldb/modules/ldb
120%{_libdir}/ldb/modules/ldb/*.so
121
122%files -n ldb-tools
123%defattr(644,root,root,755)
124%attr(755,root,root) %{_bindir}/ldbadd
125%attr(755,root,root) %{_bindir}/ldbdel
126%attr(755,root,root) %{_bindir}/ldbedit
127%attr(755,root,root) %{_bindir}/ldbmodify
128%attr(755,root,root) %{_bindir}/ldbrename
129%attr(755,root,root) %{_bindir}/ldbsearch
130%{_libdir}/ldb/libldb-cmdline.so
131%{_mandir}/man1/ldbadd.1.*
132%{_mandir}/man1/ldbdel.1.*
133%{_mandir}/man1/ldbedit.1.*
134%{_mandir}/man1/ldbmodify.1.*
135%{_mandir}/man1/ldbrename.1.*
136%{_mandir}/man1/ldbsearch.1.*
137
138%files devel
139%defattr(644,root,root,755)
140%{_includedir}/ldb_module.h
141%{_includedir}/ldb_handlers.h
142%{_includedir}/ldb_errors.h
143%{_includedir}/ldb_version.h
144%{_includedir}/ldb.h
145%{_libdir}/libldb.so
146
147%{_pkgconfigdir}/ldb.pc
148%{_mandir}/man3/ldb.3*
149
150%files -n python-ldb
151%defattr(644,root,root,755)
152%{py_sitedir}/ldb.so
153%{_libdir}/libpyldb-util.so.1*
154
155%files -n python-ldb-devel
156%defattr(644,root,root,755)
157%{_includedir}/pyldb.h
158%{_libdir}/libpyldb-util.so
159%{_pkgconfigdir}/pyldb-util.pc
This page took 0.093069 seconds and 4 git commands to generate.