]> git.pld-linux.org Git - packages/kf5-kwallet.git/blame - kf5-kwallet.spec
- new
[packages/kf5-kwallet.git] / kf5-kwallet.spec
CommitLineData
264029bf
WF
1# TODO:
2# Not packaged:
3# /usr/include/KF5
4# /usr/share/knotifications5
5# /usr/share/kservices5
6
7%define _state stable
8%define orgname kwallet
9
10Summary: Safe desktop-wide storage for passwords
11Name: kf5-%{orgname}
12Version: 5.0.0
13Release: 0.1
14License: LGPL v2.1+
15Group: X11/Libraries
16Source0: ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
17# Source0-md5: 14fc1c13e13ed451dbe8065fe3bc96ec
18URL: http://www.kde.org/
19BuildRequires: Qt5Core-devel >= 5.2.0
20BuildRequires: Qt5DBus-devel
21BuildRequires: Qt5Gui-devel >= 5.3.1
22BuildRequires: Qt5Test-devel
23BuildRequires: Qt5Widgets-devel
24BuildRequires: Qt5Xml-devel >= 5.2.0
25BuildRequires: cmake >= 2.8.12
26BuildRequires: gettext-devel
27BuildRequires: kf5-extra-cmake-modules >= 1.0.0
28BuildRequires: kf5-kauth-devel >= %{version}
29BuildRequires: kf5-kcodecs-devel >= %{version}
30BuildRequires: kf5-kconfig-devel >= %{version}
31BuildRequires: kf5-kconfigwidgets-devel >= %{version}
32BuildRequires: kf5-kcoreaddons-devel >= %{version}
33BuildRequires: kf5-kdbusaddons-devel >= %{version}
34BuildRequires: kf5-kguiaddons-devel >= %{version}
35BuildRequires: kf5-ki18n-devel >= %{version}
36BuildRequires: kf5-kiconthemes-devel >= %{version}
37BuildRequires: kf5-kitemviews-devel >= %{version}
38BuildRequires: kf5-knotifications-devel >= %{version}
39BuildRequires: kf5-kservice-devel >= %{version}
40BuildRequires: kf5-kwidgetsaddons-devel >= %{version}
41BuildRequires: kf5-kwindowsystem-devel >= %{version}
42BuildRequires: libgcrypt-devel >= 1.5.0
43BuildRequires: rpmbuild(macros) >= 1.164
44BuildRequires: tar >= 1:1.22
45BuildRequires: xz
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%define qt5dir %{_libdir}/qt5
49
50%description
51This framework contains two main components:
52- Interface to KWallet, the safe desktop-wide storage for passwords on
53 KDE work spaces.
54- The kwalletd used to safely store the passwords on KDE work spaces.
55
56The library can be built alone, without kwalletd, by setting the
57`BUILD_KWALLETD` option to `OFF`.
58
59%package devel
60Summary: Header files for %{orgname} development
61Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{orgname}
62Group: X11/Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description devel
66Header files for %{orgname} development.
67
68%description devel -l pl.UTF-8
69Pliki nagłówkowe dla programistów używających %{orgname}.
70
71%prep
72%setup -q -n %{orgname}-%{version}
73
74%build
75install -d build
76cd build
77%cmake \
78 -DBIN_INSTALL_DIR=%{_bindir} \
79 -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
80 -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
81 -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
82 -DQML_INSTALL_DIR=%{qt5dir}/qml \
83 -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
84 -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
85 -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
86 -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
87 -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
88 -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
89 -D_IMPORT_PREFIX=%{_prefix} \
90 ../
91%{__make}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96%{__make} -C build/ install \
97 DESTDIR=$RPM_BUILD_ROOT
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103%postun -p /sbin/ldconfig
104
105%files
106%defattr(644,root,root,755)
107%doc README.md
108%attr(755,root,root) %{_bindir}/kwalletd5
109%attr(755,root,root) %ghost %{_libdir}/libKF5Wallet.so.5
110%attr(755,root,root) %{_libdir}/libKF5Wallet.so.5.0.0
111%attr(755,root,root) %ghost %{_libdir}/libkwalletbackend5.so.5
112%attr(755,root,root) %{_libdir}/libkwalletbackend5.so.5.0.0
113%{_datadir}/dbus-1/interfaces/kf5_org.kde.KWallet.xml
114%{_datadir}/dbus-1/services/org.kde.kwalletd5.service
115%{_datadir}/knotifications5/kwalletd.notifyrc
116%{_datadir}/kservices5/kwalletd5.desktop
117
118%files devel
119%defattr(644,root,root,755)
120%{_includedir}/KF5/KWallet
121%{_includedir}/KF5/kwallet_version.h
122%{_libdir}/cmake/KF5Wallet
123%attr(755,root,root) %{_libdir}/libKF5Wallet.so
124%attr(755,root,root) %{_libdir}/libkwalletbackend5.so
125%{qt5dir}/mkspecs/modules/qt_KWallet.pri
This page took 0.060678 seconds and 4 git commands to generate.