]> git.pld-linux.org Git - packages/kf5-kplotting.git/blame - kf5-kplotting.spec
tar.xz deps
[packages/kf5-kplotting.git] / kf5-kplotting.spec
CommitLineData
8b0a37c1
WF
1# TODO:
2# - dir /usr/include/KF5 not packaged
3%define _state stable
4%define orgname kplotting
5
6Summary: Data plotting
7Name: kf5-%{orgname}
8Version: 5.0.0
9Release: 0.1
10License: LGPL v2.1+
11Group: X11/Libraries
12Source0: ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13# Source0-md5: 28eae81acd540a79c91acad75f0c725c
14URL: http://www.kde.org/
15BuildRequires: Qt5Core-devel
16BuildRequires: Qt5Gui-devel >= 5.3.1
17BuildRequires: Qt5Test-devel
18BuildRequires: Qt5Widgets-devel
19BuildRequires: cmake >= 2.8.12
20BuildRequires: kf5-extra-cmake-modules >= 1.0.0
21BuildRequires: rpmbuild(macros) >= 1.164
cdba659b
ER
22BuildRequires: tar >= 1:1.22
23BuildRequires: xz
8b0a37c1
WF
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define qt5dir %{_libdir}/qt5
27
28%description
29KPlotWidget is a QWidget-derived class that provides a virtual base
30class for easy data-plotting. The idea behind KPlotWidget is that you
31only have to specify information in "data units"; i.e., the natural
32units of the data being plotted. KPlotWidget automatically converts
33everything to screen pixel units.
34
35KPlotWidget draws X and Y axes with tick marks and tick labels. It
36automatically determines how many tick marks to use and where they
37should be, based on the data limits specified for the plot. You change
38the limits by calling `setLimits(double x1, double x2, double y1,
39double y2)`.
40
41Data to be plotted are stored using the KPlotObject class. KPlotObject
42consists of a QList of QPointF's, each specifying the X,Y coordinates
43of a data point. KPlotObject also specifies the "type" of data to be
44plotted (POINTS or CURVE or POLYGON or LABEL).
45
46%package devel
47Summary: Header files for %{orgname} development
48Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{orgname}
49Group: X11/Development/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description devel
53Header files for %{orgname} development.
54
55%description devel -l pl.UTF-8
56Pliki nagłówkowe dla programistów używających %{orgname}.
57
58%prep
59%setup -q -n %{orgname}-%{version}
60
61%build
62install -d build
63cd build
64%cmake \
65 -DBIN_INSTALL_DIR=%{_bindir} \
66 -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
67 -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
68 -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
69 -DQML_INSTALL_DIR=%{qt5dir}/qml \
70 -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
71 -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
72 -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
73 -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
74 -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
75 -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
76 ../
77%{__make}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82%{__make} -C build/ install \
83 DESTDIR=$RPM_BUILD_ROOT
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%post -p /sbin/ldconfig
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(644,root,root,755)
93%doc README.md
94%attr(755,root,root) %ghost %{_libdir}/libKF5Plotting.so.5
95%attr(755,root,root) %{_libdir}/libKF5Plotting.so.5.0.0
96
97%files devel
98%defattr(644,root,root,755)
99%{_includedir}/KF5/KPlotting
100%{_includedir}/KF5/kplotting_version.h
101%{_libdir}/cmake/KF5Plotting
102%attr(755,root,root) %{_libdir}/libKF5Plotting.so
103%{qt5dir}/mkspecs/modules/qt_KPlotting.pri
This page took 0.118372 seconds and 4 git commands to generate.