]> git.pld-linux.org Git - packages/kf5-kpeople.git/blame - kf5-kpeople.spec
- initial
[packages/kf5-kpeople.git] / kf5-kpeople.spec
CommitLineData
375e1bc9
AM
1# Conditional build:
2%bcond_with tests # build without tests
3#
4%define kdeframever 5.13
5%define qtver 5.3.2
6%define kfname kpeople
7Summary: Provides access to all contacts and the people who hold them
8Name: kf5-%{kfname}
9Version: 5.13.0
10Release: 1
11License: GPL v2+/LGPL v2.1+
12Group: X11/Libraries
13Source0: http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14# Source0-md5: edda286814f79baf9c0ebc515863f1df
15URL: http://www.kde.org/
16BuildRequires: Qt5Core-devel >= %{qtver}
17BuildRequires: Qt5Gui-devel >= %{qtver}
18BuildRequires: Qt5Network-devel >= %{qtver}
19BuildRequires: Qt5Test-devel >= %{qtver}
20%if %{with tests}
21BuildRequires: Qt5Gui-devel >= %{qtver}
22BuildRequires: Qt5Widgets-devel >= %{qtver}
23%endif
24BuildRequires: cmake >= 2.8.12
25BuildRequires: kf5-extra-cmake-modules >= 1.4.0
26BuildRequires: qt5-build >= %{qtver}
27BuildRequires: rpmbuild(macros) >= 1.164
28BuildRequires: tar >= 1:1.22
29BuildRequires: xz
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Provides access to all contacts and the people who hold them.
34
35%package devel
36Summary: Header files for %{kfname} development
37Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
38Group: X11/Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42Header files for %{kfname} development.
43
44%description devel -l pl.UTF-8
45Pliki nagłówkowe dla programistów używających %{kfname}.
46
47%prep
48%setup -q -n %{kfname}-%{version}
49
50%build
51install -d build
52cd build
53%cmake \
54 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
55 ..
56%{__make}
57
58%{?with_tests:%{__make} test}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62%{__make} -C build install \
63 DESTDIR=$RPM_BUILD_ROOT
64
65%find_lang %{kfname}5 --all-name
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%post -p /sbin/ldconfig
71%postun -p /sbin/ldconfig
72
73%files -f %{kfname}5.lang
74%defattr(644,root,root,755)
75%doc README.md
76%attr(755,root,root) %{_libdir}/libKF5People.so.*.*.*
77%attr(755,root,root) %ghost %{_libdir}/libKF5People.so.5
78%attr(755,root,root) %{_libdir}/libKF5PeopleBackend.so.*.*.*
79%attr(755,root,root) %ghost %{_libdir}/libKF5PeopleBackend.so.5
80%attr(755,root,root) %{_libdir}/libKF5PeopleWidgets.so.*.*.*
81%attr(755,root,root) %ghost %{_libdir}/libKF5PeopleWidgets.so.5
82%dir %{_libdir}/qt5/qml/org/kde/people
83%attr(755,root,root) %{_libdir}/qt5/qml/org/kde/people/libKF5PeopleDeclarative.so
84%{_datadir}/kf5/kpeople
85%{_datadir}/kservicetypes5/kpeople_data_source.desktop
86%{_datadir}/kservicetypes5/kpeople_plugin.desktop
87%{_datadir}/kservicetypes5/persondetailsplugin.desktop
88
89%files devel
90%defattr(644,root,root,755)
91%attr(755,root,root) %{_libdir}/libKF5People.so
92%attr(755,root,root) %{_libdir}/libKF5PeopleBackend.so
93%attr(755,root,root) %{_libdir}/libKF5PeopleWidgets.so
94%{_includedir}/KF5/KPeople
95%{_libdir}/cmake/KF5People
96%{_libdir}/qt5/mkspecs/modules/qt_KPeople*.pri
This page took 0.032172 seconds and 4 git commands to generate.