]> git.pld-linux.org Git - packages/kf5-kinit.git/blame - kf5-kinit.spec
- new
[packages/kf5-kinit.git] / kf5-kinit.spec
CommitLineData
fd2e2af6
WF
1# TODO:
2# Not packaged:
3# /usr/include/KF5
4# /usr/share/kservicetypes5
5
6%define _state stable
7%define orgname kinit
8
9Summary: Helper library to speed up start of applications on KDE workspaces
10Name: kf5-%{orgname}
11Version: 5.0.0
12Release: 0.1
13License: LGPL v2.1+
14Group: X11/Libraries
15Source0: ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
16# Source0-md5: 09860896223814082037a184fe1fdcb9
17URL: http://www.kde.org/
18BuildRequires: cmake >= 2.8.12
19BuildRequires: gettext-devel
20BuildRequires: kf5-extra-cmake-modules >= 1.0.0
21BuildRequires: libcap-devel
22BuildRequires: rpmbuild(macros) >= 1.164
23BuildRequires: tar >= 1:1.22
24BuildRequires: xorg-lib-libX11-devel
25BuildRequires: xz
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%define qt5dir %{_libdir}/qt5
29
30%description
31kdeinit is a process launcher somewhat similar to the famous init used
32for booting UNIX.
33
34It launches processes by forking and then loading a dynamic library
35which should contain a 'kdemain(...)' function.
36
37Using kdeinit to launch KDE applications makes starting a typical KDE
38applications 2.5 times faster (100ms instead of 250ms on a P-III 500)
39It reduces memory consumption by approx. 350Kb per application.
40
41%package devel
42Summary: Header files for %{orgname} development
43Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{orgname}
44Group: X11/Development/Libraries
45Requires: %{name} = %{version}-%{release}
46
47%description devel
48Header files for %{orgname} development.
49
50%description devel -l pl.UTF-8
51Pliki nagłówkowe dla programistów używających %{orgname}.
52
53%prep
54%setup -q -n %{orgname}-%{version}
55
56%build
57install -d build
58cd build
59%cmake \
60 -DBIN_INSTALL_DIR=%{_bindir} \
61 -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
62 -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
63 -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
64 -DQML_INSTALL_DIR=%{qt5dir}/qml \
65 -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
66 -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
67 -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
68 -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
69 -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
70 -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
71 -D_IMPORT_PREFIX=%{_prefix} \
72 ../
73%{__make}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78%{__make} -C build/ install \
79 DESTDIR=$RPM_BUILD_ROOT
80
81%find_lang %{orgname}5
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -p /sbin/ldconfig
87%postun -p /sbin/ldconfig
88
89%files -f %{orgname}5.lang
90%defattr(644,root,root,755)
91%doc README.md
92%attr(755,root,root) %{_bindir}/kdeinit5
93%attr(755,root,root) %{_bindir}/kdeinit5_shutdown
94%attr(755,root,root) %{_bindir}/kdeinit5_wrapper
95%attr(755,root,root) %{_bindir}/kshell5
96%attr(755,root,root) %{_bindir}/kwrapper5
97%attr(755,root,root) %{_libdir}/kf5/klauncher
98%attr(755,root,root) %{_libdir}/kf5/start_kdeinit
99%attr(755,root,root) %{_libdir}/kf5/start_kdeinit_wrapper
100%attr(755,root,root) %{_libdir}/libkdeinit5_klauncher.so
101%{_datadir}/dbus-1/interfaces/kf5_org.kde.KLauncher.xml
102%{_mandir}/man8/kdeinit5.8*
103
104%files devel
105%defattr(644,root,root,755)
106%{_libdir}/cmake/KF5Init
This page took 0.080823 seconds and 4 git commands to generate.