]> git.pld-linux.org Git - packages/kf5-kglobalaccel.git/blame - kf5-kglobalaccel.spec
- new
[packages/kf5-kglobalaccel.git] / kf5-kglobalaccel.spec
CommitLineData
5262500d
WF
1# TODO:
2# - dir /usr/include/KF5 not packaged
3%define _state stable
4%define orgname kglobalaccel
5
6Summary: Global desktop keyboard shortcuts
7Name: kf5-%{orgname}
8Version: 5.0.0
9Release: 0.1
10License: LGPL v2.1+
11Group: X11/Libraries
12Source0: ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13# Source0-md5: 2789a7e598942a9a7004fa867019ec6a
14URL: http://www.kde.org/
15BuildRequires: Qt5Core-devel
16BuildRequires: Qt5DBus-devel
17BuildRequires: Qt5Gui-devel >= 5.3.1
18BuildRequires: Qt5Test-devel
19BuildRequires: Qt5Widgets-devel
20BuildRequires: Qt5X11Extras-devel
21BuildRequires: Qt5Xml-devel >= 5.2.0
22BuildRequires: cmake >= 2.8.12
23BuildRequires: kf5-extra-cmake-modules >= 1.0.0
24BuildRequires: qt5-linguist
25BuildRequires: rpmbuild(macros) >= 1.164
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%define qt5dir %{_libdir}/qt5
29
30%description
31KGlobalAccel allows you to have global accelerators that are
32independent of the focused window. Unlike regular shortcuts, the
33application's window does not need focus for them to be activated.
34
35%package devel
36Summary: Header files for %{orgname} development
37Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{orgname}
38Group: X11/Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42Header files for %{orgname} development.
43
44%description devel -l pl.UTF-8
45Pliki nagłówkowe dla programistów używających %{orgname}.
46
47%prep
48%setup -q -n %{orgname}-%{version}
49
50%build
51install -d build
52cd build
53%cmake \
54 -DBIN_INSTALL_DIR=%{_bindir} \
55 -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
56 -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
57 -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
58 -DQML_INSTALL_DIR=%{qt5dir}/qml \
59 -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
60 -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
61 -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
62 -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
63 -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
64 -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
65 ../
66%{__make}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71%{__make} -C build/ install \
72 DESTDIR=$RPM_BUILD_ROOT
73
74%find_lang %{orgname}5_qt --with-qm
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post -p /sbin/ldconfig
80%postun -p /sbin/ldconfig
81
82%files -f %{orgname}5_qt.lang
83%defattr(644,root,root,755)
84%doc README.md
85%attr(755,root,root) %ghost %{_libdir}/libKF5GlobalAccel.so.5
86%attr(755,root,root) %{_libdir}/libKF5GlobalAccel.so.5.0.0
87%{_datadir}/dbus-1/interfaces/kf5_org.kde.KGlobalAccel.xml
88%{_datadir}/dbus-1/interfaces/kf5_org.kde.kglobalaccel.Component.xml
89
90%files devel
91%defattr(644,root,root,755)
92%{_includedir}/KF5/KGlobalAccel
93%{_includedir}/KF5/kglobalaccel_version.h
94%{_libdir}/cmake/KF5GlobalAccel
95%attr(755,root,root) %{_libdir}/libKF5GlobalAccel.so
96%{qt5dir}/mkspecs/modules/qt_KGlobalAccel.pri
This page took 0.043357 seconds and 4 git commands to generate.