]> git.pld-linux.org Git - packages/kernel.git/blame - kernel.spec
This commit was manufactured by cvs2git to create branch 'LINUX_2_6_16'.
[packages/kernel.git] / kernel.spec
CommitLineData
11b4fb9f 1# TODO:
878db323 2# - test pax stuff (btw. tested ok in softmode)
3# - prepare config for non SEGMEXEC capable archs (ie not x86/32bit)
4e6fef18
JK
4# - patch scripts/Makefile.xen not to require bash
5# - make PAE usage configurable when Xen is on
11b4fb9f 6# ALL
cf100084
ER
7# - #vserver: try to get a 2.2.x kernel patch or if you like development
8# features a 2.3.x one instead of the long discontinued 2.1.x you are using
9#
11b4fb9f 10# WARNING: Kernels from 2.6.16.X series not work under OldWorldMac
11#
12# Conditional build:
13%bcond_without smp # don't build SMP kernel
14%bcond_without up # don't build UP kernel
15%bcond_without source # don't build kernel-source package
16%bcond_without pcmcia # don't build pcmcia
17
18%bcond_with grsec_full # build full grsecurity
878db323 19%bcond_with pax # build PaX and full grsecurity
11b4fb9f 20%bcond_with verbose # verbose build (V=1)
21%bcond_with xen0 # added Xen0 support
22%bcond_with xenU # added XenU support
23%bcond_without grsecurity # don't build grsecurity at all
24%bcond_without grsec_minimal # build only minimal subset (proc,link,fifo,shm)
25
3092550a 26%bcond_without bootsplash # build with bootsplash instead of fbsplash
b0395610 27%bcond_with vesafb_tng # vesafb-tng, vesafb replacement from gentoo
11b4fb9f 28%bcond_with pae # build PAE (HIGHMEM64G) support on uniprocessor
29%bcond_with nfsroot # build with root on NFS support
6383a7ab 30%bcond_with reiserfs4 # build with ReiserFS 4 support
d959720d 31%bcond_with ext2compiled # compile ext2 into kernel to be able to boot from ext2 rootfs
11b4fb9f 32
33%{?debug:%define with_verbose 1}
34
9ac14f47 35%if %{without grsecurity}
11b4fb9f 36%undefine with_grsec_full
37%undefine with_grsec_minimal
878db323 38%undefine with_pax
39%endif
40
41%if %{with pax}
42%undefine with_grsec_minimal
43%undefine with_grsec_full
44%define with_grsecurity 1
11b4fb9f 45%endif
46
47%if %{with grsec_full}
48%undefine with_grsec_minimal
49%define with_grsecurity 1
50%endif
51
52%if %{with grsec_minimal}
53%undefine with_grsec_full
878db323 54%undefine with_pax
11b4fb9f 55%define with_grsecurity 1
56%endif
57
58%ifarch sparc
59# sparc32 is missing important updates from 2.5 cycle - won't build.
60%undefine with_smp
61%endif
62
63%ifarch ia64
64# broken
65%undefine with_up
66%endif
67
68%define have_drm 1
69%define have_oss 1
70%define have_sound 1
71
72%ifarch %{ix86} alpha ppc
73%define have_isa 1
74%else
75%define have_isa 0
76%endif
77
78%ifarch sparc sparc64
79%undefine with_pcmcia
80%define have_drm 0
81%define have_oss 0
82%endif
83
d4f08b76 84%if %{with xen0}
4e6fef18 85%define xen xen0
11f6a40e
JK
86%define dashxen \-xen0
87%define pae 1
4e6fef18
JK
88%else
89%if %{with xenU}
90%define xen xenU
11f6a40e
JK
91%define dashxen \-xenU
92%define pae 1
4e6fef18
JK
93%else
94%define xen %{nil}
11f6a40e 95%define dashxen %{nil}
4e6fef18
JK
96%endif
97%endif
98
67ea3fe1 99## Programs required by kernel to work.
11b4fb9f 100%define _binutils_ver 2.12.1
101%define _util_linux_ver 2.10o
102%define _module_init_tool_ver 0.9.10
103%define _e2fsprogs_ver 1.29
104%define _jfsutils_ver 1.1.3
105%define _reiserfsprogs_ver 3.6.3
106%define _reiser4progs_ver 1.0.0
107%define _xfsprogs_ver 2.6.0
108%define _pcmcia_cs_ver 3.1.21
109%define _pcmciautils_ver 004
110%define _quota_tools_ver 3.09
111%define _ppp_ver 1:2.4.0
112%define _isdn4k_utils_ver 3.1pre1
113%define _nfs_utils_ver 1.0.5
114%define _procps_ver 3.2.0
115%define _oprofile_ver 0.9
116%define _udev_ver 071
117%define _mkvmlinuz_ver 1.3
118
11b4fb9f 119%define _netfilter_snap 20060504
120%define _nf_hipac_ver 0.9.1
121
122%define _enable_debug_packages 0
11b4fb9f 123
124%define pcmcia_version 3.1.22
125%define drm_xfree_version 4.3.0
126
8204bf44 127%define squashfs_version 3.1
11b4fb9f 128%define suspend_version 2.2.5
129
130%define xen_version 3.0.2
131
d4f08b76 132%define _basever 2.6.16
2d025c77
AG
133%define _postver .56
134%define _rel 1
828151a9 135%define _subname %{?with_pax:-pax}%{?with_grsec_full:-grsecurity}%{?with_xen0:-xen0}%{?with_xenU:-xenU}
11b4fb9f 136Summary: The Linux kernel (the core of the Linux operating system)
137Summary(de): Der Linux-Kernel (Kern des Linux-Betriebssystems)
138Summary(fr): Le Kernel-Linux (La partie centrale du systeme)
139