]> git.pld-linux.org Git - packages/kernel.git/blame - kernel.spec
- updated to 2.6.16.53
[packages/kernel.git] / kernel.spec
CommitLineData
11b4fb9f 1# TODO:
878db323 2# - test pax stuff (btw. tested ok in softmode)
3# - prepare config for non SEGMEXEC capable archs (ie not x86/32bit)
4e6fef18
JK
4# - patch scripts/Makefile.xen not to require bash
5# - make PAE usage configurable when Xen is on
11b4fb9f 6# ALL
7# WARNING: Kernels from 2.6.16.X series not work under OldWorldMac
8#
9# Conditional build:
10%bcond_without smp # don't build SMP kernel
11%bcond_without up # don't build UP kernel
12%bcond_without source # don't build kernel-source package
13%bcond_without pcmcia # don't build pcmcia
14
15%bcond_with grsec_full # build full grsecurity
878db323 16%bcond_with pax # build PaX and full grsecurity
11b4fb9f 17%bcond_with verbose # verbose build (V=1)
18%bcond_with xen0 # added Xen0 support
19%bcond_with xenU # added XenU support
20%bcond_without grsecurity # don't build grsecurity at all
21%bcond_without grsec_minimal # build only minimal subset (proc,link,fifo,shm)
22
3092550a 23%bcond_without bootsplash # build with bootsplash instead of fbsplash
b0395610 24%bcond_with vesafb_tng # vesafb-tng, vesafb replacement from gentoo
11b4fb9f 25%bcond_with pae # build PAE (HIGHMEM64G) support on uniprocessor
26%bcond_with nfsroot # build with root on NFS support
6383a7ab 27%bcond_with reiserfs4 # build with ReiserFS 4 support
d959720d 28%bcond_with ext2compiled # compile ext2 into kernel to be able to boot from ext2 rootfs
11b4fb9f 29
30%{?debug:%define with_verbose 1}
31
9ac14f47 32%if %{without grsecurity}
11b4fb9f 33%undefine with_grsec_full
34%undefine with_grsec_minimal
878db323 35%undefine with_pax
36%endif
37
38%if %{with pax}
39%undefine with_grsec_minimal
40%undefine with_grsec_full
41%define with_grsecurity 1
11b4fb9f 42%endif
43
44%if %{with grsec_full}
45%undefine with_grsec_minimal
46%define with_grsecurity 1
47%endif
48
49%if %{with grsec_minimal}
50%undefine with_grsec_full
878db323 51%undefine with_pax
11b4fb9f 52%define with_grsecurity 1
53%endif
54
55%ifarch sparc
56# sparc32 is missing important updates from 2.5 cycle - won't build.
57%undefine with_smp
58%endif
59
60%ifarch ia64
61# broken
62%undefine with_up
63%endif
64
65%define have_drm 1
66%define have_oss 1
67%define have_sound 1
68
69%ifarch %{ix86} alpha ppc
70%define have_isa 1
71%else
72%define have_isa 0
73%endif
74
75%ifarch sparc sparc64
76%undefine with_pcmcia
77%define have_drm 0
78%define have_oss 0
79%endif
80
d4f08b76 81%if %{with xen0}
4e6fef18 82%define xen xen0
11f6a40e
JK
83%define dashxen \-xen0
84%define pae 1
4e6fef18
JK
85%else
86%if %{with xenU}
87%define xen xenU
11f6a40e
JK
88%define dashxen \-xenU
89%define pae 1
4e6fef18
JK
90%else
91%define xen %{nil}
11f6a40e 92%define dashxen %{nil}
4e6fef18
JK
93%endif
94%endif
95
67ea3fe1 96## Programs required by kernel to work.
11b4fb9f 97%define _binutils_ver 2.12.1
98%define _util_linux_ver 2.10o
99%define _module_init_tool_ver 0.9.10
100%define _e2fsprogs_ver 1.29
101%define _jfsutils_ver 1.1.3
102%define _reiserfsprogs_ver 3.6.3
103%define _reiser4progs_ver 1.0.0
104%define _xfsprogs_ver 2.6.0
105%define _pcmcia_cs_ver 3.1.21
106%define _pcmciautils_ver 004
107%define _quota_tools_ver 3.09
108%define _ppp_ver 1:2.4.0
109%define _isdn4k_utils_ver 3.1pre1
110%define _nfs_utils_ver 1.0.5
111%define _procps_ver 3.2.0
112%define _oprofile_ver 0.9
113%define _udev_ver 071
114%define _mkvmlinuz_ver 1.3
115
11b4fb9f 116%define _netfilter_snap 20060504
117%define _nf_hipac_ver 0.9.1
118
119%define _enable_debug_packages 0
11b4fb9f 120
121%define pcmcia_version 3.1.22
122%define drm_xfree_version 4.3.0
123
8204bf44 124%define squashfs_version 3.1
11b4fb9f 125%define suspend_version 2.2.5
126
127%define xen_version 3.0.2
128
d4f08b76 129%define _basever 2.6.16
54b9e9d9
AG
130%define _postver .53
131%define _rel 1
828151a9 132%define _subname %{?with_pax:-pax}%{?with_grsec_full:-grsecurity}%{?with_xen0:-xen0}%{?with_xenU:-xenU}
11b4fb9f 133Summary: The Linux kernel (the core of the Linux operating system)
134Summary(de): Der Linux-Kernel (Kern des Linux-Betriebssystems)
135Summary(fr): Le Kernel-Linux (La partie centrale du systeme)
136