]> git.pld-linux.org Git - projects/template-specs.git/blame - kernel-module.spec
- formatting
[projects/template-specs.git] / kernel-module.spec
CommitLineData
f9ab3660 1#
5ff61201
AM
2# Replace MODULE_NAME with real module name and MODULE_DIR
3# with required directory name.
4#
f9ab3660
PS
5# Conditional build:
6%bcond_without dist_kernel # allow non-distribution kernel
7%bcond_without kernel # don't build kernel modules
8%bcond_without smp # don't build SMP module
9%bcond_without userspace # don't build userspace module
10%bcond_with verbose # verbose build (V=1)
f9ab3660
PS
11#
12# main package.
13#
62d8299f
PS
14Summary: -
15Summary(pl): -
16Name: -
17Version: -
6e5f56d1
PS
18%define _rel 0.x
19Release: %{_rel}
62d8299f
PS
20Epoch: -
21License: - (enter GPL/LGPL/BSD/BSD-like/other license name here)
22Group: -
23Vendor: -
24Icon: -
25Source0: %{name}-%{version}.tar.gz
26# Source0-md5: -
27Source1: -
28# Source1-md5: -
29Patch0: %{name}-what.patch
30URL: -
063b9033
JB
31%if %{with kernel}
32%{?with_dist_kernel:BuildRequires: kernel-module-build >= 2.6.7}
33BuildRequires: rpmbuild(macros) >= 1.153
34%endif
62d8299f
PS
35BuildRequires: -
36PreReq: -
37Requires(pre,post): -
38Requires(preun): -
39Requires(postun): -
40Requires: -
41Provides: -
42Obsoletes: -
43Conflicts: -
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47
48%description -l pl
f9ab3660
PS
49
50# kernel subpackages.
51
52%package -n kernel-...
53Summary: Linux driver for ...
54Summary(pl): Sterownik dla Linuksa do ...
55Release: %{_rel}@%{_kernel_ver_str}
56Group: Base/Kernel
063b9033 57%{?with_dist_kernel:%requires_releq_kernel_up}
f9ab3660 58Requires(post,postun): /sbin/depmod
cef6d055 59%{?with_dist_kernel:Requires(postun): kernel}
f9ab3660 60
07a953a9 61%description -n kernel-...
f9ab3660
PS
62This is driver for ... for Linux.
63
64This package contains Linux module.
65
07a953a9 66%description -n kernel-... -l pl
f9ab3660
PS
67Sterownik dla Linuksa do ...
68
69