]> git.pld-linux.org Git - projects/template-specs.git/blame - kernel-module.spec
- (B)R: python-pygtk-gtk instead of python-pygtk
[projects/template-specs.git] / kernel-module.spec
CommitLineData
f9ab3660 1#
5ff61201
AM
2# Replace MODULE_NAME with real module name and MODULE_DIR
3# with required directory name.
4#
f9ab3660
PS
5# Conditional build:
6%bcond_without dist_kernel # allow non-distribution kernel
7%bcond_without kernel # don't build kernel modules
8%bcond_without smp # don't build SMP module
9%bcond_without userspace # don't build userspace module
10%bcond_with verbose # verbose build (V=1)
11
12#
13# main package.
14#
063b9033
JB
15%if %{with kernel}
16%{?with_dist_kernel:BuildRequires: kernel-module-build >= 2.6.7}
17BuildRequires: rpmbuild(macros) >= 1.153
18%endif
f9ab3660
PS
19
20# kernel subpackages.
21
22%package -n kernel-...
23Summary: Linux driver for ...
24Summary(pl): Sterownik dla Linuksa do ...
25Release: %{_rel}@%{_kernel_ver_str}
26Group: Base/Kernel
063b9033 27%{?with_dist_kernel:%requires_releq_kernel_up}
f9ab3660 28Requires(post,postun): /sbin/depmod
cef6d055 29%{?with_dist_kernel:Requires(postun): kernel}
f9ab3660
PS
30
31%description -n kernel-smp-...
32This is driver for ... for Linux.
33
34This package contains Linux module.
35
36%description -n kernel-smp-... -l pl
37Sterownik dla Linuksa do ...
38
39