]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blame - kde4-kdeplasma-addons.spec
- up to 4.6.5
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
CommitLineData
32c4451f 1# TODO:
2# Lancelot: installed - cmake unimplemented because not found
3# * XRender - Lancelot compositing support
4# * Eigen2 - Eigen2 enables the Mandelbrot wallpaper plugin.
c73f6b0c 5
6%bcond_without marble # don't build marble plasma support
7
32c4451f 8%define orgname kdeplasma-addons
9%define _state stable
c054b3a8 10%define qtver 4.7.3
1cf65df3 11
12Summary: KDE4 Plasmoids
b4bc4746 13Summary(pl.UTF-8): Plazmoidy dla KDE4
1cf65df3 14Name: kde4-kdeplasma-addons
c054b3a8 15Version: 4.6.5
a2052627 16Release: 1
1cf65df3 17License: GPL v2
18Group: X11/Applications
19Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
c054b3a8 20# Source0-md5: aa6cc294c723c874710a1118793f4724
9baaa66a 21Patch100: %{name}-branch.diff
28096eda 22Patch0: %{name}-pastebinpld.patch
7ab2d436 23URL: http://www.kde.org/
22957f69 24BuildRequires: OpenGL-GLU-devel
ae48935e 25BuildRequires: OpenGL-devel
32c4451f 26BuildRequires: QtNetwork-devel >= %{qtver}
28096eda 27BuildRequires: automoc4 >= 0.9.88
32c4451f 28BuildRequires: cmake >= 2.8.0
cae2d48b 29BuildRequires: eigen >= 1:2.0.12-3
1cf65df3 30BuildRequires: kde4-kdebase-workspace-devel >= %{version}
fa5beca3 31%{?with_marble:BuildRequires: kde4-kdeedu-devel >= %{version}}
c73f6b0c 32BuildRequires: kde4-kdegraphics-devel >= %{version}
1cf65df3 33BuildRequires: kde4-kdelibs-devel >= %{version}
34BuildRequires: kde4-kdepimlibs-devel >= %{version}
05a0aa81 35BuildRequires: phonon-devel >= 4.4.1
0915a2df 36BuildRequires: pkgconfig
37BuildRequires: python
fd153232 38BuildRequires: qca-devel >= 2.0.2
64ed9cbc 39BuildRequires: qimageblitz-devel >= 0.0.6
32c4451f 40BuildRequires: qt4-build >= %{qtver}
41BuildRequires: qt4-qmake >= %{qtver}
b86025ef 42BuildRequires: qwt-devel
50c904e6 43BuildRequires: rpmbuild(macros) >= 1.600
6352f2c4 44BuildRequires: scim-devel
05a0aa81 45BuildRequires: shared-desktop-ontologies-devel >= 0.5
46BuildRequires: soprano-devel >= 2.4.64
47BuildRequires: strigi-devel >= 0.7.2
32c4451f 48BuildRequires: xorg-lib-libXcomposite-devel
49BuildRequires: xorg-lib-libXdamage-devel
50BuildRequires: xorg-lib-libXrender-devel
75f86cc0 51BuildRequires: xorg-lib-libXtst-devel
1cf65df3 52Obsoletes: kde4-kdeplasmoids
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55%description
b4bc4746 56KDE4 plasmoids.
1cf65df3 57
58%description -l pl.UTF-8
b4bc4746 59Plazmoidy dla KDE4.
1cf65df3 60
28096eda 61%package lancelot
62Summary: Lancelot Desktop Theme
72db3ff2 63Summary(pl.UTF-8): Motyw pulpitu Lancelot
28096eda 64Group: X11/Applications
65Requires: kde4-kdebase-workspace >= %{version}
66
67%description lancelot
68Lancelot Desktop Theme.
69
70%description lancelot -l pl.UTF-8
72db3ff2 71Motyw pulpitu Lancelot.
28096eda 72
c73f6b0c 73%package devel
74Summary: Development files for KDE4 Plasmoids
75Summary(pl.UTF-8): Pliki nagłówkowe bibliotek plazmoidów dla KDE4
76Group: X11/Development/Libraries
77Requires: %{name} = %{version}-%{release}
0e26ec14 78Requires: kde4-kdebase-workspace-devel >= %{version}
79Requires: kde4-kdegraphics-devel >= %{version}
80Requires: kde4-kdelibs-devel >= %{version}
81Requires: kde4-kdepimlibs-devel >= %{version}
c73f6b0c 82
83%description devel
84This package contains header files needed if you wish to build
85applications based on KDE4 Plasmoids.
86
87%description devel -l pl.UTF-8
88Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
89opartych na plazmoidach dla KDE4.
90
1cf65df3 91%prep
92%setup -q -n %{orgname}-%{version}
508bd1fc 93#%patch100 -p0
db617da2 94#%patch0 -p1
1cf65df3 95
96%build
97install -d build
98cd build
99%cmake \
1cf65df3 100 ../
101
102%{__make}
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107%{__make} -C build install \
108 DESTDIR=$RPM_BUILD_ROOT
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
28096eda 116%post lancelot -p /sbin/ldconfig
117%postun lancelot -p /sbin/ldconfig
118
1cf65df3 119%files
120%defattr(644,root,root,755)
522d5a47 121%attr(755,root,root) %{_bindir}/kimpanel
1cf65df3 122%attr(755,root,root) %{_libdir}/kde4/krunner_*.so
28096eda 123%attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
05fc8ea2
RT
124%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bball.so
125%attr(755,root,root) %{_libdir}/kde4/plasma_applet_binaryclock.so
126%attr(755,root,root) %{_libdir}/kde4/plasma_applet_blackboard.so
127%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bookmarks.so
128%attr(755,root,root) %{_libdir}/kde4/plasma_applet_bubblemon.so
129%attr(755,root,root) %{_libdir}/kde4/plasma_applet_calculator.so
130%attr(755,root,root) %{_libdir}/kde4/plasma_applet_charselect.so
131%attr(755,root,root) %{_libdir}/kde4/plasma_applet_comic.so
132%attr(755,root,root) %{_libdir}/kde4/plasma_applet_dict.so
133%attr(755,root,root) %{_libdir}/kde4/plasma_applet_eyes.so
134%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fifteenPuzzle.so
135%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fileWatcher.so
136%attr(755,root,root) %{_libdir}/kde4/plasma_applet_frame.so
137%attr(755,root,root) %{_libdir}/kde4/plasma_applet_fuzzy_clock.so
138%attr(755,root,root) %{_libdir}/kde4/plasma_applet_incomingmsg.so
50c904e6 139%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kdeobservatory.so
522d5a47 140%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kimpanel.so
05fc8ea2
RT
141%attr(755,root,root) %{_libdir}/kde4/plasma_applet_knowledgebase.so
142%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kolourpicker.so
143%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konqprofiles.so
144%attr(755,root,root) %{_libdir}/kde4/plasma_applet_konsoleprofiles.so
145%attr(755,root,root) %{_libdir}/kde4/plasma_applet_leavenote.so
146%attr(755,root,root) %{_libdir}/kde4/plasma_applet_life.so
147%attr(755,root,root) %{_libdir}/kde4/plasma_applet_luna.so
148%attr(755,root,root) %{_libdir}/kde4/plasma_applet_magnifique.so
149%attr(755,root,root) %{_libdir}/kde4/plasma_applet_mediaplayer.so
150%attr(755,root,root) %{_libdir}/kde4/plasma_applet_microblog.so
151%attr(755,root,root) %{_libdir}/kde4/plasma_applet_news.so
152%attr(755,root,root) %{_libdir}/kde4/plasma_applet_notes.so
153%attr(755,root,root) %{_libdir}/kde4/plasma_applet_nowplaying.so
154%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop.so
155%attr(755,root,root) %{_libdir}/kde4/plasma_applet_opendesktop_activities.so
156%attr(755,root,root) %{_libdir}/kde4/plasma_applet_paste.so
157%attr(755,root,root) %{_libdir}/kde4/plasma_applet_pastebin.so
158%attr(755,root,root) %{_libdir}/kde4/plasma_applet_plasmaboard.so
159%attr(755,root,root) %{_libdir}/kde4/plasma_applet_previewer.so
160%attr(755,root,root) %{_libdir}/kde4/plasma_applet_qalculate.so
161%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rssnow.so
162%attr(755,root,root) %{_libdir}/kde4/plasma_applet_rtm.so
163%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdashboard.so
164%attr(755,root,root) %{_libdir}/kde4/plasma_applet_showdesktop.so
165%attr(755,root,root) %{_libdir}/kde4/plasma_applet_spellcheck.so
166%attr(755,root,root) %{_libdir}/kde4/plasma_applet_timer.so
167%attr(755,root,root) %{_libdir}/kde4/plasma_applet_unitconverter.so
168%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weather.so
169%attr(755,root,root) %{_libdir}/kde4/plasma_applet_weatherstation.so
170%attr(755,root,root) %{_libdir}/kde4/plasma_applet_webslice.so
1cf65df3 171%attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
172%attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
28096eda 173%attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
1cf65df3 174%attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
175%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
c73f6b0c 176%attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
177%attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
178%attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
179%attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
180%attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
181%attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
85896f2c 182%attr(755,root,root) %{_libdir}/kde4/plasma_runner_datetime.so
c73f6b0c 183%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
db617da2 184%attr(755,root,root) %{_libdir}/kde4/kcm_plasma_runner_events.so
185%attr(755,root,root) %{_libdir}/kde4/plasma_containment_griddesktop.so
186%attr(755,root,root) %{_libdir}/kde4/plasma_containment_groupingdesktop.so
187%attr(755,root,root) %{_libdir}/kde4/plasma_containment_groupingpanel.so
188%attr(755,root,root) %{_libdir}/kde4/plasma_runner_events.so
c73f6b0c 189%if %{with marble}
190%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
191%endif
192%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
193%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
194%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
522d5a47 195%attr(755,root,root) %{_libdir}/libkimpanelruntime.so.?
c73f6b0c 196%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
197%attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
198%attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
199%attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
200%attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
201%attr(755,root,root) %ghost %{_libdir}/librtm.so.?
202%attr(755,root,root) %{_libdir}/librtm.so.*.*.*
db617da2 203%attr(755,root,root) %ghost %{_libdir}/libplasma_groupingcontainment.so.?
204%attr(755,root,root) %{_libdir}/libplasma_groupingcontainment.so.*.*.*
522d5a47
AM
205%attr(755,root,root) %{_libdir}/scim-*/scim-panel-dbus
206%{_datadir}/config.kcfg/kimpanelconfig.kcfg
207%{_datadir}/dbus-1/interfaces/org.kde.impanel.xml
1cf65df3 208%{_datadir}/apps/desktoptheme/Aya
db617da2 209#%{_datadir}/apps/desktoptheme/Elegance
210#%{_datadir}/apps/desktoptheme/Silicon
28096eda 211%dir %{_datadir}/apps/desktoptheme/default/stylesheets
212%{_datadir}/apps/desktoptheme/default/stylesheets/*
213%dir %{_datadir}/apps/desktoptheme/default/weatherstation
214%{_datadir}/apps/desktoptheme/default/weatherstation/*
c73f6b0c 215%dir %{_datadir}/apps/desktoptheme/default/weather/
216%{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
1cf65df3 217%{_datadir}/apps/desktoptheme/default/widgets/*
db617da2 218#%{_datadir}/apps/desktoptheme/heron
1cf65df3 219%{_datadir}/apps/desktoptheme/slim-glow
05fc8ea2
RT
220%{_datadir}/kde4/services/CharRunner_config.desktop
221%{_datadir}/kde4/services/CharacterRunner.desktop
222%{_datadir}/kde4/services/apodprovider.desktop
223%{_datadir}/kde4/services/browserhistory.desktop
224%{_datadir}/kde4/services/epodprovider.desktop
225%{_datadir}/kde4/services/flickrprovider.desktop
226%{_datadir}/kde4/services/katesessions.desktop
227%{_datadir}/kde4/services/konquerorsessions.desktop
228%{_datadir}/kde4/services/konsolesessions.desktop
229%{_datadir}/kde4/services/oseiprovider.desktop
230%{_datadir}/kde4/services/plasma-applet-bball.desktop
231%{_datadir}/kde4/services/plasma-applet-binaryclock.desktop
232%{_datadir}/kde4/services/plasma-applet-blackboard.desktop
233%{_datadir}/kde4/services/plasma-applet-bookmarks.desktop
234%{_datadir}/kde4/services/plasma-applet-bubblemon.desktop
235%{_datadir}/kde4/services/plasma-applet-calculator.desktop
236%{_datadir}/kde4/services/plasma-applet-charselect.desktop
237%{_datadir}/kde4/services/plasma-applet-eyes.desktop
238%{_datadir}/kde4/services/plasma-applet-fifteenPuzzle.desktop
239%{_datadir}/kde4/services/plasma-applet-incomingmsg.desktop
50c904e6 240%{_datadir}/kde4/services/plasma-applet-kdeobservatory.desktop
522d5a47 241%{_datadir}/kde4/services/plasma-applet-kimpanel.desktop
05fc8ea2
RT
242%{_datadir}/kde4/services/plasma-applet-knowledgebase.desktop
243%{_datadir}/kde4/services/plasma-applet-konqprofiles.desktop
244%{_datadir}/kde4/services/plasma-applet-konsoleprofiles.desktop
245%{_datadir}/kde4/services/plasma-applet-leavenote.desktop
246%{_datadir}/kde4/services/plasma-applet-life.desktop
247%{_datadir}/kde4/services/plasma-applet-luna.desktop
248%{_datadir}/kde4/services/plasma-applet-magnifique.desktop
249%{_datadir}/kde4/services/plasma-applet-mediaplayer.desktop
250%{_datadir}/kde4/services/plasma-applet-microblog.desktop
251%{_datadir}/kde4/services/plasma-applet-news.desktop
252%{_datadir}/kde4/services/plasma-applet-nowplaying.desktop
253%{_datadir}/kde4/services/plasma-applet-opendesktop-activities.desktop
254%{_datadir}/kde4/services/plasma-applet-opendesktop.desktop
255%{_datadir}/kde4/services/plasma-applet-paste.desktop
256%{_datadir}/kde4/services/plasma-applet-pastebin.desktop
257%{_datadir}/kde4/services/plasma-applet-previewer.desktop
258%{_datadir}/kde4/services/plasma-applet-qalculate.desktop
259%{_datadir}/kde4/services/plasma-applet-rememberthemilk.desktop
260%{_datadir}/kde4/services/plasma-applet-rssnow.desktop
261%{_datadir}/kde4/services/plasma-applet-showdashboard.desktop
262%{_datadir}/kde4/services/plasma-applet-showdesktop.desktop
263%{_datadir}/kde4/services/plasma-applet-spellcheck.desktop
264%{_datadir}/kde4/services/plasma-applet-systemloadviewer.desktop
265%{_datadir}/kde4/services/plasma-applet-timer.desktop
266%{_datadir}/kde4/services/plasma-applet-unitconverter.desktop
267%{_datadir}/kde4/services/plasma-applet-weather.desktop
268%{_datadir}/kde4/services/plasma-applet-weatherstation.desktop
269%{_datadir}/kde4/services/plasma-applet-webslice.desktop
270%{_datadir}/kde4/services/plasma-clock-fuzzy.desktop
271%{_datadir}/kde4/services/plasma-comic-default.desktop
272%{_datadir}/kde4/services/plasma-dataengine-comic.desktop
273%{_datadir}/kde4/services/plasma-dataengine-microblog.desktop
274%{_datadir}/kde4/services/plasma-dataengine-ocs.desktop
275%{_datadir}/kde4/services/plasma-dataengine-potd.desktop
276%{_datadir}/kde4/services/plasma-dict-default.desktop
277%{_datadir}/kde4/services/plasma-engine-kdeobservatory.desktop
db617da2 278#%{_datadir}/kde4/services/plasma-engine-pastebin.desktop
05fc8ea2
RT
279%{_datadir}/kde4/services/plasma-engine-rtm.desktop
280%{_datadir}/kde4/services/plasma-fileWatcher-default.desktop
281%{_datadir}/kde4/services/plasma-frame-default.desktop
282%{_datadir}/kde4/services/plasma-kolourpicker-default.desktop
283%{_datadir}/kde4/services/plasma-notes-default.desktop
284%{_datadir}/kde4/services/plasma-packagestructure-comic.desktop
285%{_datadir}/kde4/services/plasma-runner-audioplayercontrol.desktop
286%{_datadir}/kde4/services/plasma-runner-audioplayercontrol_config.desktop
287%{_datadir}/kde4/services/plasma-runner-contacts.desktop
288%{_datadir}/kde4/services/plasma-runner-converter.desktop
289%{_datadir}/kde4/services/plasma-runner-datetime.desktop
290%{_datadir}/kde4/services/plasma-runner-kopete.desktop
291%{_datadir}/kde4/services/plasma-runner-spellchecker.desktop
292%{_datadir}/kde4/services/plasma-runner-spellchecker_config.desktop
293%{_datadir}/kde4/services/plasma-runner-techbase.desktop
294%{_datadir}/kde4/services/plasma-runner-wikipedia.desktop
295%{_datadir}/kde4/services/plasma-runner-wikitravel.desktop
296%{_datadir}/kde4/services/plasma-wallpaper-mandelbrot.desktop
297%{_datadir}/kde4/services/plasma-wallpaper-marble.desktop
298%{_datadir}/kde4/services/plasma-wallpaper-pattern.desktop
299%{_datadir}/kde4/services/plasma-wallpaper-virus.desktop
300%{_datadir}/kde4/services/plasma-wallpaper-weather.desktop
301%{_datadir}/kde4/services/plasma_applet_plasmaboard.desktop
302%{_datadir}/kde4/services/wcpotdprovider.desktop
1cf65df3 303%{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
c73f6b0c 304%{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
28096eda 305%{_datadir}/config/comic.knsrc
32c4451f 306%{_datadir}/config/plasmaweather.knsrc
c73f6b0c 307%{_datadir}/config/virus_wallpaper.knsrc
28096eda 308%dir %{_datadir}/apps/desktoptheme/default/rssnow
309%{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
310%{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
311%{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
312%{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
c73f6b0c 313%dir %{_datadir}/apps/desktoptheme/default/bubblemon
314%{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
315%dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
32c4451f 316%{_datadir}/apps/desktoptheme/default/fifteenPuzzle/blanksquare.svg
c73f6b0c 317%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
32c4451f 318%{_iconsdir}/hicolor/scalable/apps/accessories-dictionary.svgz
319%{_iconsdir}/hicolor/scalable/apps/bball.svgz
544dba0a 320%{_iconsdir}/hicolor/*x*/apps/qalculate-applet.png
85896f2c 321%{_iconsdir}/hicolor/*x*/apps/plasmaapplet-shelf.png
5d543186
AM
322%{_iconsdir}/hicolor/*x*/apps/eyes.png
323%{_iconsdir}/hicolor/*x*/apps/kdeobservatory.png
324%{_iconsdir}/hicolor/*x*/apps/lifegame.png
325%{_iconsdir}/hicolor/*x*/apps/luna.png
db617da2 326%{_datadir}/config/pastebin.knsrc
28096eda 327%dir %{_datadir}/apps/rssnow
328%{_datadir}/apps/rssnow/feeds
329%{_iconsdir}/*/*x*/apps/previewer.png
28096eda 330%{_datadir}/kde4/services/ServiceMenus/preview.desktop
331%dir %{_datadir}/apps/bball
332%{_datadir}/apps/bball/bball.svgz
32c4451f 333%{_iconsdir}/*/*x*/apps/bball.png
28096eda 334%{_datadir}/apps/bball/bounce.ogg
335%{_datadir}/apps/bball/football.svgz
c73f6b0c 336%{_datadir}/apps/plasma
85896f2c 337%{_datadir}/apps/plasmaboard
c73f6b0c 338%{_datadir}/apps/plasma-applet-opendesktop
32c4451f 339%{_datadir}/apps/plasma-applet-opendesktop-activities
340%{_datadir}/apps/plasma-applet-frame
c73f6b0c 341%{_datadir}/apps/plasma_pastebin
342%{_datadir}/apps/plasma_wallpaper_pattern
db617da2 343%{_datadir}/kde4/services/lancelot.desktop
344%{_datadir}/kde4/services/plasma-containment-griddesktop.desktop
345%{_datadir}/kde4/services/plasma-containment-groupingdesktop.desktop
346%{_datadir}/kde4/services/plasma-containment-groupingpanel.desktop
347%{_datadir}/kde4/services/plasma-runner-events.desktop
348%{_datadir}/kde4/services/plasma-runner-events_config.desktop
28096eda 349
350%files lancelot
351%defattr(644,root,root,755)
352%attr(755,root,root) %{_bindir}/lancelot
353%attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
354%attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
05fc8ea2
RT
355%attr(755,root,root) %{_libdir}/liblancelot.so
356%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.?
357%attr(755,root,root) %{_libdir}/liblancelot-datamodels.so.*.*.*
358%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_launcher.so
359%attr(755,root,root) %{_libdir}/kde4/plasma_applet_lancelot_part.so
28096eda 360%{_datadir}/apps/desktoptheme/default/lancelot
32c4451f 361%{_datadir}/apps/desktoptheme/oxygen/lancelot
05fc8ea2
RT
362%{_datadir}/kde4/services/plasma-applet-lancelot-launcher.desktop
363%{_datadir}/kde4/services/plasma-applet-lancelot-part.desktop
db617da2 364#%{_datadir}/dbus-1/services/org.kde.lancelot.service
28096eda 365%{_datadir}/mime/packages/lancelotpart-mime.xml
c73f6b0c 366%{_datadir}/apps/lancelot
28096eda 367%{_iconsdir}/hicolor/*x*/apps/lancelot.png
85896f2c 368%{_iconsdir}/hicolor/*x*/apps/lancelot-start.png
c73f6b0c 369
370%files devel
371%defattr(644,root,root,755)
372%attr(755,root,root) %{_libdir}/*.so
05fc8ea2
RT
373%{_includedir}/KDE/Lancelot
374%{_includedir}/lancelot-datamodels
c73f6b0c 375%{_includedir}/lancelot
40f03c32 376%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.122327 seconds and 4 git commands to generate.