]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blame - kde4-kdeplasma-addons.spec
- 4.3.5
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
CommitLineData
c73f6b0c 1
2%bcond_without marble # don't build marble plasma support
3
1cf65df3 4%define orgname kdeplasma-addons
57887d81 5%define _state stable
13d438a0 6%define _qtver 4.5.3
1cf65df3 7
8Summary: KDE4 Plasmoids
b4bc4746 9Summary(pl.UTF-8): Plazmoidy dla KDE4
1cf65df3 10Name: kde4-kdeplasma-addons
4416ae9c 11Version: 4.3.5
508bd1fc 12Release: 1
1cf65df3 13License: GPL v2
14Group: X11/Applications
15Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
4416ae9c 16# Source0-md5: cc1dbdc54760f3e7ded6ca6a717ee6da
c73f6b0c 17#Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
9baaa66a 18Patch100: %{name}-branch.diff
28096eda 19Patch0: %{name}-pastebinpld.patch
7ab2d436 20URL: http://www.kde.org/
22957f69 21BuildRequires: OpenGL-GLU-devel
ae48935e 22BuildRequires: OpenGL-devel
1cf65df3 23BuildRequires: QtCore-devel >= %{_qtver}
75f86cc0 24BuildRequires: QtNetwork-devel >= %{_qtver}
ae48935e 25BuildRequires: QtOpenGL-devel >= %{_qtver}
28096eda 26BuildRequires: QtScript-devel >= %{_qtver}
75f86cc0 27BuildRequires: QtSvg-devel >= %{_qtver}
28096eda 28BuildRequires: QtWebKit-devel >= %{_qtver}
29BuildRequires: automoc4 >= 0.9.88
bad3bd06 30BuildRequires: cmake >= 2.6.3
c73f6b0c 31BuildRequires: eigen-devel >= 2.0.51
1cf65df3 32BuildRequires: kde4-kdebase-workspace-devel >= %{version}
fa5beca3 33%{?with_marble:BuildRequires: kde4-kdeedu-devel >= %{version}}
c73f6b0c 34BuildRequires: kde4-kdegraphics-devel >= %{version}
1cf65df3 35BuildRequires: kde4-kdelibs-devel >= %{version}
36BuildRequires: kde4-kdepimlibs-devel >= %{version}
f1ec62d6 37BuildRequires: phonon-devel >= 4.3.1
fa5beca3 38BuildRequires: pkgconfig
39BuildRequires: python
40BuildRequires: python-modules
41BuildRequires: qimageblitz-devel
1cf65df3 42BuildRequires: qt4-build >= %{_qtver}
43BuildRequires: qt4-qmake >= %{_qtver}
44BuildRequires: rpmbuild(macros) >= 1.293
ee644e19 45BuildRequires: soprano-devel
c73f6b0c 46BuildRequires: strigi-devel >= 0.6.5
47BuildRequires: xorg-lib-libXcomposite
48BuildRequires: xorg-lib-libXdamage
49BuildRequires: xorg-lib-libXrender
75f86cc0 50BuildRequires: xorg-lib-libXtst-devel
1cf65df3 51Obsoletes: kde4-kdeplasmoids
52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54%description
b4bc4746 55KDE4 plasmoids.
1cf65df3 56
57%description -l pl.UTF-8
b4bc4746 58Plazmoidy dla KDE4.
1cf65df3 59
28096eda 60%package lancelot
61Summary: Lancelot Desktop Theme
72db3ff2 62Summary(pl.UTF-8): Motyw pulpitu Lancelot
28096eda 63Group: X11/Applications
64Requires: kde4-kdebase-workspace >= %{version}
65
66%description lancelot
67Lancelot Desktop Theme.
68
69%description lancelot -l pl.UTF-8
72db3ff2 70Motyw pulpitu Lancelot.
28096eda 71
c73f6b0c 72%package devel
73Summary: Development files for KDE4 Plasmoids
74Summary(pl.UTF-8): Pliki nagłówkowe bibliotek plazmoidów dla KDE4
75Group: X11/Development/Libraries
76Requires: %{name} = %{version}-%{release}
0e26ec14 77Requires: kde4-kdebase-workspace-devel >= %{version}
78Requires: kde4-kdegraphics-devel >= %{version}
79Requires: kde4-kdelibs-devel >= %{version}
80Requires: kde4-kdepimlibs-devel >= %{version}
c73f6b0c 81
82%description devel
83This package contains header files needed if you wish to build
84applications based on KDE4 Plasmoids.
85
86%description devel -l pl.UTF-8
87Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
88opartych na plazmoidach dla KDE4.
89
1cf65df3 90%prep
91%setup -q -n %{orgname}-%{version}
508bd1fc 92#%patch100 -p0
28096eda 93%patch0 -p1
1cf65df3 94
95%build
96install -d build
97cd build
98%cmake \
99 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
c73f6b0c 100 -DLIB_INSTALL_DIR=%{_libdir} \
07563c11 101 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
1cf65df3 102%if "%{_lib}" != "lib"
103 -DLIB_SUFFIX=64 \
104%endif
105 ../
106
107%{__make}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%{__make} -C build install \
113 DESTDIR=$RPM_BUILD_ROOT
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
120
28096eda 121%post lancelot -p /sbin/ldconfig
122%postun lancelot -p /sbin/ldconfig
123
1cf65df3 124%files
125%defattr(644,root,root,755)
126%attr(755,root,root) %{_libdir}/kde4/krunner_*.so
28096eda 127%attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
1cf65df3 128%attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
129%attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
130%attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
28096eda 131%attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
1cf65df3 132%attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
133%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
c73f6b0c 134%attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
135%attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
136%attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
137%attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
138%attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
139%attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
140%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
141%if %{with marble}
142%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
143%endif
144%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
145%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
146%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
147%attr(755,root,root) %ghost %{_libdir}/libconversion.so.?
148%attr(755,root,root) %{_libdir}/libconversion.so.*.*.*
149%attr(755,root,root) %{_libdir}/liblancelot.so
150%attr(755,root,root) %ghost %{_libdir}/libocsclient.so.?
151%attr(755,root,root) %{_libdir}/libocsclient.so.*.*.*
152%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
153%attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
154%attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
155%attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
156%attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
157%attr(755,root,root) %ghost %{_libdir}/librtm.so.?
158%attr(755,root,root) %{_libdir}/librtm.so.*.*.*
1cf65df3 159%{_datadir}/apps/desktoptheme/Aya
160%{_datadir}/apps/desktoptheme/Elegance
161%{_datadir}/apps/desktoptheme/Silicon
28096eda 162%dir %{_datadir}/apps/desktoptheme/default/stylesheets
163%{_datadir}/apps/desktoptheme/default/stylesheets/*
164%dir %{_datadir}/apps/desktoptheme/default/weatherstation
165%{_datadir}/apps/desktoptheme/default/weatherstation/*
c73f6b0c 166%dir %{_datadir}/apps/desktoptheme/default/weather/
167%{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
1cf65df3 168%{_datadir}/apps/desktoptheme/default/widgets/*
169%{_datadir}/apps/desktoptheme/heron
170%{_datadir}/apps/desktoptheme/slim-glow
1cf65df3 171%{_datadir}/kde4/services/*.desktop
172%{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
c73f6b0c 173%{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
28096eda 174%{_datadir}/config/comic.knsrc
c73f6b0c 175%{_datadir}/config/virus_wallpaper.knsrc
28096eda 176%dir %{_datadir}/apps/desktoptheme/default/rssnow
177%{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
178%{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
179%{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
180%{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
c73f6b0c 181%dir %{_datadir}/apps/desktoptheme/default/bubblemon
182%{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
183%dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
184%{_datadir}/apps/desktoptheme/default/fifteenPuzzle/greensquare.svgz
185%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
186
28096eda 187%dir %{_datadir}/apps/rssnow
188%{_datadir}/apps/rssnow/feeds
189%{_iconsdir}/*/*x*/apps/previewer.png
28096eda 190%{_datadir}/kde4/services/ServiceMenus/preview.desktop
191%dir %{_datadir}/apps/bball
192%{_datadir}/apps/bball/bball.svgz
193%{_datadir}/apps/bball/bounce.ogg
194%{_datadir}/apps/bball/football.svgz
c73f6b0c 195#%{_datadir}/apps/plasma-bluemarble
196%{_datadir}/apps/plasma
197%{_datadir}/apps/plasma-applet-opendesktop
198%{_datadir}/apps/plasma_pastebin
199%{_datadir}/apps/plasma_wallpaper_pattern
28096eda 200
201%files lancelot
202%defattr(644,root,root,755)
203%attr(755,root,root) %{_bindir}/lancelot
204%attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
205%attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
206%{_datadir}/apps/desktoptheme/default/lancelot
c73f6b0c 207#%{_datadir}/apps/desktoptheme/air/
208
28096eda 209%{_datadir}/dbus-1/services/org.kde.lancelot.service
210%{_datadir}/mime/packages/lancelotpart-mime.xml
c73f6b0c 211%{_datadir}/apps/lancelot
28096eda 212%{_iconsdir}/hicolor/*x*/apps/lancelot.png
213%{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
c73f6b0c 214
215%files devel
216%defattr(644,root,root,755)
217%attr(755,root,root) %{_libdir}/*.so
218%{_includedir}/conversion
219%{_includedir}/lancelot
220%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.122555 seconds and 4 git commands to generate.