]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blame - kde4-kdeplasma-addons.spec
- 4.4.5
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
CommitLineData
32c4451f 1# TODO:
2# Lancelot: installed - cmake unimplemented because not found
3# * XRender - Lancelot compositing support
4# * Eigen2 - Eigen2 enables the Mandelbrot wallpaper plugin.
c73f6b0c 5
6%bcond_without marble # don't build marble plasma support
7
32c4451f 8%define orgname kdeplasma-addons
9%define _state stable
d472d97f 10%define qtver 4.6.3
1cf65df3 11
12Summary: KDE4 Plasmoids
b4bc4746 13Summary(pl.UTF-8): Plazmoidy dla KDE4
1cf65df3 14Name: kde4-kdeplasma-addons
d472d97f 15Version: 4.4.5
508bd1fc 16Release: 1
1cf65df3 17License: GPL v2
18Group: X11/Applications
19Source0: ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
d472d97f 20# Source0-md5: cdc027b3dfdcc588f253006baa970638
9baaa66a 21Patch100: %{name}-branch.diff
28096eda 22Patch0: %{name}-pastebinpld.patch
7ab2d436 23URL: http://www.kde.org/
22957f69 24BuildRequires: OpenGL-GLU-devel
ae48935e 25BuildRequires: OpenGL-devel
32c4451f 26BuildRequires: QtCore-devel >= %{qtver}
27BuildRequires: QtNetwork-devel >= %{qtver}
28BuildRequires: QtOpenGL-devel >= %{qtver}
29BuildRequires: QtScript-devel >= %{qtver}
30BuildRequires: QtSvg-devel >= %{qtver}
31BuildRequires: QtWebKit-devel >= %{qtver}
28096eda 32BuildRequires: automoc4 >= 0.9.88
32c4451f 33BuildRequires: cmake >= 2.8.0
cae2d48b 34BuildRequires: eigen >= 1:2.0.12-3
1cf65df3 35BuildRequires: kde4-kdebase-workspace-devel >= %{version}
fa5beca3 36%{?with_marble:BuildRequires: kde4-kdeedu-devel >= %{version}}
c73f6b0c 37BuildRequires: kde4-kdegraphics-devel >= %{version}
1cf65df3 38BuildRequires: kde4-kdelibs-devel >= %{version}
39BuildRequires: kde4-kdepimlibs-devel >= %{version}
32c4451f 40BuildRequires: phonon-devel >= 4.3.80
0915a2df 41BuildRequires: pkgconfig
42BuildRequires: python
43BuildRequires: qimageblitz-devel
32c4451f 44BuildRequires: qt4-build >= %{qtver}
45BuildRequires: qt4-qmake >= %{qtver}
1cf65df3 46BuildRequires: rpmbuild(macros) >= 1.293
32c4451f 47BuildRequires: shared-desktop-ontologies-devel >= 0.2
0915a2df 48BuildRequires: soprano-devel
32c4451f 49BuildRequires: strigi-devel >= 0.7.0
50BuildRequires: xorg-lib-libXcomposite-devel
51BuildRequires: xorg-lib-libXdamage-devel
52BuildRequires: xorg-lib-libXrender-devel
75f86cc0 53BuildRequires: xorg-lib-libXtst-devel
1cf65df3 54Obsoletes: kde4-kdeplasmoids
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57%description
b4bc4746 58KDE4 plasmoids.
1cf65df3 59
60%description -l pl.UTF-8
b4bc4746 61Plazmoidy dla KDE4.
1cf65df3 62
28096eda 63%package lancelot
64Summary: Lancelot Desktop Theme
72db3ff2 65Summary(pl.UTF-8): Motyw pulpitu Lancelot
28096eda 66Group: X11/Applications
67Requires: kde4-kdebase-workspace >= %{version}
68
69%description lancelot
70Lancelot Desktop Theme.
71
72%description lancelot -l pl.UTF-8
72db3ff2 73Motyw pulpitu Lancelot.
28096eda 74
c73f6b0c 75%package devel
76Summary: Development files for KDE4 Plasmoids
77Summary(pl.UTF-8): Pliki nagłówkowe bibliotek plazmoidów dla KDE4
78Group: X11/Development/Libraries
79Requires: %{name} = %{version}-%{release}
0e26ec14 80Requires: kde4-kdebase-workspace-devel >= %{version}
81Requires: kde4-kdegraphics-devel >= %{version}
82Requires: kde4-kdelibs-devel >= %{version}
83Requires: kde4-kdepimlibs-devel >= %{version}
c73f6b0c 84
85%description devel
86This package contains header files needed if you wish to build
87applications based on KDE4 Plasmoids.
88
89%description devel -l pl.UTF-8
90Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
91opartych na plazmoidach dla KDE4.
92
1cf65df3 93%prep
94%setup -q -n %{orgname}-%{version}
508bd1fc 95#%patch100 -p0
28096eda 96%patch0 -p1
1cf65df3 97
98%build
99install -d build
100cd build
101%cmake \
102 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
c73f6b0c 103 -DLIB_INSTALL_DIR=%{_libdir} \
07563c11 104 -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
1cf65df3 105%if "%{_lib}" != "lib"
106 -DLIB_SUFFIX=64 \
107%endif
108 ../
109
110%{__make}
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115%{__make} -C build install \
116 DESTDIR=$RPM_BUILD_ROOT
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post -p /sbin/ldconfig
122%postun -p /sbin/ldconfig
123
28096eda 124%post lancelot -p /sbin/ldconfig
125%postun lancelot -p /sbin/ldconfig
126
1cf65df3 127%files
128%defattr(644,root,root,755)
129%attr(755,root,root) %{_libdir}/kde4/krunner_*.so
28096eda 130%attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
1cf65df3 131%attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
132%attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
133%attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
28096eda 134%attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
1cf65df3 135%attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
136%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
c73f6b0c 137%attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
138%attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
139%attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
140%attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
141%attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
142%attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
143%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
144%if %{with marble}
145%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
146%endif
147%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
148%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
149%attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
32c4451f 150#%attr(755,root,root) %ghost %{_libdir}/libconversion.so.?
151#%attr(755,root,root) %{_libdir}/libconversion.so.*.*.*
c73f6b0c 152%attr(755,root,root) %{_libdir}/liblancelot.so
32c4451f 153#%attr(755,root,root) %ghost %{_libdir}/libocsclient.so.?
154#%attr(755,root,root) %{_libdir}/libocsclient.so.*.*.*
c73f6b0c 155%attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
156%attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
157%attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
158%attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
159%attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
160%attr(755,root,root) %ghost %{_libdir}/librtm.so.?
161%attr(755,root,root) %{_libdir}/librtm.so.*.*.*
1cf65df3 162%{_datadir}/apps/desktoptheme/Aya
163%{_datadir}/apps/desktoptheme/Elegance
164%{_datadir}/apps/desktoptheme/Silicon
28096eda 165%dir %{_datadir}/apps/desktoptheme/default/stylesheets
166%{_datadir}/apps/desktoptheme/default/stylesheets/*
167%dir %{_datadir}/apps/desktoptheme/default/weatherstation
168%{_datadir}/apps/desktoptheme/default/weatherstation/*
c73f6b0c 169%dir %{_datadir}/apps/desktoptheme/default/weather/
170%{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
1cf65df3 171%{_datadir}/apps/desktoptheme/default/widgets/*
172%{_datadir}/apps/desktoptheme/heron
173%{_datadir}/apps/desktoptheme/slim-glow
1cf65df3 174%{_datadir}/kde4/services/*.desktop
175%{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
c73f6b0c 176%{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
28096eda 177%{_datadir}/config/comic.knsrc
32c4451f 178%{_datadir}/config/plasmaweather.knsrc
c73f6b0c 179%{_datadir}/config/virus_wallpaper.knsrc
28096eda 180%dir %{_datadir}/apps/desktoptheme/default/rssnow
181%{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
182%{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
183%{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
184%{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
c73f6b0c 185%dir %{_datadir}/apps/desktoptheme/default/bubblemon
186%{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
187%dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
32c4451f 188%{_datadir}/apps/desktoptheme/default/fifteenPuzzle/blanksquare.svg
c73f6b0c 189%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
32c4451f 190%{_iconsdir}/hicolor/scalable/apps/accessories-dictionary.svgz
191%{_iconsdir}/hicolor/scalable/apps/bball.svgz
544dba0a 192%{_iconsdir}/hicolor/*x*/apps/qalculate-applet.png
c73f6b0c 193
28096eda 194%dir %{_datadir}/apps/rssnow
195%{_datadir}/apps/rssnow/feeds
196%{_iconsdir}/*/*x*/apps/previewer.png
28096eda 197%{_datadir}/kde4/services/ServiceMenus/preview.desktop
198%dir %{_datadir}/apps/bball
199%{_datadir}/apps/bball/bball.svgz
32c4451f 200%{_iconsdir}/*/*x*/apps/bball.png
28096eda 201%{_datadir}/apps/bball/bounce.ogg
202%{_datadir}/apps/bball/football.svgz
c73f6b0c 203#%{_datadir}/apps/plasma-bluemarble
204%{_datadir}/apps/plasma
205%{_datadir}/apps/plasma-applet-opendesktop
32c4451f 206%{_datadir}/apps/plasma-applet-opendesktop-activities
207%{_datadir}/apps/plasma-applet-frame
c73f6b0c 208%{_datadir}/apps/plasma_pastebin
209%{_datadir}/apps/plasma_wallpaper_pattern
28096eda 210
211%files lancelot
212%defattr(644,root,root,755)
213%attr(755,root,root) %{_bindir}/lancelot
214%attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
215%attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
216%{_datadir}/apps/desktoptheme/default/lancelot
32c4451f 217%{_datadir}/apps/desktoptheme/oxygen/lancelot
c73f6b0c 218#%{_datadir}/apps/desktoptheme/air/
219
28096eda 220%{_datadir}/dbus-1/services/org.kde.lancelot.service
221%{_datadir}/mime/packages/lancelotpart-mime.xml
c73f6b0c 222%{_datadir}/apps/lancelot
28096eda 223%{_iconsdir}/hicolor/*x*/apps/lancelot.png
224%{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
c73f6b0c 225
226%files devel
227%defattr(644,root,root,755)
228%attr(755,root,root) %{_libdir}/*.so
32c4451f 229#%{_includedir}/conversion
c73f6b0c 230%{_includedir}/lancelot
32c4451f 231#%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.170692 seconds and 4 git commands to generate.