]> git.pld-linux.org Git - packages/ka5-kontact.git/blame - ka5-kontact.spec
- updated to 23.08.5
[packages/ka5-kontact.git] / ka5-kontact.spec
CommitLineData
fd5eb0a9
WF
1#
2# Conditional build:
3%bcond_with tests # build with tests
3f771662 4%define kdeappsver 23.08.5
8a9e888d
WF
5%define kframever 5.94.0
6%define qtver 5.15.2
3afc98c6
WF
7%define kaname kontact
8Summary: kontact
9Name: ka5-%{kaname}
3f771662 10Version: 23.08.5
1fae9ddb 11Release: 1
3afc98c6
WF
12License: GPL v2+/LGPL v2.1+
13Group: X11/Applications
1fae9ddb 14Source0: https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
3f771662 15# Source0-md5: b396a793ef1bc7bbcc8a51a6d2befd4f
3afc98c6 16URL: http://www.kde.org/
1fae9ddb
WF
17BuildRequires: Qt5Core-devel >= %{qtver}
18BuildRequires: Qt5DBus-devel
19BuildRequires: Qt5Gui-devel >= 5.11.1
20BuildRequires: Qt5Network-devel >= 5.11.1
21BuildRequires: Qt5Positioning-devel >= 5.11.1
22BuildRequires: Qt5PrintSupport-devel >= 5.11.1
23BuildRequires: Qt5Qml-devel >= 5.11.1
24BuildRequires: Qt5Quick-devel >= 5.11.1
25BuildRequires: Qt5WebChannel-devel >= 5.11.1
26BuildRequires: Qt5WebEngine-devel
27BuildRequires: Qt5Widgets-devel
8c4f21d6 28BuildRequires: cmake >= 3.20
3afc98c6 29BuildRequires: gettext-devel
0cfd155d
WF
30BuildRequires: ka5-akonadi-devel >= %{kdeappsver}
31BuildRequires: ka5-grantleetheme-devel >= %{kdeappsver}
0cfd155d
WF
32BuildRequires: ka5-kontactinterface-devel >= %{kdeappsver}
33BuildRequires: ka5-kpimtextedit-devel >= %{kdeappsver}
34BuildRequires: ka5-libkdepim-devel >= %{kdeappsver}
1fae9ddb
WF
35BuildRequires: kf5-extra-cmake-modules >= %{kframever}
36BuildRequires: kf5-kcmutils-devel >= %{kframever}
37BuildRequires: kf5-kcrash-devel >= %{kframever}
38BuildRequires: kf5-kdbusaddons-devel >= %{kframever}
39BuildRequires: kf5-kdoctools-devel >= %{kframever}
40BuildRequires: kf5-kiconthemes-devel >= %{kframever}
41BuildRequires: kf5-kwindowsystem-devel >= %{kframever}
0cfd155d 42BuildRequires: ninja
1fae9ddb 43BuildRequires: qt5-build >= %{qtver}
3afc98c6
WF
44BuildRequires: rpmbuild(macros) >= 1.164
45BuildRequires: shared-mime-info
46BuildRequires: tar >= 1:1.22
47BuildRequires: xz
c27f05a8 48ExcludeArch: x32
3afc98c6
WF
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%description
52Kontact is the integrated solution to your personal information
53management (PIM) needs. It combines well-known KDE applications like
54KMail, KOrganizer and KAddressBook into a single interface to provide
55easy access to mail, scheduling, address book and other PIM
56functionality.
57
fc580692
WF
58%description -l pl.UTF-8
59Kontact jest zintegrowanym rozwiązaniem do zarządzania informacją
9ac7b09b
WF
60osobistą (PIM). W jego skład wchodzą dobrze znane aplikacje KDE,
61takie jak KMail, KOrganizer i KAddressBook. Mają ujednolicony
62interfejs i dają łatwy dostęp do poczty, listy zadań, książki
63adresowej i innych funkcjonalności PIM.
fc580692 64
3afc98c6
WF
65%prep
66%setup -q -n %{kaname}-%{version}
67
68%build
3afc98c6 69%cmake \
8c4f21d6 70 -B build \
0cfd155d 71 -G Ninja \
fd5eb0a9 72 %{!?with_tests:-DBUILD_TESTING=OFF} \
c5b245cd 73 -DHTML_INSTALL_DIR=%{_kdedocdir} \
8c4f21d6
WF
74 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
75%ninja_build -C build
3afc98c6 76
fd5eb0a9 77%if %{with tests}
8c4f21d6 78ctest --test-dir build
fd5eb0a9
WF
79%endif
80
81
3afc98c6
WF
82%install
83rm -rf $RPM_BUILD_ROOT
0cfd155d 84%ninja_install -C build
3afc98c6
WF
85
86%find_lang %{kaname} --all-name --with-kde
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post -p /sbin/ldconfig
92%postun -p /sbin/ldconfig
93
94%files -f %{kaname}.lang
95%defattr(644,root,root,755)
3afc98c6 96%attr(755,root,root) %{_bindir}/kontact
1fae9ddb
WF
97%ghost %{_libdir}/libkontactprivate.so.5
98%attr(755,root,root) %{_libdir}/libkontactprivate.so.*.*.*
3afc98c6
WF
99%{_desktopdir}/org.kde.kontact.desktop
100%{_datadir}/config.kcfg/kontact.kcfg
1fae9ddb
WF
101%{_iconsdir}/hicolor/128x128/apps/kontact.png
102%{_iconsdir}/hicolor/16x16/apps/kontact.png
103%{_iconsdir}/hicolor/22x22/apps/kontact.png
104%{_iconsdir}/hicolor/32x32/apps/kontact.png
105%{_iconsdir}/hicolor/48x48/apps/kontact.png
106%{_iconsdir}/hicolor/64x64/apps/kontact.png
3afc98c6 107%{_iconsdir}/hicolor/scalable/apps/kontact.svg
3afc98c6
WF
108%{_datadir}/messageviewer/about/default/introduction_kontact.html
109%{_datadir}/messageviewer/about/default/loading_kontact.html
110%{_datadir}/metainfo/org.kde.kontact.appdata.xml
710a9bd2 111%{_datadir}/dbus-1/services/org.kde.kontact.service
1fae9ddb
WF
112%{_datadir}/qlogging-categories5/kontact.categories
113%{_datadir}/qlogging-categories5/kontact.renamecategories
114%dir %{_libdir}/qt5/plugins/pim5/kcms/kontact
115%{_libdir}/qt5/plugins/pim5/kcms/kontact/kcm_kontact.so
This page took 0.731253 seconds and 5 git commands to generate.