]> git.pld-linux.org Git - packages/ixion.git/blame - ixion.spec
- new
[packages/ixion.git] / ixion.spec
CommitLineData
fb44557a
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4#
5Summary: Generic formula compulation library
6Summary(pl.UTF-8): Ogólna biblioteka do obliczania wzorów
7Name: ixion
8Version: 0.2.0
9Release: 1
10License: MIT
11Group: Libraries
12Source0: http://dev-www.libreoffice.org/src/%{name}-%{version}.tar.gz
13# Source0-md5: 0f63ee487fda8f21fafa767b3c447ac9
14URL: http://kohei.us/2010/06/21/ixion-threaded-formula-calculation-library/
15BuildRequires: boost-devel >= 1.36
16BuildRequires: libstdc++-devel
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20Ixion aims to provide a library for calculating the results of formula
21expressions stored in multiple named targets, or "cells". The cells
22can be referenced from each other, and the library takes care of
23resolving their dependencies automatically upon calculation. The
24caller can run the calculation routine either in a single-threaded
25mode, or a multi-threaded mode. The library also supports
26re-calculation where the contents of one or more cells have been
27modified since the last calculation, and a partial calculation of only
28the affected cells gets performed. It is written entirely in C++, and
29makes extensive use of the boost library to achieve portability across
30different platforms.
31
32%description -l pl.UTF-8
33Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
34wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
35"komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
36biblioteka dba o automatyczne rozwiązywanie ich zależności przy
37obliczeniach. Procedura obliczająca może być wywołana w trybie
38jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
39przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
40komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
41komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
42C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
43przenośność na wiele platform.
44
45%package devel
46Summary: Development files for ixion
47Summary(pl.UTF-8): Pliki nagłówkowe dla ixion
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: boost-devel >= 1.36
51Requires: libstdc++-devel
52
53%description devel
54This package contains the header files for developing applications
55that use ixion.
56
57%description devel -l pl.UTF-8
58Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
59ixion.
60
61%package static
62Summary: Static ixion library
63Summary(pl.UTF-8): Statyczna biblioteka ixion
64Group: Development/Libraries
65Requires: %{name}-devel = %{version}-%{release}
66
67%description static
68Static ixion library.
69
70%description static -l pl.UTF-8
71Statyczna biblioteka ixion.
72
73%prep
74%setup -q
75
76%build
77%configure \
78 %{!?with_static_libs:--disable-static}
79
80%{__make}
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85%{__make} install \
86 DESTDIR=$RPM_BUILD_ROOT
87
88# obsoleted by pkg-config
89%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%files
98%defattr(644,root,root,755)
99%doc AUTHORS COPYING ChangeLog README
100%attr(755,root,root) %{_bindir}/ixion-parser
101%attr(755,root,root) %{_bindir}/ixion-sorter
102%attr(755,root,root) %{_libdir}/libixion-0.2.so.*.*.*
103%attr(755,root,root) %ghost %{_libdir}/libixion-0.2.so.0
104
105%files devel
106%defattr(644,root,root,755)
107%attr(755,root,root) %{_libdir}/libixion-0.2.so
108%{_includedir}/libixion-0.2
109%{_pkgconfigdir}/ixion-0.2.pc
110
111%if %{with static_libs}
112%files static
113%defattr(644,root,root,755)
114%{_libdir}/libixion-0.2.a
115%endif
This page took 0.032223 seconds and 4 git commands to generate.