]> git.pld-linux.org Git - packages/ixion.git/blame - ixion.spec
- updated to 0.3.0
[packages/ixion.git] / ixion.spec
CommitLineData
fb44557a
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4#
5Summary: Generic formula compulation library
6Summary(pl.UTF-8): Ogólna biblioteka do obliczania wzorów
7Name: ixion
b8fb894e 8Version: 0.3.0
fb44557a
JB
9Release: 1
10License: MIT
11Group: Libraries
b8fb894e
JB
12Source0: http://kohei.us/files/ixion/src/libixion_%{version}.tar.bz2
13# Source0-md5: 96a36a0016f968a5a7c4b167eeb1643b
14Patch0: %{name}-am.patch
15URL: http://gitorious.org/ixion/pages/Home
16BuildRequires: autoconf >= 2.63
17BuildRequires: automake
fb44557a
JB
18BuildRequires: boost-devel >= 1.36
19BuildRequires: libstdc++-devel
b8fb894e 20BuildRequires: libtool
fb44557a
JB
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Ixion aims to provide a library for calculating the results of formula
25expressions stored in multiple named targets, or "cells". The cells
26can be referenced from each other, and the library takes care of
27resolving their dependencies automatically upon calculation. The
28caller can run the calculation routine either in a single-threaded
29mode, or a multi-threaded mode. The library also supports
30re-calculation where the contents of one or more cells have been
31modified since the last calculation, and a partial calculation of only
32the affected cells gets performed. It is written entirely in C++, and
33makes extensive use of the boost library to achieve portability across
34different platforms.
35
36%description -l pl.UTF-8
37Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
38wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
39"komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
40biblioteka dba o automatyczne rozwiązywanie ich zależności przy
41obliczeniach. Procedura obliczająca może być wywołana w trybie
42jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
43przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
44komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
45komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
46C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
47przenośność na wiele platform.
48
49%package devel
50Summary: Development files for ixion
51Summary(pl.UTF-8): Pliki nagłówkowe dla ixion
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: boost-devel >= 1.36
55Requires: libstdc++-devel
56
57%description devel
58This package contains the header files for developing applications
59that use ixion.
60
61%description devel -l pl.UTF-8
62Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
63ixion.
64
65%package static
66Summary: Static ixion library
67Summary(pl.UTF-8): Statyczna biblioteka ixion
68Group: Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72Static ixion library.
73
74%description static -l pl.UTF-8
75Statyczna biblioteka ixion.
76
77%prep
b8fb894e
JB
78%setup -q -n libixion_%{version}
79%patch0 -p1
fb44557a
JB
80
81%build
b8fb894e
JB
82%{__libtoolize}
83%{__aclocal} -I m4
84%{__autoconf}
85%{__automake}
fb44557a 86%configure \
b8fb894e
JB
87 boost_cv_lib_thread=yes \
88 boost_cv_lib_thread_LIBS="-lboost_thread -lboost_system" \
fb44557a
JB
89 %{!?with_static_libs:--disable-static}
90
91%{__make}
92
93
94%install
95rm -rf $RPM_BUILD_ROOT
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
98
99# obsoleted by pkg-config
100%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
107
108%files
109%defattr(644,root,root,755)
b8fb894e 110%doc AUTHORS COPYING README
fb44557a
JB
111%attr(755,root,root) %{_bindir}/ixion-parser
112%attr(755,root,root) %{_bindir}/ixion-sorter
b8fb894e
JB
113%attr(755,root,root) %{_libdir}/libixion-0.4.so.*.*.*
114%attr(755,root,root) %ghost %{_libdir}/libixion-0.4.so.0
fb44557a
JB
115
116%files devel
117%defattr(644,root,root,755)
b8fb894e
JB
118%attr(755,root,root) %{_libdir}/libixion-0.4.so
119%{_includedir}/libixion-0.4
120%{_pkgconfigdir}/libixion-0.4.pc
fb44557a
JB
121
122%if %{with static_libs}
123%files static
124%defattr(644,root,root,755)
b8fb894e 125%{_libdir}/libixion-0.4.a
fb44557a 126%endif
This page took 0.075774 seconds and 4 git commands to generate.