]> git.pld-linux.org Git - packages/ixion.git/blame - ixion.spec
- - rebuild with boost 1.55.0
[packages/ixion.git] / ixion.spec
CommitLineData
fb44557a
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4#
5Summary: Generic formula compulation library
6Summary(pl.UTF-8): Ogólna biblioteka do obliczania wzorów
7Name: ixion
f369ddf3 8Version: 0.5.0
b2e94c48 9Release: 4
fb44557a
JB
10License: MIT
11Group: Libraries
2270dba6 12#Source0Download: http://gitorious.org/ixion/pages/Download
f369ddf3
JB
13Source0: http://kohei.us/files/ixion/src/libixion-%{version}.tar.bz2
14# Source0-md5: ebaeab9ffe1e6bd68b2a20bfa430b3af
b8fb894e
JB
15Patch0: %{name}-am.patch
16URL: http://gitorious.org/ixion/pages/Home
17BuildRequires: autoconf >= 2.63
f369ddf3 18BuildRequires: automake >= 1:1.11
fb44557a
JB
19BuildRequires: boost-devel >= 1.36
20BuildRequires: libstdc++-devel
f369ddf3
JB
21BuildRequires: libtool >= 2:1.5
22BuildRequires: mdds-devel
fb44557a
JB
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Ixion aims to provide a library for calculating the results of formula
27expressions stored in multiple named targets, or "cells". The cells
28can be referenced from each other, and the library takes care of
29resolving their dependencies automatically upon calculation. The
30caller can run the calculation routine either in a single-threaded
31mode, or a multi-threaded mode. The library also supports
32re-calculation where the contents of one or more cells have been
33modified since the last calculation, and a partial calculation of only
34the affected cells gets performed. It is written entirely in C++, and
35makes extensive use of the boost library to achieve portability across
36different platforms.
37
38%description -l pl.UTF-8
39Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
40wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
41"komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
42biblioteka dba o automatyczne rozwiązywanie ich zależności przy
43obliczeniach. Procedura obliczająca może być wywołana w trybie
44jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
45przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
46komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
47komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
48C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
49przenośność na wiele platform.
50
51%package devel
52Summary: Development files for ixion
53Summary(pl.UTF-8): Pliki nagłówkowe dla ixion
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: boost-devel >= 1.36
57Requires: libstdc++-devel
f369ddf3 58Requires: mdds-devel
fb44557a
JB
59
60%description devel
61This package contains the header files for developing applications
62that use ixion.
63
64%description devel -l pl.UTF-8
65Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
66ixion.
67
68%package static
69Summary: Static ixion library
70Summary(pl.UTF-8): Statyczna biblioteka ixion
71Group: Development/Libraries
72Requires: %{name}-devel = %{version}-%{release}
73
74%description static
75Static ixion library.
76
77%description static -l pl.UTF-8
78Statyczna biblioteka ixion.
79
80%prep
f369ddf3 81%setup -q -n libixion-%{version}
b8fb894e 82%patch0 -p1
fb44557a
JB
83
84%build
b8fb894e
JB
85%{__libtoolize}
86%{__aclocal} -I m4
87%{__autoconf}
88%{__automake}
fb44557a 89%configure \
b8fb894e
JB
90 boost_cv_lib_thread=yes \
91 boost_cv_lib_thread_LIBS="-lboost_thread -lboost_system" \
fb44557a
JB
92 %{!?with_static_libs:--disable-static}
93
94%{__make}
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99%{__make} install \
100 DESTDIR=$RPM_BUILD_ROOT
101
102# obsoleted by pkg-config
103%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
111%files
112%defattr(644,root,root,755)
b8fb894e 113%doc AUTHORS COPYING README
fb44557a
JB
114%attr(755,root,root) %{_bindir}/ixion-parser
115%attr(755,root,root) %{_bindir}/ixion-sorter
f369ddf3
JB
116%attr(755,root,root) %{_libdir}/libixion-0.6.so.*.*.*
117%attr(755,root,root) %ghost %{_libdir}/libixion-0.6.so.0
fb44557a
JB
118
119%files devel
120%defattr(644,root,root,755)
f369ddf3
JB
121%attr(755,root,root) %{_libdir}/libixion-0.6.so
122%{_includedir}/libixion-0.6
123%{_pkgconfigdir}/libixion-0.6.pc
fb44557a
JB
124
125%if %{with static_libs}
126%files static
127%defattr(644,root,root,755)
f369ddf3 128%{_libdir}/libixion-0.6.a
fb44557a 129%endif
This page took 0.070143 seconds and 4 git commands to generate.