]> git.pld-linux.org Git - packages/iproute2.git/blame - iproute2.spec
- added missing files (by Pawel Nogas)
[packages/iproute2.git] / iproute2.spec
CommitLineData
4d4e8753 1#
0a1f6d9e
AM
2# TODO:
3# - fix build @ uClibc
4#
4d4e8753 5# Conditional build
c2f906a7
PS
6%bcond_without doc # don't build documentation
7%bcond_without tc # don't build tc program (it breaks static linkage)
d072516f 8%bcond_without atm # don't required ATM.
c2f906a7 9%bcond_with uClibc # do some hacks to build with uClibc
7762157f 10%bcond_with iface_descr # build with interface description support
61f3b6a3 11#
0a1f6d9e 12Summary: Utility to control Networking behavior in.X kernels
d2344512
ER
13Summary(es.UTF-8): Herramientas para encaminamiento avanzado y configuración de interfaces de red
14Summary(pl.UTF-8): Narzędzie do kontrolowania Sieci w kernelach
15Summary(pt_BR.UTF-8): Ferramentas para roteamento avançado e configuração de interfaces de rede
354f4215 16Name: iproute2
1525a420 17%define sdate 061002
aa691b5d 18# do not use ,,2.6.X'' as version here, put whole number like 2.6.8
1525a420 19Version: 2.6.18
91d521f5 20Release: 1.1
323e0978 21License: GPL
0a1f6d9e 22Vendor: Stephen Hemminger <shemminger@osdl.org>
354f4215 23Group: Networking/Admin
9b057263 24Source0: http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
1525a420 25# Source0-md5: 193b570128cf852afba337438413adf9
af6313ca 26Patch0: %{name}-build.patch
3f9edb83 27Patch1: %{name}-arp.patch
9b057263 28Patch2: %{name}-lex.patch
e3fc76c4 29Patch3: %{name}-iptables.patch
30Patch4: %{name}-iptables64.patch
93591f64 31Patch5: %{name}-LDFLAGS.patch
207621e4 32# extensions
af6313ca 33Patch10: %{name}-2.2.4-wrr.patch
00a4c5cb 34Patch11: esfq-%{name}.patch
91d521f5 35Patch12: 001-net-dev-iface-descr-0.1.diff
9b057263 36URL: http://linux-net.osdl.org/index.php/Iproute2
4ef82693 37BuildRequires: bison
4c573c73 38BuildRequires: db-devel
e3fc76c4 39BuildRequires: flex
d072516f 40%if %{with atm}
76ab126a 41BuildRequires: linux-atm-devel
d072516f 42%endif
1525a420 43BuildRequires: linux-libc-headers >= 7:2.6.12.0-15
61f3b6a3
PS
44%if %{with doc}
45BuildRequires: psutils
46BuildRequires: sgml-tools
47BuildRequires: tetex-dvips
43c559c0 48BuildRequires: tetex-fonts-jknappen
76ac8df9 49BuildRequires: tetex-format-latex
de2f8bd6 50BuildRequires: tetex-metafont
61f3b6a3
PS
51BuildRequires: tetex-tex-babel
52%endif
12c8b5e2 53Obsoletes: iproute
b84ea0a7 54Obsoletes: ifstat
9b85a8c8 55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
8ca003ed 56
9ea83253 57%define _sbindir /sbin
58%define _sysconfdir /etc/iproute2
c2827c7c 59
8ca003ed 60%description
af6313ca
SP
61Linux maintains compatibility with the basic configuration utilities
62of the network (ifconfig, route) but a new utility is required to
63exploit the new characteristics and features of the kernel. This
64package includes the new utilities.
e316d7c9 65
70fcbc5f
JR
66%description -l es.UTF-8
67Linux mantiene compatibilidad con los utilitarios estándares de
68configuración de la red, pero se necesitan nuevos utilitarios para
69usar los recursos y características del nuevo núcleo. Este paquete
e316d7c9 70incluye los nuevos utilitarios.
323e0978 71
70fcbc5f
JR
72%description -l pl.UTF-8
73Ten pakiet zawiera programy pozwalające na kontrolę routingu i innych
74aspektów dotyczących sieci.
e316d7c9 75
70fcbc5f
JR
76%description -l pt_BR.UTF-8
77O Linux mantém compatibilidade com os utilitários padrão de
78configuração da rede, mas novos utilitários são necessários para fazer
79uso das características e recursos da nova kernel. This package
e316d7c9 80includes the new utilities.
323e0978 81
49c78676
JK
82%package -n libnetlink-devel
83Summary: Library for the netlink interface
d2344512 84Summary(pl.UTF-8): Biblioteka do interfejsu netlink
49c78676
JK
85Group: Development/Libraries
86
87%description -n libnetlink-devel
88This library provides an interface for kernel-user netlink interface.
89
70fcbc5f
JR
90%description -n libnetlink-devel -l pl.UTF-8
91Ta biblioteka udostępnia interfejs do interfejsu netlink między jądrem
92a przestrzenią użytkownika.
a52556c3 93
8ca003ed 94%prep
9b057263 95%setup -q -n %{name}-%{version}-%{sdate}
00a4c5cb 96rm -rf include-glibc include/linux
e7a2e041 97%patch0 -p1
3f9edb83 98%patch1 -p1
9b057263 99%patch2 -p1
055ee3d7 100%if "%{_lib}" == "lib64"
e3fc76c4 101%patch4 -p1
102%else
103%patch3 -p1
104%endif
93591f64 105%patch5 -p1
91d521f5
PG
106
107# extensions:
e42218cf
PS
108%patch10 -p1
109%patch11 -p1
7762157f 110%{?with_iface_descr:%patch12 -p1}
d1f6ab22 111
8ca003ed 112%build
dd97cf21 113%{__make} \
93591f64 114%if %{with uClibc}
115 CC="%{_target_cpu}-uclibc-gcc" \
116 LD="%{_target_cpu}-uclibc-gcc" \
117%else
118 CC="%{__cc}" \
119 LD="%{__cc}" \
120%endif
f2b536a2 121 HOSTCC="%{__cc}" \
25f0047d 122 OPT="%{rpmcflags}" \
93591f64 123 LDFLAGS="%{rpmldflags}" \
124 %{!?with_tc:SUBDIRS="lib ip misc"}
207621e4 125
1b109167 126%{?with_doc:%{__make} -C doc}
8ca003ed
AM
127
128%install
129rm -rf $RPM_BUILD_ROOT
49382eb3 130install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir},%{?with_tc:%{_libdir}/tc}}
9ea83253 131
3f9edb83 132install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
354f4215 133install etc/iproute2/rt_protos \
134 etc/iproute2/rt_realms \
135 etc/iproute2/rt_scopes \
136 etc/iproute2/rt_tables \
323e0978 137 $RPM_BUILD_ROOT%{_sysconfdir}
0a1f6d9e
AM
138
139install man/man8/* $RPM_BUILD_ROOT%{_mandir}/man8
140echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
141echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
142
49c78676
JK
143install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
144install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
49382eb3 145%{?with_tc:install tc/*.so $RPM_BUILD_ROOT%{_libdir}/tc}
354f4215 146
8ca003ed
AM
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%files
151%defattr(644,root,root,755)
9b6ea7ca
AM
152%doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
153%doc ChangeLog %{?with_doc:doc/*.ps}
93c6b3a3 154%attr(755,root,root) %{_sbindir}/*
dd519f44 155%dir %{_sysconfdir}
af6313ca 156%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
6ef7db99 157%{_mandir}/man8/*
49382eb3 158%{?with_tc:%dir %{_libdir}/tc}
159%{?with_tc:%attr(755,root,root) %{_libdir}/tc/*.so}
49c78676
JK
160
161%files -n libnetlink-devel
162%defattr(644,root,root,755)
a40db8cc
JB
163%{_libdir}/lib*.a
164%{_includedir}/*.h
This page took 0.206284 seconds and 4 git commands to generate.