]> git.pld-linux.org Git - packages/icedove.git/blame - icedove.spec
- rebuild with libevent 2.1.8
[packages/icedove.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
283702b9 2# - build with system mozldap
3b54e43a 3# - update to current version and debrand, see thunderbird.spec
c4ddd260 4#
44be9ed4 5# Conditional builds
3366507a 6%bcond_with gtk3 # GTK+ 3.x instead of 2.x
44be9ed4 7%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 8%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 9%bcond_with xulrunner # system xulrunner
765a3a27 10%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
a97d3356
JR
11# - disabled shared_js - https://bugzilla.mozilla.org/show_bug.cgi?id=1039964
12%bcond_with shared_js # shared libmozjs library [broken]
3b54e43a 13%bcond_with system_icu # build with system ICU (disabled due to crashes with system icu 58.2)
88149483 14
f4114a7f 15%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
16%undefine crashreporter
17%endif
18
62096d2c 19%define nspr_ver 4.10.6
3a30e2d7 20%define nss_ver 3.19.2.1
44be9ed4 21
62096d2c 22%define xulrunner_ver 2:31.3.0
4f34f106 23
7d981f69
ER
24%if %{without xulrunner}
25# The actual sqlite version (see RHBZ#480989):
26%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
27%endif
28
44be9ed4 29Summary: Icedove - email client
30Summary(pl.UTF-8): Icedove - klient poczty
31Name: icedove
c03e9b1a 32Version: 38.5.0
fa824d9a 33Release: 7
3366507a 34License: MPL v2.0
2d289b25 35Group: X11/Applications/Mail
c03e9b1a
JR
36Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
37# Source0-md5: 516ddb66f788ea7db48ed0d76f7a7ebc
090220f6 38Source2: %{name}-branding.tar.xz
3a30e2d7 39# Source2-md5: 66753bc5c924d7492b6b5c9bdc3e4b5b
44be9ed4 40Source4: %{name}.desktop
41Source5: %{name}.sh
44be9ed4 42Patch0: %{name}-branding.patch
f53f9bcd 43Patch2: %{name}-prefs.patch
c03e9b1a 44Patch3: system-mozldap.patch
f53f9bcd
JR
45Patch5: %{name}-extensiondir.patch
46Patch6: no-subshell.patch
c03e9b1a
JR
47# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
48Patch7: system-virtualenv.patch
f53f9bcd 49Patch8: enable-addons.patch
c03e9b1a 50Patch9: bump-nss-req.patch
3b54e43a
JR
51Patch10: gcc6.patch
52Patch11: sed-syntax.patch
5745d706 53URL: http://www.pld-linux.org/Packages/Icedove
6458b220 54BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 55BuildRequires: alsa-lib-devel
44be9ed4 56BuildRequires: automake
51a3b6db 57BuildRequires: bzip2-devel
e820c55e
JB
58BuildRequires: cairo-devel >= 1.10
59BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 60BuildRequires: freetype-devel >= 1:2.1.8
6f32f966 61BuildRequires: glib2-devel >= 1:2.20
d0b96b40
JR
62BuildRequires: gstreamer0.10-devel
63BuildRequires: gstreamer0.10-plugins-base-devel
3366507a
JB
64%{!?with_gtk3:BuildRequires: gtk+2-devel >= 2:2.14}
65%{?with_gtk3:BuildRequires: gtk+3-devel >= 3.0.0}
5e9bb798 66BuildRequires: hunspell-devel
44be9ed4 67BuildRequires: libIDL-devel >= 0.8.0
d0b96b40 68BuildRequires: libevent-devel
3b54e43a 69%{?with_system_icu:BuildRequires: libicu-devel >= 50.1}
51a3b6db 70BuildRequires: libiw-devel
e82da7a1 71# requires libjpeg-turbo implementing at least libjpeg 6b API
44be9ed4 72BuildRequires: libjpeg-devel >= 6b
e82da7a1 73BuildRequires: libjpeg-turbo-devel
e820c55e 74BuildRequires: libpng-devel >= 1.4.1
44be9ed4 75BuildRequires: libstdc++-devel
d0b96b40 76BuildRequires: mozldap-devel
f4114a7f
ER
77BuildRequires: nspr-devel >= 1:%{nspr_ver}
78BuildRequires: nss-devel >= 1:%{nss_ver}
62096d2c 79BuildRequires: pango-devel >= 1:1.22.0
e820c55e 80BuildRequires: perl-base >= 1:5.6
d0b96b40 81BuildRequires: python-virtualenv
1c62cadb 82BuildRequires: pkgconfig
e820c55e 83BuildRequires: python >= 1:2.5
44be9ed4 84BuildRequires: sed >= 4.0
62096d2c 85BuildRequires: sqlite3-devel >= 3.8.4.2
1c62cadb 86BuildRequires: startup-notification-devel >= 0.8
62096d2c 87BuildRequires: libvpx-devel >= 1.3.0
ffb12c8e 88BuildRequires: virtualenv
44be9ed4 89BuildRequires: xorg-lib-libXext-devel
44be9ed4 90BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 91BuildRequires: xorg-lib-libXt-devel
5745d706 92BuildRequires: yasm
1c62cadb 93BuildRequires: zip
7d981f69 94%if %{with xulrunner}
e8326f77 95BuildRequires: xulrunner-devel >= %{xulrunner_ver}
62096d2c 96BuildRequires: xulrunner-devel < 2:32
7d981f69 97%else
6f32f966 98Requires: glib2 >= 1:2.20
3366507a
JB
99%{!?with_gtk3:Requires: gtk+2 >= 2:2.14}
100%{?with_gtk3:Requires: gtk+3 >= 3.0.0}
62096d2c 101Requires: libvpx >= 1.3.0
44be9ed4 102Requires: myspell-common
f4114a7f
ER
103Requires: nspr >= 1:%{nspr_ver}
104Requires: nss >= 1:%{nss_ver}
62096d2c 105Requires: pango >= 1:1.22.0
4b6bc367 106Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 107%endif
4f34f106
ER
108Requires(post): mktemp >= 1.5-18
109%if %{with xulrunner}
110%requires_eq_to xulrunner xulrunner-devel
111%endif
e82da7a1 112Requires: libjpeg-turbo
44be9ed4 113Obsoletes: mozilla-thunderbird
114Obsoletes: mozilla-thunderbird-dictionary-en-US
d606e9b3 115Conflicts: icedove-lang-resources < %{version}
44be9ed4 116BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
9e366f18
AM
118%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
119
44be9ed4 120# iceweasel/icedove/iceape provide their own versions
44be9ed4 121%define _noautoprovfiles %{_libdir}/%{name}/components
fb7d4f06
JB
122%if %{without xulrunner}
123# we don't want these to satisfy packages depending on xulrunner
6f32f966 124%define _noautoprov libmozalloc.so libmozjs.so libxul.so
44be9ed4 125# and as we don't provide them, don't require either
6f32f966 126%define _noautoreq libmozalloc.so libmozjs.so libxul.so
fb7d4f06 127%endif
44be9ed4 128
c03e9b1a 129%define topdir %{_builddir}/%{name}-%{version}
9e7875fc
ER
130%define objdir %{topdir}/obj-%{_target_cpu}
131
44be9ed4 132%description
6b327de6 133Icedove is an open-source, fast and portable email client.
44be9ed4 134
135%description -l pl.UTF-8
6b327de6
JB
136Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
137poczty.
44be9ed4 138
6578c165 139%package addon-lightning
140Summary: An integrated calendar for Icedove
141Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
142License: MPL 1.1 or GPL v2+ or LGPL v2.1+
143Group: Applications/Networking
144Requires: %{name} = %{version}-%{release}
145
146%description addon-lightning
147Lightning is an calendar extension to Icedove email client.
148
149%description addon-lightning -l pl.UTF-8
150Lightning to rozszerzenie do klienta poczty Icedove dodające
151funkcjonalność kalendarza.
152
44be9ed4 153%prep
c03e9b1a
JR
154%setup -qc
155%{__mv} comm-esr38 mozilla
156%setup -q -T -D -a2
157cd mozilla
983562b1 158%patch0 -p1
f53f9bcd 159%patch2 -p1
c03e9b1a 160%patch3 -p1
f53f9bcd 161%patch5 -p2
983562b1 162%patch6 -p1
c03e9b1a 163%patch7 -p1
f53f9bcd 164%patch8 -p1
c03e9b1a 165%patch9 -p2
3b54e43a
JR
166%patch10 -p1
167%patch11 -p1
d0b96b40 168
44be9ed4 169%build
c03e9b1a
JR
170cd mozilla
171cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
172cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
173cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
174
fbac75ca 175cat << EOF > .mozconfig
9e7875fc 176mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 177
3b54e43a
JR
178export CFLAGS="%{rpmcflags} -fno-schedule-insns2 -fno-delete-null-pointer-checks"
179export CXXFLAGS="%{rpmcxxflags} -fno-schedule-insns2 -fno-delete-null-pointer-checks"
765a3a27
ER
180
181%if %{with crashreporter}
182export MOZ_DEBUG_SYMBOLS=1
183%endif
184
59c5a0e8 185# Options for 'configure' (same as command-line options).
44be9ed4 186ac_add_options --prefix=%{_prefix}
187ac_add_options --exec-prefix=%{_exec_prefix}
188ac_add_options --bindir=%{_bindir}
189ac_add_options --sbindir=%{_sbindir}
190ac_add_options --sysconfdir=%{_sysconfdir}
191ac_add_options --datadir=%{_datadir}
192ac_add_options --includedir=%{_includedir}
193ac_add_options --libdir=%{_libdir}
194ac_add_options --libexecdir=%{_libexecdir}
195ac_add_options --localstatedir=%{_localstatedir}
196ac_add_options --sharedstatedir=%{_sharedstatedir}
197ac_add_options --mandir=%{_mandir}
198ac_add_options --infodir=%{_infodir}
199%if %{?debug:1}0
59c5a0e8 200ac_add_options --disable-optimize
44be9ed4 201ac_add_options --enable-debug
202ac_add_options --enable-debug-modules
59c5a0e8
SP
203ac_add_options --enable-debugger-info-modules
204ac_add_options --enable-crash-on-assert
44be9ed4 205%else
206ac_add_options --disable-debug
207ac_add_options --disable-debug-modules
59c5a0e8 208ac_add_options --disable-logging
3b54e43a 209ac_add_options --enable-optimize="%{rpmcflags} -Os -fno-schedule-insns2 -fno-delete-null-pointer-checks"
44be9ed4 210%endif
88149483
ER
211ac_add_options --disable-strip
212ac_add_options --disable-strip-libs
44be9ed4 213%if %{with tests}
214ac_add_options --enable-tests
215%else
216ac_add_options --disable-tests
217%endif
3366507a
JB
218%if %{with lightning}
219ac_add_options --enable-calendar
44be9ed4 220%else
3366507a 221ac_add_options --disable-calendar
44be9ed4 222%endif
765a3a27
ER
223%if %{with crashreporter}
224ac_add_options --enable-crashreporter
225%else
59c5a0e8 226ac_add_options --disable-crashreporter
765a3a27 227%endif
d0b96b40 228ac_add_options --disable-elf-dynstr-gc
59e5e620 229ac_add_options --disable-elf-hack
3366507a
JB
230ac_add_options --disable-gnomeui
231ac_add_options --disable-gnomevfs
44be9ed4 232ac_add_options --disable-installer
d0b96b40 233ac_add_options --disable-javaxpcom
3366507a 234ac_add_options --disable-profilesharing
88149483 235ac_add_options --disable-updater
3366507a
JB
236ac_add_options --disable-xterm-updates
237ac_add_options --enable-application=mail
44be9ed4 238ac_add_options --enable-crypto
3366507a
JB
239ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
240ac_add_options --enable-gio
241%if %{with ldap}
242ac_add_options --enable-ldap
243ac_add_options --with-system-ldap
244%else
245ac_add_options --disable-ldap
246%endif
d0b96b40 247ac_add_options --enable-libxul
44be9ed4 248ac_add_options --enable-pango
3366507a 249ac_add_options --enable-postscript
a97d3356 250%{?with_shared_js:ac_add_options --enable-shared-js}
3366507a 251ac_add_options --enable-single-profile
88149483 252ac_add_options --enable-startup-notification
44be9ed4 253ac_add_options --enable-system-cairo
5e9bb798 254ac_add_options --enable-system-hunspell
7d981f69 255ac_add_options --enable-system-sqlite
88149483 256ac_add_options --with-branding=icedove/branding
3366507a
JB
257ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
258ac_add_options --with-distribution-id=org.pld-linux
88149483 259%if %{with xulrunner}
d0b96b40 260ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
3366507a 261ac_add_options --with-system-libxul
88149483
ER
262%endif
263ac_add_options --with-pthreads
264ac_add_options --with-system-bz2
d0b96b40 265ac_add_options --with-system-ffi
3b54e43a 266ac_add_options --with%{!?with_system_icu:out}-system-icu
44be9ed4 267ac_add_options --with-system-jpeg
d0b96b40
JR
268ac_add_options --with-system-libevent
269ac_add_options --with-system-libvpx
44be9ed4 270ac_add_options --with-system-nspr
271ac_add_options --with-system-nss
272ac_add_options --with-system-png
273ac_add_options --with-system-zlib
44be9ed4 274EOF
275
d0b96b40 276mkdir -p %{objdir}/config
c03e9b1a 277ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
d0b96b40 278
90e998ba 279%{__make} -j1 -f client.mk build \
d076d93e 280 STRIP="/bin/true" \
765a3a27 281 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d0b96b40 282 installdir=%{_libdir}/%{name} \
de09c00d 283 XLIBS="-lX11 -lXt" \
d076d93e 284 CC="%{__cc}" \
44be9ed4 285 CXX="%{__cxx}"
286
765a3a27
ER
287%if %{with crashreporter}
288# create debuginfo for crash-stats.mozilla.com
289%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
290%endif
291
44be9ed4 292%install
293rm -rf $RPM_BUILD_ROOT
765a3a27 294install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 295
9e7875fc 296cd %{objdir}
ecf04393 297%{__make} -C mail/installer stage-package \
44be9ed4 298 DESTDIR=$RPM_BUILD_ROOT \
d0b96b40 299 installdir=%{_libdir}/%{name} \
44be9ed4 300 PKG_SKIP_STRIP=1
301
d0b96b40
JR
302%{__make} -C icedove/branding install \
303 DESTDIR=$RPM_BUILD_ROOT
304
3a30e2d7 305cp -a dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
d0b96b40 306
9b40a2c3
JB
307%if %{with xulrunner}
308# needed to find mozilla runtime
309ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
310%endif
311
312# Enable crash reporter for Thunderbird application
765a3a27
ER
313%if %{with crashreporter}
314%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
315
316# Add debuginfo for crash-stats.mozilla.com
51a3b6db 317install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
3a30e2d7 318cp -a dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
319%endif
320
44be9ed4 321# move arch independant ones to datadir
eca54e0f 322mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
eca54e0f 323ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
44be9ed4 324
c6ec3c1c
ER
325# dir for arch independant extensions besides arch dependant extensions
326# see mozilla/xpcom/build/nsXULAppAPI.h
327# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
328install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
329
73d54cb2 330%if %{without xulrunner}
63d8f5c3 331%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 332ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
73d54cb2 333%endif
e6bc19b3 334
0889474f
JR
335%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
336 -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
337 %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
338
44be9ed4 339%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
340ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
341ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
342
d0b96b40 343# install icons and desktop file
52f5507d 344cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
d0b96b40
JR
345for i in 16 32 48 64 128 256; do
346 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
347 cp -a %{topdir}/mozilla/icedove/branding/icedove${i}.png \
348 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/icedove.png
349done
350install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
351cp -a %{topdir}/mozilla/icedove/branding/icedove.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/icedove.svg
352
353cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
44be9ed4 354
e8f4ba81 355# files created by regxpcom -register in post
52fc61e6
ER
356touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
357touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
358cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
359#!/bin/sh
360umask 022
361# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
362# dangerous if you run this with sudo with keep_env += HOME
363# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
364t=$(mktemp -d)
d50a2a28 365%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
366TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
367rm -rf $t
368EOF
369chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 370
283702b9 371# mozldap
d0b96b40
JR
372%{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
373%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
283702b9 374
44be9ed4 375%clean
376rm -rf $RPM_BUILD_ROOT
377
378%pretrans
379if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
380 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
381fi
eca54e0f 382for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 383 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
384 install -d %{_datadir}/%{name}
385 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
386 fi
387done
388exit 0
389
e8f4ba81
ER
390%post
391%{_libdir}/%{name}/register || :
392
44be9ed4 393%files
394%defattr(644,root,root,755)
395%attr(755,root,root) %{_bindir}/icedove
396%attr(755,root,root) %{_bindir}/mozilla-thunderbird
397%attr(755,root,root) %{_bindir}/thunderbird
398%dir %{_libdir}/%{name}
765a3a27 399%{_libdir}/%{name}/application.ini
6b327de6
JB
400%{_libdir}/%{name}/blocklist.xml
401%{_libdir}/%{name}/chrome.manifest
44be9ed4 402%dir %{_libdir}/%{name}/components
6b327de6 403%{_libdir}/%{name}/components/components.manifest
73d54cb2
JB
404%attr(755,root,root) %{_libdir}/%{name}/*.sh
405%attr(755,root,root) %{_libdir}/%{name}/*-bin
406%attr(755,root,root) %{_libdir}/%{name}/icedove
407%attr(755,root,root) %{_libdir}/%{name}/register
d0b96b40 408%{_libdir}/%{name}/omni.ja
73d54cb2 409%if %{without xulrunner}
a367af64 410%{_libdir}/%{name}/dependentlibs.list
73d54cb2 411%{_libdir}/%{name}/platform.ini
73d54cb2 412%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 413%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
a97d3356 414%{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
0516fc42 415%attr(755,root,root) %{_libdir}/%{name}/libxul.so
cf62736e 416%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 417%endif
44be9ed4 418
419# symlinks
420%{_libdir}/%{name}/chrome
421%{_libdir}/%{name}/defaults
44be9ed4 422%{_libdir}/%{name}/isp
eca54e0f 423%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
424%if %{with xulrunner}
425%{_libdir}/%{name}/xulrunner
426%else
73d54cb2 427%{_libdir}/%{name}/dictionaries
73d54cb2 428%endif
44be9ed4 429
224cf96a
JB
430%{_pixmapsdir}/icedove.png
431%{_desktopdir}/icedove.desktop
44be9ed4 432
433%dir %{_datadir}/%{name}
3a30e2d7
JR
434%dir %{_libdir}/%{name}/distribution
435%dir %{_libdir}/%{name}/distribution/extensions
eca54e0f 436%{_datadir}/%{name}/extensions
eca54e0f 437%{_datadir}/%{name}/searchplugins
44be9ed4 438
765a3a27
ER
439%if %{with crashreporter}
440%attr(755,root,root) %{_libdir}/%{name}/crashreporter
441%{_libdir}/%{name}/crashreporter.ini
442%{_libdir}/%{name}/Throbber-small.gif
443%endif
444
44be9ed4 445%dir %{_libdir}/%{name}/extensions
446%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 447
52fc61e6
ER
448# files created by regxpcom -register
449%ghost %{_libdir}/%{name}/components/compreg.dat
450%ghost %{_libdir}/%{name}/components/xpti.dat
451
d0b96b40
JR
452%{_iconsdir}/hicolor/*/apps/icedove.*
453
6578c165 454%if %{with lightning}
455%files addon-lightning
456%defattr(644,root,root,755)
3a30e2d7
JR
457%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
458%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/app.ini
459%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.jar
460%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
461%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
462%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
463%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
464%attr(755,root,root) %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
465%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
466%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*manifest
467%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
468%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
469%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
470%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones
471%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones/zones.json
6578c165 472%endif
This page took 0.819228 seconds and 5 git commands to generate.