]> git.pld-linux.org Git - packages/icedove.git/blame - icedove.spec
- up to 10.0.1
[packages/icedove.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
f14018b4 4# - enigmail - new version needed
c4ddd260 5#
44be9ed4 6# Conditional builds
7%bcond_without enigmail # don't build enigmail - GPG/PGP support
8%bcond_without gnomeui # disable gnomeui support
6458b220 9%bcond_without gnome # alias for gnomeui
44be9ed4 10%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 11%bcond_without lightning # disable Sunbird/Lightning calendar
f4114a7f 12%bcond_without xulrunner # build with xulrunner
765a3a27 13%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 14
44be9ed4 15%if %{without gnome}
16%undefine with_gnomeui
44be9ed4 17%endif
88149483 18
f4114a7f 19%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
20%undefine crashreporter
21%endif
22
6864d0a2 23%define enigmail_ver 1.3.5
af42cf6d
JB
24%define nspr_ver 4.8.8
25%define nss_ver 3.12.10
44be9ed4 26
d06a830c 27# convert firefox release number to platform version: 9.0.x -> 9.0.x
6864d0a2
AZ
28%define xulrunner_main 10.0
29%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#10.0})
4f34f106 30
7d981f69
ER
31%if %{without xulrunner}
32# The actual sqlite version (see RHBZ#480989):
33%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
34%endif
35
44be9ed4 36Summary: Icedove - email client
37Summary(pl.UTF-8): Icedove - klient poczty
38Name: icedove
6864d0a2
AZ
39Version: 10.0.1
40Release: 1
44be9ed4 41License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 42Group: X11/Applications/Networking
cadfb931 43Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
6864d0a2 44# Source0-md5: 623c32d9deae370383e1422b1ea48061
44be9ed4 45Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
6864d0a2 46# Source1-md5: 1b008b0d106e238c11e4bead08126bc0
44be9ed4 47Source2: %{name}-branding.tar.bz2
c105f759 48# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 49Source3: %{name}-rm_nonfree.sh
50Source4: %{name}.desktop
51Source5: %{name}.sh
44be9ed4 52Patch0: %{name}-branding.patch
faa5c89d
SP
53Patch1: %{name}-enigmail-shared.patch
54Patch2: %{name}-gcc.patch
55Patch3: %{name}-fonts.patch
56Patch4: %{name}-install.patch
5e9bb798 57Patch5: %{name}-hunspell.patch
faa5c89d 58Patch6: %{name}-prefs.patch
9a743685 59Patch7: system-mozldap.patch
a85e0ecb 60Patch8: %{name}-makefile.patch
6864d0a2 61#Patch9: %{name}-libpng.patch
ccc206fe 62Patch10: %{name}-extensiondir.patch
765a3a27 63Patch11: crashreporter.patch
268e7766 64Patch12: no-subshell.patch
5745d706 65URL: http://www.pld-linux.org/Packages/Icedove
6458b220 66BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 67BuildRequires: alsa-lib-devel
44be9ed4 68BuildRequires: automake
51a3b6db 69BuildRequires: bzip2-devel
e820c55e
JB
70BuildRequires: cairo-devel >= 1.10
71BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 72BuildRequires: freetype-devel >= 1:2.1.8
6458b220 73BuildRequires: glib2-devel >= 2.0
e820c55e 74BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 75BuildRequires: hunspell-devel
44be9ed4 76BuildRequires: libIDL-devel >= 0.8.0
6458b220 77%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 78%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 79%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 80BuildRequires: libiw-devel
44be9ed4 81BuildRequires: libjpeg-devel >= 6b
51a3b6db 82BuildRequires: libnotify-devel >= 0.4
e820c55e 83BuildRequires: libpng-devel >= 1.4.1
44be9ed4 84BuildRequires: libstdc++-devel
f4114a7f
ER
85BuildRequires: nspr-devel >= 1:%{nspr_ver}
86BuildRequires: nss-devel >= 1:%{nss_ver}
44be9ed4 87BuildRequires: pango-devel >= 1:1.1.0
e820c55e 88BuildRequires: perl-base >= 1:5.6
1c62cadb 89BuildRequires: pkgconfig
e820c55e 90BuildRequires: python >= 1:2.5
44be9ed4 91BuildRequires: sed >= 4.0
9d1bfad8 92BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 93BuildRequires: startup-notification-devel >= 0.8
44be9ed4 94BuildRequires: xorg-lib-libXext-devel
44be9ed4 95BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 96BuildRequires: xorg-lib-libXt-devel
5745d706 97BuildRequires: yasm
1c62cadb 98BuildRequires: zip
7d981f69 99%if %{with xulrunner}
4f34f106 100BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
7d981f69 101%else
44be9ed4 102Requires: myspell-common
f4114a7f
ER
103Requires: nspr >= 1:%{nspr_ver}
104Requires: nss >= 1:%{nss_ver}
4b6bc367 105Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 106%endif
4f34f106
ER
107Requires(post): mktemp >= 1.5-18
108%if %{with xulrunner}
109%requires_eq_to xulrunner xulrunner-devel
110%endif
44be9ed4 111Obsoletes: mozilla-thunderbird
112Obsoletes: mozilla-thunderbird-dictionary-en-US
113BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
9e366f18
AM
115%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
116
44be9ed4 117# iceweasel/icedove/iceape provide their own versions
c072808a 118%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
44be9ed4 119%define _noautoprovfiles %{_libdir}/%{name}/components
120# we don't want these to satisfy xulrunner-devel
c072808a 121%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 122# and as we don't provide them, don't require either
c072808a 123%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
44be9ed4 124
9e7875fc
ER
125%define topdir %{_builddir}/%{name}-%{version}
126%define objdir %{topdir}/obj-%{_target_cpu}
127
44be9ed4 128%description
6b327de6 129Icedove is an open-source, fast and portable email client.
44be9ed4 130
131%description -l pl.UTF-8
6b327de6
JB
132Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
133poczty.
44be9ed4 134
6578c165 135%package addon-lightning
136Summary: An integrated calendar for Icedove
137Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
138License: MPL 1.1 or GPL v2+ or LGPL v2.1+
139Group: Applications/Networking
140Requires: %{name} = %{version}-%{release}
141
142%description addon-lightning
143Lightning is an calendar extension to Icedove email client.
144
145%description addon-lightning -l pl.UTF-8
146Lightning to rozszerzenie do klienta poczty Icedove dodające
147funkcjonalność kalendarza.
148
44be9ed4 149%package addon-enigmail
150Summary: Extension for the authentication and encryption features provided by GnuPG
151Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
152License: MPL/LGPL
153Group: Applications/Networking
154URL: http://enigmail.mozdev.org/
cd056caa 155Requires: %{name} = %{version}-%{release}
d076d93e 156Requires: gnupg
75991bbb 157Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 158
159%description addon-enigmail
c5e06599 160Enigmail is an extension to the Icedove mail client which allows users
161to access the authentication and encryption features provided by
162GnuPG.
44be9ed4 163
164Main Features:
165- Encrypt/sign mail when sending, decrypt/authenticate received mail
166- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
167- Per-Account based encryption and signing defaults
168- Per-Recipient rules for automated key selection, and
169 enabling/disabling encryption and signing
170- OpenPGP key management interface
171
172%description addon-enigmail -l pl.UTF-8
c5e06599 173Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
174użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
175przez GnuPG.
44be9ed4 176
177Główne możliwości:
178- szyfrowanie/podpisywanie poczty przy wysyłaniu,
179 odszyfrowywanie/uwierzytelnianie poczty odebranej
180- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
181- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
182- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
183 podpisywania dla każdego adresata
184- interfejs do zarządzania kluczami OpenPGP
185
186%prep
983562b1 187%setup -qc
f4114a7f 188mv comm-release mozilla
983562b1 189%setup -q -T -D -a2
190cd mozilla
1c70899a 191%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 192/bin/sh %{SOURCE3}
983562b1 193%patch0 -p1
faa5c89d
SP
194%{?with_enigmail:%patch1 -p1}
195%patch2 -p1
4ccc2157 196%patch3 -p1
faa5c89d 197%patch4 -p1
983562b1 198%patch6 -p1
9a743685 199%patch7 -p1
f4114a7f 200%patch8 -p2
6864d0a2 201#%patch9 -p1
ccc206fe 202%patch10 -p2
765a3a27 203%patch11 -p2
268e7766 204%patch12 -p1
44be9ed4 205
206%build
983562b1 207cd mozilla
cadfb931
SP
208cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
209cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 210cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 211
9a743685
ER
212install -d libxul-sdk
213ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
9a743685 214
fbac75ca 215cat << EOF > .mozconfig
9e7875fc 216mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 217
5745d706 218export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
219export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
765a3a27
ER
220
221%if %{with crashreporter}
222export MOZ_DEBUG_SYMBOLS=1
223%endif
224
59c5a0e8 225# Options for 'configure' (same as command-line options).
44be9ed4 226ac_add_options --prefix=%{_prefix}
227ac_add_options --exec-prefix=%{_exec_prefix}
228ac_add_options --bindir=%{_bindir}
229ac_add_options --sbindir=%{_sbindir}
230ac_add_options --sysconfdir=%{_sysconfdir}
231ac_add_options --datadir=%{_datadir}
232ac_add_options --includedir=%{_includedir}
233ac_add_options --libdir=%{_libdir}
234ac_add_options --libexecdir=%{_libexecdir}
235ac_add_options --localstatedir=%{_localstatedir}
236ac_add_options --sharedstatedir=%{_sharedstatedir}
237ac_add_options --mandir=%{_mandir}
238ac_add_options --infodir=%{_infodir}
239%if %{?debug:1}0
59c5a0e8 240ac_add_options --disable-optimize
44be9ed4 241ac_add_options --enable-debug
242ac_add_options --enable-debug-modules
59c5a0e8
SP
243ac_add_options --enable-debugger-info-modules
244ac_add_options --enable-crash-on-assert
44be9ed4 245%else
246ac_add_options --disable-debug
247ac_add_options --disable-debug-modules
59c5a0e8
SP
248ac_add_options --disable-logging
249ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 250%endif
88149483
ER
251ac_add_options --disable-strip
252ac_add_options --disable-strip-libs
44be9ed4 253%if %{with tests}
254ac_add_options --enable-tests
255%else
256ac_add_options --disable-tests
257%endif
6458b220 258ac_add_options --enable-gio
44be9ed4 259%if %{with gnomeui}
260ac_add_options --enable-gnomeui
261%else
262ac_add_options --disable-gnomeui
263%endif
44be9ed4 264ac_add_options --disable-gnomevfs
44be9ed4 265%if %{with ldap}
266ac_add_options --enable-ldap
9a743685 267ac_add_options --with-system-ldap
44be9ed4 268%else
269ac_add_options --disable-ldap
270%endif
765a3a27
ER
271%if %{with crashreporter}
272ac_add_options --enable-crashreporter
273%else
59c5a0e8 274ac_add_options --disable-crashreporter
765a3a27 275%endif
59c5a0e8 276ac_add_options --disable-xterm-updates
59c5a0e8 277ac_add_options --enable-postscript
d076d93e 278%if %{with lightning}
cb0e4412 279ac_add_options --enable-calendar
d076d93e
SP
280%else
281ac_add_options --disable-calendar
282%endif
44be9ed4 283ac_add_options --disable-installer
284ac_add_options --disable-jsd
88149483 285ac_add_options --disable-updater
44be9ed4 286ac_add_options --disable-xprint
cadfb931
SP
287ac_add_options --disable-permissions
288ac_add_options --disable-pref-extensions
44be9ed4 289ac_add_options --enable-canvas
290ac_add_options --enable-crypto
44be9ed4 291ac_add_options --enable-mathml
44be9ed4 292ac_add_options --enable-pango
293ac_add_options --enable-reorder
88149483
ER
294ac_add_options --enable-startup-notification
295ac_add_options --enable-svg
44be9ed4 296ac_add_options --enable-system-cairo
5e9bb798 297ac_add_options --enable-system-hunspell
7d981f69 298ac_add_options --enable-system-sqlite
44be9ed4 299ac_add_options --enable-xft
cadfb931
SP
300ac_add_options --enable-application=mail
301ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 302ac_add_options --enable-xinerama
88149483
ER
303ac_add_options --with-distribution-id=org.pld-linux
304ac_add_options --with-branding=icedove/branding
305%if %{with xulrunner}
f4114a7f
ER
306#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
307ac_add_options --with-system-libxul
fbac75ca 308ac_add_options --enable-shared
f4114a7f 309ac_add_options --enable-libxul
fbac75ca 310%else
f4114a7f 311ac_add_options --disable-xul
88149483
ER
312%endif
313ac_add_options --with-pthreads
314ac_add_options --with-system-bz2
44be9ed4 315ac_add_options --with-system-jpeg
316ac_add_options --with-system-nspr
317ac_add_options --with-system-nss
318ac_add_options --with-system-png
319ac_add_options --with-system-zlib
44be9ed4 320ac_add_options --enable-single-profile
321ac_add_options --disable-profilesharing
44be9ed4 322ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
323EOF
324
90e998ba 325%{__make} -j1 -f client.mk build \
d076d93e 326 STRIP="/bin/true" \
765a3a27 327 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 328 CC="%{__cc}" \
44be9ed4 329 CXX="%{__cxx}"
330
765a3a27
ER
331%if %{with crashreporter}
332# create debuginfo for crash-stats.mozilla.com
333%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
334%endif
335
44be9ed4 336%if %{with enigmail}
59c5a0e8 337cd mailnews/extensions/enigmail
9e7875fc
ER
338./makemake -r -o %{objdir}
339%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
340 STRIP="/bin/true" \
341 CC="%{__cc}" \
342 CXX="%{__cxx}"
44be9ed4 343%endif
344
345%install
346rm -rf $RPM_BUILD_ROOT
765a3a27 347install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 348
9e7875fc 349cd %{objdir}
ecf04393 350%{__make} -C mail/installer stage-package \
44be9ed4 351 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 352 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 353 PKG_SKIP_STRIP=1
354
765a3a27
ER
355# Enable crash reporter for Firefox application
356%if %{with crashreporter}
357%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
358
359# Add debuginfo for crash-stats.mozilla.com
51a3b6db 360install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
361cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
362%endif
363
ecf04393
ER
364# copy manually lightning files, somewhy they are not installed by make
365cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
366 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
367 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
368
44be9ed4 369# move arch independant ones to datadir
370mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
371mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 372mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 373mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 374mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
375ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
376ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 377ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 378ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 379ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
380
c6ec3c1c
ER
381# dir for arch independant extensions besides arch dependant extensions
382# see mozilla/xpcom/build/nsXULAppAPI.h
383# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
384install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
385
63d8f5c3 386%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 387ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
388
e6bc19b3
ER
389%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
390ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
391
44be9ed4 392%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
393ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
394ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
395
52f5507d
ER
396cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
397cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 398
e8f4ba81 399# files created by regxpcom -register in post
52fc61e6
ER
400touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
401touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
402cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
403#!/bin/sh
404umask 022
405# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
406# dangerous if you run this with sudo with keep_env += HOME
407# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
408t=$(mktemp -d)
d50a2a28 409%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
410TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
411rm -rf $t
412EOF
413chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 414
44be9ed4 415%if %{with enigmail}
283702b9
ER
416ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
417install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6 418cd mozilla/dist/bin
0516fc42 419#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
420#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
52fc61e6
ER
421cp -rfLp components/enig* $ext_dir/components
422cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 423cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
424cp -rfLp components/ipc.xpt $ext_dir/components
425cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
426cd -
52f5507d
ER
427cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
428cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 429%endif
430
9a743685 431# remove unecessary stuff
9e402408 432#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
0516fc42 433#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
434#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
44be9ed4 435
9cdc8923
ER
436# never package these. always remove
437# nss
438%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
439# nspr
440%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 441# mozldap
9cdc8923 442%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
283702b9 443
44be9ed4 444%clean
445rm -rf $RPM_BUILD_ROOT
446
447%pretrans
448if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
449 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
450fi
6b327de6 451for d in chrome defaults icons isp modules res; do
44be9ed4 452 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
453 install -d %{_datadir}/%{name}
454 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
455 fi
456done
457exit 0
458
e8f4ba81
ER
459%post
460%{_libdir}/%{name}/register || :
461
44be9ed4 462%files
463%defattr(644,root,root,755)
464%attr(755,root,root) %{_bindir}/icedove
465%attr(755,root,root) %{_bindir}/mozilla-thunderbird
466%attr(755,root,root) %{_bindir}/thunderbird
467%dir %{_libdir}/%{name}
765a3a27
ER
468%{_libdir}/%{name}/application.ini
469%{_libdir}/%{name}/platform.ini
6b327de6
JB
470%{_libdir}/%{name}/blocklist.xml
471%{_libdir}/%{name}/chrome.manifest
472%{_libdir}/%{name}/greprefs.js
44be9ed4 473%dir %{_libdir}/%{name}/components
474%attr(755,root,root) %{_libdir}/%{name}/components/*.so
475%{_libdir}/%{name}/components/*.js
476%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
477%{_libdir}/%{name}/components/components.manifest
478%{_libdir}/%{name}/components/interfaces.manifest
0516fc42 479%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 480%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 481%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 482%attr(755,root,root) %{_libdir}/%{name}/*.sh
483%attr(755,root,root) %{_libdir}/%{name}/*-bin
484%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 485%attr(755,root,root) %{_libdir}/%{name}/icedove
cf62736e 486%attr(755,root,root) %{_libdir}/%{name}/plugin-container
e8f4ba81 487%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 488
489# symlinks
490%{_libdir}/%{name}/chrome
491%{_libdir}/%{name}/defaults
492%{_libdir}/%{name}/dictionaries
e6bc19b3 493%{_libdir}/%{name}/hyphenation
44be9ed4 494%{_libdir}/%{name}/isp
9e097178 495%{_libdir}/%{name}/modules
44be9ed4 496%{_libdir}/%{name}/res
497
293928f3 498%{_pixmapsdir}/*.png
44be9ed4 499%{_desktopdir}/*.desktop
500
501%dir %{_datadir}/%{name}
502%{_datadir}/%{name}/chrome
503%{_datadir}/%{name}/defaults
0516fc42 504#%%{_datadir}/%{name}/greprefs
44be9ed4 505%{_datadir}/%{name}/isp
9e097178 506%{_datadir}/%{name}/modules
44be9ed4 507%{_datadir}/%{name}/res
c6ec3c1c 508%{_datadir}/%{name}/extensions
44be9ed4 509
765a3a27
ER
510%if %{with crashreporter}
511%attr(755,root,root) %{_libdir}/%{name}/crashreporter
512%{_libdir}/%{name}/crashreporter.ini
513%{_libdir}/%{name}/Throbber-small.gif
514%endif
515
44be9ed4 516%dir %{_libdir}/%{name}/extensions
517%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 518
52fc61e6
ER
519# files created by regxpcom -register
520%ghost %{_libdir}/%{name}/components/compreg.dat
521%ghost %{_libdir}/%{name}/components/xpti.dat
522
6578c165 523%if %{with lightning}
524%files addon-lightning
525%defattr(644,root,root,755)
f3b6d696 526%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 527%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
528%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
529%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 530%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
531%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
532%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
533%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 534%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
535%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
536%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
537%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
539%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 540%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
541%endif
44be9ed4 542
543%if %{with enigmail}
544%files addon-enigmail
545%defattr(644,root,root,755)
f6a43e2f
ER
546%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
547%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
548%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
549%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
550%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
551%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
552%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
553%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
554%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 555%endif
This page took 0.169506 seconds and 4 git commands to generate.