]> git.pld-linux.org Git - packages/icedove.git/blame - icedove.spec
- xulrunner/icedove now requires libjpeg-turbo (with at least libjpeg 6b API), not...
[packages/icedove.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 11%bcond_with xulrunner # system xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
9c1b9ad4
JR
22%define enigmail_ver 1.5.0
23%define nspr_ver 4.9.3
24%define nss_ver 3.14.1
44be9ed4 25
aaaf7356 26%define xulrunner_ver 2:17.0
4f34f106 27
7d981f69
ER
28%if %{without xulrunner}
29# The actual sqlite version (see RHBZ#480989):
30%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31%endif
32
44be9ed4 33Summary: Icedove - email client
34Summary(pl.UTF-8): Icedove - klient poczty
35Name: icedove
9c1b9ad4 36Version: 17.0.2
e82da7a1 37Release: 2
44be9ed4 38License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 39Group: X11/Applications/Networking
cadfb931 40Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
9c1b9ad4 41# Source0-md5: 9b7f15fbc672745571d47a3c0e227ca1
44be9ed4 42Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
9c1b9ad4 43# Source1-md5: af4b3534417f32dc201765e4de6ecc86
44be9ed4 44Source2: %{name}-branding.tar.bz2
c105f759 45# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 46Source3: %{name}-rm_nonfree.sh
47Source4: %{name}.desktop
48Source5: %{name}.sh
44be9ed4 49Patch0: %{name}-branding.patch
faa5c89d 50Patch1: %{name}-enigmail-shared.patch
fac7e24d 51Patch2: %{name}-system-xulrunner.patch
faa5c89d
SP
52Patch3: %{name}-fonts.patch
53Patch4: %{name}-install.patch
5e9bb798 54Patch5: %{name}-hunspell.patch
faa5c89d 55Patch6: %{name}-prefs.patch
9a743685 56Patch7: system-mozldap.patch
a85e0ecb 57Patch8: %{name}-makefile.patch
37973fb0 58Patch9: system-cairo.patch
ccc206fe 59Patch10: %{name}-extensiondir.patch
765a3a27 60Patch11: crashreporter.patch
268e7766 61Patch12: no-subshell.patch
03be87a5
JR
62# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
63Patch13: system-virtualenv.patch
5745d706 64URL: http://www.pld-linux.org/Packages/Icedove
6458b220 65BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 66BuildRequires: alsa-lib-devel
44be9ed4 67BuildRequires: automake
51a3b6db 68BuildRequires: bzip2-devel
e820c55e
JB
69BuildRequires: cairo-devel >= 1.10
70BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 71BuildRequires: freetype-devel >= 1:2.1.8
6458b220 72BuildRequires: glib2-devel >= 2.0
e820c55e 73BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 74BuildRequires: hunspell-devel
44be9ed4 75BuildRequires: libIDL-devel >= 0.8.0
6458b220 76%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 77%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 78%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 79BuildRequires: libiw-devel
e82da7a1 80# requires libjpeg-turbo implementing at least libjpeg 6b API
44be9ed4 81BuildRequires: libjpeg-devel >= 6b
e82da7a1 82BuildRequires: libjpeg-turbo-devel
51a3b6db 83BuildRequires: libnotify-devel >= 0.4
e820c55e 84BuildRequires: libpng-devel >= 1.4.1
44be9ed4 85BuildRequires: libstdc++-devel
f4114a7f
ER
86BuildRequires: nspr-devel >= 1:%{nspr_ver}
87BuildRequires: nss-devel >= 1:%{nss_ver}
3815090b 88BuildRequires: pango-devel >= 1:1.14.0
e820c55e 89BuildRequires: perl-base >= 1:5.6
1c62cadb 90BuildRequires: pkgconfig
e820c55e 91BuildRequires: python >= 1:2.5
44be9ed4 92BuildRequires: sed >= 4.0
9d1bfad8 93BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 94BuildRequires: startup-notification-devel >= 0.8
44be9ed4 95BuildRequires: xorg-lib-libXext-devel
44be9ed4 96BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 97BuildRequires: xorg-lib-libXt-devel
5745d706 98BuildRequires: yasm
1c62cadb 99BuildRequires: zip
7d981f69 100%if %{with xulrunner}
e8326f77 101BuildRequires: xulrunner-devel >= %{xulrunner_ver}
7d981f69 102%else
44be9ed4 103Requires: myspell-common
f4114a7f
ER
104Requires: nspr >= 1:%{nspr_ver}
105Requires: nss >= 1:%{nss_ver}
4b6bc367 106Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 107%endif
4f34f106
ER
108Requires(post): mktemp >= 1.5-18
109%if %{with xulrunner}
110%requires_eq_to xulrunner xulrunner-devel
111%endif
e82da7a1 112Requires: libjpeg-turbo
44be9ed4 113Obsoletes: mozilla-thunderbird
114Obsoletes: mozilla-thunderbird-dictionary-en-US
d606e9b3 115Conflicts: icedove-lang-resources < %{version}
44be9ed4 116BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
9e366f18
AM
118%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
119
44be9ed4 120# iceweasel/icedove/iceape provide their own versions
44be9ed4 121%define _noautoprovfiles %{_libdir}/%{name}/components
fb7d4f06
JB
122%if %{without xulrunner}
123# we don't want these to satisfy packages depending on xulrunner
124%define _noautoprov libmozalloc.so libxpcom.so libxul.so
44be9ed4 125# and as we don't provide them, don't require either
fb7d4f06
JB
126%define _noautoreq libmozalloc.so libxpcom.so libxul.so
127%endif
44be9ed4 128
9e7875fc
ER
129%define topdir %{_builddir}/%{name}-%{version}
130%define objdir %{topdir}/obj-%{_target_cpu}
131
44be9ed4 132%description
6b327de6 133Icedove is an open-source, fast and portable email client.
44be9ed4 134
135%description -l pl.UTF-8
6b327de6
JB
136Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
137poczty.
44be9ed4 138
6578c165 139%package addon-lightning
140Summary: An integrated calendar for Icedove
141Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
142License: MPL 1.1 or GPL v2+ or LGPL v2.1+
143Group: Applications/Networking
144Requires: %{name} = %{version}-%{release}
145
146%description addon-lightning
147Lightning is an calendar extension to Icedove email client.
148
149%description addon-lightning -l pl.UTF-8
150Lightning to rozszerzenie do klienta poczty Icedove dodające
151funkcjonalność kalendarza.
152
44be9ed4 153%package addon-enigmail
154Summary: Extension for the authentication and encryption features provided by GnuPG
155Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
156License: MPL/LGPL
157Group: Applications/Networking
158URL: http://enigmail.mozdev.org/
cd056caa 159Requires: %{name} = %{version}-%{release}
d076d93e 160Requires: gnupg
75991bbb 161Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 162
163%description addon-enigmail
c5e06599 164Enigmail is an extension to the Icedove mail client which allows users
165to access the authentication and encryption features provided by
166GnuPG.
44be9ed4 167
168Main Features:
169- Encrypt/sign mail when sending, decrypt/authenticate received mail
170- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
171- Per-Account based encryption and signing defaults
172- Per-Recipient rules for automated key selection, and
173 enabling/disabling encryption and signing
174- OpenPGP key management interface
175
176%description addon-enigmail -l pl.UTF-8
c5e06599 177Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
178użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
179przez GnuPG.
44be9ed4 180
181Główne możliwości:
182- szyfrowanie/podpisywanie poczty przy wysyłaniu,
183 odszyfrowywanie/uwierzytelnianie poczty odebranej
184- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
185- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
186- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
187 podpisywania dla każdego adresata
188- interfejs do zarządzania kluczami OpenPGP
189
190%prep
983562b1 191%setup -qc
f4114a7f 192mv comm-release mozilla
983562b1 193%setup -q -T -D -a2
194cd mozilla
1c70899a 195%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 196/bin/sh %{SOURCE3}
983562b1 197%patch0 -p1
faa5c89d 198%{?with_enigmail:%patch1 -p1}
73d54cb2 199%{?with_xulrunner:%patch2 -p1}
4ccc2157 200%patch3 -p1
faa5c89d 201%patch4 -p1
983562b1 202%patch6 -p1
9a743685 203%patch7 -p1
f4114a7f 204%patch8 -p2
3815090b 205%patch9 -p1
ccc206fe 206%patch10 -p2
765a3a27 207%patch11 -p2
268e7766 208%patch12 -p1
03be87a5 209%patch13 -p1
44be9ed4 210
211%build
983562b1 212cd mozilla
cadfb931
SP
213cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
214cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 215cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 216
fbac75ca 217cat << EOF > .mozconfig
9e7875fc 218mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 219
fac7e24d 220export CFLAGS="%{rpmcflags}"
73d54cb2 221export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
222
223%if %{with crashreporter}
224export MOZ_DEBUG_SYMBOLS=1
225%endif
226
59c5a0e8 227# Options for 'configure' (same as command-line options).
44be9ed4 228ac_add_options --prefix=%{_prefix}
229ac_add_options --exec-prefix=%{_exec_prefix}
230ac_add_options --bindir=%{_bindir}
231ac_add_options --sbindir=%{_sbindir}
232ac_add_options --sysconfdir=%{_sysconfdir}
233ac_add_options --datadir=%{_datadir}
234ac_add_options --includedir=%{_includedir}
235ac_add_options --libdir=%{_libdir}
236ac_add_options --libexecdir=%{_libexecdir}
237ac_add_options --localstatedir=%{_localstatedir}
238ac_add_options --sharedstatedir=%{_sharedstatedir}
239ac_add_options --mandir=%{_mandir}
240ac_add_options --infodir=%{_infodir}
241%if %{?debug:1}0
59c5a0e8 242ac_add_options --disable-optimize
44be9ed4 243ac_add_options --enable-debug
244ac_add_options --enable-debug-modules
59c5a0e8
SP
245ac_add_options --enable-debugger-info-modules
246ac_add_options --enable-crash-on-assert
44be9ed4 247%else
248ac_add_options --disable-debug
249ac_add_options --disable-debug-modules
59c5a0e8
SP
250ac_add_options --disable-logging
251ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 252%endif
88149483
ER
253ac_add_options --disable-strip
254ac_add_options --disable-strip-libs
44be9ed4 255%if %{with tests}
256ac_add_options --enable-tests
257%else
258ac_add_options --disable-tests
259%endif
6458b220 260ac_add_options --enable-gio
44be9ed4 261%if %{with gnomeui}
262ac_add_options --enable-gnomeui
263%else
264ac_add_options --disable-gnomeui
265%endif
44be9ed4 266ac_add_options --disable-gnomevfs
44be9ed4 267%if %{with ldap}
268ac_add_options --enable-ldap
9a743685 269ac_add_options --with-system-ldap
44be9ed4 270%else
271ac_add_options --disable-ldap
272%endif
765a3a27
ER
273%if %{with crashreporter}
274ac_add_options --enable-crashreporter
275%else
59c5a0e8 276ac_add_options --disable-crashreporter
765a3a27 277%endif
59c5a0e8 278ac_add_options --disable-xterm-updates
59c5a0e8 279ac_add_options --enable-postscript
d076d93e 280%if %{with lightning}
cb0e4412 281ac_add_options --enable-calendar
d076d93e
SP
282%else
283ac_add_options --disable-calendar
284%endif
44be9ed4 285ac_add_options --disable-installer
88149483 286ac_add_options --disable-updater
44be9ed4 287ac_add_options --disable-xprint
cadfb931
SP
288ac_add_options --disable-permissions
289ac_add_options --disable-pref-extensions
44be9ed4 290ac_add_options --enable-canvas
291ac_add_options --enable-crypto
44be9ed4 292ac_add_options --enable-mathml
44be9ed4 293ac_add_options --enable-pango
294ac_add_options --enable-reorder
88149483
ER
295ac_add_options --enable-startup-notification
296ac_add_options --enable-svg
44be9ed4 297ac_add_options --enable-system-cairo
5e9bb798 298ac_add_options --enable-system-hunspell
7d981f69 299ac_add_options --enable-system-sqlite
44be9ed4 300ac_add_options --enable-xft
cadfb931
SP
301ac_add_options --enable-application=mail
302ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 303ac_add_options --enable-xinerama
88149483
ER
304ac_add_options --with-distribution-id=org.pld-linux
305ac_add_options --with-branding=icedove/branding
306%if %{with xulrunner}
fac7e24d
JB
307ac_add_options --enable-shared-js
308ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
f4114a7f 309ac_add_options --with-system-libxul
88149483
ER
310%endif
311ac_add_options --with-pthreads
312ac_add_options --with-system-bz2
44be9ed4 313ac_add_options --with-system-jpeg
314ac_add_options --with-system-nspr
315ac_add_options --with-system-nss
316ac_add_options --with-system-png
317ac_add_options --with-system-zlib
44be9ed4 318ac_add_options --enable-single-profile
319ac_add_options --disable-profilesharing
44be9ed4 320ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
321EOF
322
90e998ba 323%{__make} -j1 -f client.mk build \
d076d93e 324 STRIP="/bin/true" \
765a3a27 325 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
de09c00d 326 XLIBS="-lX11 -lXt" \
d076d93e 327 CC="%{__cc}" \
44be9ed4 328 CXX="%{__cxx}"
329
765a3a27
ER
330%if %{with crashreporter}
331# create debuginfo for crash-stats.mozilla.com
332%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
333%endif
334
44be9ed4 335%if %{with enigmail}
59c5a0e8 336cd mailnews/extensions/enigmail
9e7875fc
ER
337./makemake -r -o %{objdir}
338%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
339 STRIP="/bin/true" \
340 CC="%{__cc}" \
341 CXX="%{__cxx}"
916d4050
JR
342
343%{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
344 STRIP="/bin/true" \
345 CC="%{__cc}" \
346 CXX="%{__cxx}"
44be9ed4 347%endif
348
349%install
350rm -rf $RPM_BUILD_ROOT
765a3a27 351install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 352
9e7875fc 353cd %{objdir}
ecf04393 354%{__make} -C mail/installer stage-package \
44be9ed4 355 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 356 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 357 PKG_SKIP_STRIP=1
358
9b40a2c3
JB
359%if %{with xulrunner}
360# needed to find mozilla runtime
361ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
362%endif
363
364# Enable crash reporter for Thunderbird application
765a3a27
ER
365%if %{with crashreporter}
366%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
367
368# Add debuginfo for crash-stats.mozilla.com
51a3b6db 369install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
370cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
371%endif
372
ecf04393
ER
373# copy manually lightning files, somewhy they are not installed by make
374cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
375 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
376 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
377
44be9ed4 378# move arch independant ones to datadir
379mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
380mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 381mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 382mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
eca54e0f 383mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 384ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
385ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 386ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 387ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
eca54e0f 388ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
73d54cb2
JB
389%if %{without xulrunner}
390mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
391ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
392%endif
44be9ed4 393
c6ec3c1c
ER
394# dir for arch independant extensions besides arch dependant extensions
395# see mozilla/xpcom/build/nsXULAppAPI.h
396# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
397install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
398
73d54cb2 399%if %{without xulrunner}
63d8f5c3 400%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 401ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
e6bc19b3
ER
402%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
403ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
73d54cb2 404%endif
e6bc19b3 405
0889474f
JR
406%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
407 -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
408 %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
409
44be9ed4 410%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
411ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
412ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
413
52f5507d
ER
414cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
415cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 416
e8f4ba81 417# files created by regxpcom -register in post
52fc61e6
ER
418touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
419touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
420cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
421#!/bin/sh
422umask 022
423# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
424# dangerous if you run this with sudo with keep_env += HOME
425# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
426t=$(mktemp -d)
d50a2a28 427%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
428TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
429rm -rf $t
430EOF
431chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 432
44be9ed4 433%if %{with enigmail}
283702b9 434ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
916d4050 435install -d $ext_dir/{chrome,components,defaults/preferences,modules}
52fc61e6 436cd mozilla/dist/bin
916d4050 437cp -rfLp chrome/enigmail.jar $ext_dir/chrome
52fc61e6
ER
438cp -rfLp components/enig* $ext_dir/components
439cp -rfLp components/libenigmime.so $ext_dir/components
52fc61e6 440cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
de09c00d 441cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
916d4050 442cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
52fc61e6 443cd -
52f5507d
ER
444cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
445cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 446%endif
447
9cdc8923
ER
448# never package these. always remove
449# nss
450%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
451# nspr
452%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 453# mozldap
9cdc8923 454%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
3815090b
ER
455# testpilot quiz
456%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
283702b9 457
44be9ed4 458%clean
459rm -rf $RPM_BUILD_ROOT
460
461%pretrans
462if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
463 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
464fi
eca54e0f 465for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 466 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
467 install -d %{_datadir}/%{name}
468 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
469 fi
470done
471exit 0
472
e8f4ba81
ER
473%post
474%{_libdir}/%{name}/register || :
475
44be9ed4 476%files
477%defattr(644,root,root,755)
478%attr(755,root,root) %{_bindir}/icedove
479%attr(755,root,root) %{_bindir}/mozilla-thunderbird
480%attr(755,root,root) %{_bindir}/thunderbird
481%dir %{_libdir}/%{name}
765a3a27 482%{_libdir}/%{name}/application.ini
6b327de6
JB
483%{_libdir}/%{name}/blocklist.xml
484%{_libdir}/%{name}/chrome.manifest
44be9ed4 485%dir %{_libdir}/%{name}/components
44be9ed4 486%{_libdir}/%{name}/components/*.js
487%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
488%{_libdir}/%{name}/components/components.manifest
489%{_libdir}/%{name}/components/interfaces.manifest
73d54cb2
JB
490%attr(755,root,root) %{_libdir}/%{name}/*.sh
491%attr(755,root,root) %{_libdir}/%{name}/*-bin
492%attr(755,root,root) %{_libdir}/%{name}/icedove
493%attr(755,root,root) %{_libdir}/%{name}/register
494%if %{without xulrunner}
495%{_libdir}/%{name}/platform.ini
496%{_libdir}/%{name}/greprefs.js
497%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 498%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 499%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 500%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 501%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
cf62736e 502%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 503%endif
44be9ed4 504
505# symlinks
506%{_libdir}/%{name}/chrome
507%{_libdir}/%{name}/defaults
44be9ed4 508%{_libdir}/%{name}/isp
9e097178 509%{_libdir}/%{name}/modules
eca54e0f 510%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
511%if %{with xulrunner}
512%{_libdir}/%{name}/xulrunner
513%else
73d54cb2
JB
514%{_libdir}/%{name}/dictionaries
515%{_libdir}/%{name}/hyphenation
516%{_libdir}/%{name}/res
517%endif
44be9ed4 518
224cf96a
JB
519%{_pixmapsdir}/icedove.png
520%{_desktopdir}/icedove.desktop
44be9ed4 521
522%dir %{_datadir}/%{name}
523%{_datadir}/%{name}/chrome
524%{_datadir}/%{name}/defaults
eca54e0f 525%{_datadir}/%{name}/extensions
44be9ed4 526%{_datadir}/%{name}/isp
9e097178 527%{_datadir}/%{name}/modules
916d4050
JR
528%if %{with enigmail}
529%exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
530%exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
531%exclude %{_datadir}/%{name}/modules/keyManagement.jsm
532%exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
916d4050
JR
533%exclude %{_datadir}/%{name}/modules/subprocess.jsm
534%exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
535%exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
536%endif
eca54e0f 537%{_datadir}/%{name}/searchplugins
73d54cb2
JB
538%if %{without xulrunner}
539%{_datadir}/%{name}/res
540%endif
44be9ed4 541
765a3a27
ER
542%if %{with crashreporter}
543%attr(755,root,root) %{_libdir}/%{name}/crashreporter
544%{_libdir}/%{name}/crashreporter.ini
545%{_libdir}/%{name}/Throbber-small.gif
546%endif
547
44be9ed4 548%dir %{_libdir}/%{name}/extensions
549%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 550
52fc61e6
ER
551# files created by regxpcom -register
552%ghost %{_libdir}/%{name}/components/compreg.dat
553%ghost %{_libdir}/%{name}/components/xpti.dat
554
6578c165 555%if %{with lightning}
556%files addon-lightning
557%defattr(644,root,root,755)
f3b6d696 558%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 559%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
560%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
561%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 562%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
563%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
564%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
565%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 566%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
567%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
568%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
569%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
570%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
571%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 572%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
573%endif
44be9ed4 574
575%if %{with enigmail}
576%files addon-enigmail
577%defattr(644,root,root,755)
f6a43e2f
ER
578%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
579%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
580%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
581%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
582%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
583%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
584%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
585%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
586%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
916d4050
JR
587%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
588%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
589%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
44be9ed4 590%endif
This page took 0.187161 seconds and 4 git commands to generate.