]> git.pld-linux.org Git - packages/icedove.git/blame - icedove.spec
- added gyp-slashism patch (try to eliminate double slashes) to fix debuginfo problem
[packages/icedove.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 11%bcond_with xulrunner # system xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
9c1b9ad4
JR
22%define enigmail_ver 1.5.0
23%define nspr_ver 4.9.3
24%define nss_ver 3.14.1
44be9ed4 25
aaaf7356 26%define xulrunner_ver 2:17.0
4f34f106 27
7d981f69
ER
28%if %{without xulrunner}
29# The actual sqlite version (see RHBZ#480989):
30%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
31%endif
32
44be9ed4 33Summary: Icedove - email client
34Summary(pl.UTF-8): Icedove - klient poczty
35Name: icedove
9c1b9ad4 36Version: 17.0.2
13ed8387 37Release: 2
44be9ed4 38License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 39Group: X11/Applications/Networking
cadfb931 40Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
9c1b9ad4 41# Source0-md5: 9b7f15fbc672745571d47a3c0e227ca1
44be9ed4 42Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
9c1b9ad4 43# Source1-md5: af4b3534417f32dc201765e4de6ecc86
44be9ed4 44Source2: %{name}-branding.tar.bz2
c105f759 45# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 46Source3: %{name}-rm_nonfree.sh
47Source4: %{name}.desktop
48Source5: %{name}.sh
44be9ed4 49Patch0: %{name}-branding.patch
faa5c89d 50Patch1: %{name}-enigmail-shared.patch
fac7e24d 51Patch2: %{name}-system-xulrunner.patch
faa5c89d
SP
52Patch3: %{name}-fonts.patch
53Patch4: %{name}-install.patch
5e9bb798 54Patch5: %{name}-hunspell.patch
faa5c89d 55Patch6: %{name}-prefs.patch
9a743685 56Patch7: system-mozldap.patch
a85e0ecb 57Patch8: %{name}-makefile.patch
37973fb0 58Patch9: system-cairo.patch
ccc206fe 59Patch10: %{name}-extensiondir.patch
765a3a27 60Patch11: crashreporter.patch
268e7766 61Patch12: no-subshell.patch
03be87a5
JR
62# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
63Patch13: system-virtualenv.patch
13ed8387 64Patch14: gyp-slashism.patch
5745d706 65URL: http://www.pld-linux.org/Packages/Icedove
6458b220 66BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 67BuildRequires: alsa-lib-devel
44be9ed4 68BuildRequires: automake
51a3b6db 69BuildRequires: bzip2-devel
e820c55e
JB
70BuildRequires: cairo-devel >= 1.10
71BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 72BuildRequires: freetype-devel >= 1:2.1.8
6458b220 73BuildRequires: glib2-devel >= 2.0
e820c55e 74BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 75BuildRequires: hunspell-devel
44be9ed4 76BuildRequires: libIDL-devel >= 0.8.0
6458b220 77%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 78%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 79%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 80BuildRequires: libiw-devel
44be9ed4 81BuildRequires: libjpeg-devel >= 6b
51a3b6db 82BuildRequires: libnotify-devel >= 0.4
e820c55e 83BuildRequires: libpng-devel >= 1.4.1
44be9ed4 84BuildRequires: libstdc++-devel
f4114a7f
ER
85BuildRequires: nspr-devel >= 1:%{nspr_ver}
86BuildRequires: nss-devel >= 1:%{nss_ver}
3815090b 87BuildRequires: pango-devel >= 1:1.14.0
e820c55e 88BuildRequires: perl-base >= 1:5.6
1c62cadb 89BuildRequires: pkgconfig
e820c55e 90BuildRequires: python >= 1:2.5
44be9ed4 91BuildRequires: sed >= 4.0
9d1bfad8 92BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 93BuildRequires: startup-notification-devel >= 0.8
44be9ed4 94BuildRequires: xorg-lib-libXext-devel
44be9ed4 95BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 96BuildRequires: xorg-lib-libXt-devel
5745d706 97BuildRequires: yasm
1c62cadb 98BuildRequires: zip
7d981f69 99%if %{with xulrunner}
e8326f77 100BuildRequires: xulrunner-devel >= %{xulrunner_ver}
7d981f69 101%else
44be9ed4 102Requires: myspell-common
f4114a7f
ER
103Requires: nspr >= 1:%{nspr_ver}
104Requires: nss >= 1:%{nss_ver}
4b6bc367 105Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 106%endif
4f34f106
ER
107Requires(post): mktemp >= 1.5-18
108%if %{with xulrunner}
109%requires_eq_to xulrunner xulrunner-devel
110%endif
44be9ed4 111Obsoletes: mozilla-thunderbird
112Obsoletes: mozilla-thunderbird-dictionary-en-US
d606e9b3 113Conflicts: icedove-lang-resources < %{version}
44be9ed4 114BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
9e366f18
AM
116%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
117
44be9ed4 118# iceweasel/icedove/iceape provide their own versions
44be9ed4 119%define _noautoprovfiles %{_libdir}/%{name}/components
fb7d4f06
JB
120%if %{without xulrunner}
121# we don't want these to satisfy packages depending on xulrunner
122%define _noautoprov libmozalloc.so libxpcom.so libxul.so
44be9ed4 123# and as we don't provide them, don't require either
fb7d4f06
JB
124%define _noautoreq libmozalloc.so libxpcom.so libxul.so
125%endif
44be9ed4 126
9e7875fc
ER
127%define topdir %{_builddir}/%{name}-%{version}
128%define objdir %{topdir}/obj-%{_target_cpu}
129
44be9ed4 130%description
6b327de6 131Icedove is an open-source, fast and portable email client.
44be9ed4 132
133%description -l pl.UTF-8
6b327de6
JB
134Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
135poczty.
44be9ed4 136
6578c165 137%package addon-lightning
138Summary: An integrated calendar for Icedove
139Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
140License: MPL 1.1 or GPL v2+ or LGPL v2.1+
141Group: Applications/Networking
142Requires: %{name} = %{version}-%{release}
143
144%description addon-lightning
145Lightning is an calendar extension to Icedove email client.
146
147%description addon-lightning -l pl.UTF-8
148Lightning to rozszerzenie do klienta poczty Icedove dodające
149funkcjonalność kalendarza.
150
44be9ed4 151%package addon-enigmail
152Summary: Extension for the authentication and encryption features provided by GnuPG
153Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
154License: MPL/LGPL
155Group: Applications/Networking
156URL: http://enigmail.mozdev.org/
cd056caa 157Requires: %{name} = %{version}-%{release}
d076d93e 158Requires: gnupg
75991bbb 159Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 160
161%description addon-enigmail
c5e06599 162Enigmail is an extension to the Icedove mail client which allows users
163to access the authentication and encryption features provided by
164GnuPG.
44be9ed4 165
166Main Features:
167- Encrypt/sign mail when sending, decrypt/authenticate received mail
168- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
169- Per-Account based encryption and signing defaults
170- Per-Recipient rules for automated key selection, and
171 enabling/disabling encryption and signing
172- OpenPGP key management interface
173
174%description addon-enigmail -l pl.UTF-8
c5e06599 175Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
176użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
177przez GnuPG.
44be9ed4 178
179Główne możliwości:
180- szyfrowanie/podpisywanie poczty przy wysyłaniu,
181 odszyfrowywanie/uwierzytelnianie poczty odebranej
182- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
183- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
184- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
185 podpisywania dla każdego adresata
186- interfejs do zarządzania kluczami OpenPGP
187
188%prep
983562b1 189%setup -qc
f4114a7f 190mv comm-release mozilla
983562b1 191%setup -q -T -D -a2
192cd mozilla
1c70899a 193%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 194/bin/sh %{SOURCE3}
983562b1 195%patch0 -p1
faa5c89d 196%{?with_enigmail:%patch1 -p1}
73d54cb2 197%{?with_xulrunner:%patch2 -p1}
4ccc2157 198%patch3 -p1
faa5c89d 199%patch4 -p1
983562b1 200%patch6 -p1
9a743685 201%patch7 -p1
f4114a7f 202%patch8 -p2
3815090b 203%patch9 -p1
ccc206fe 204%patch10 -p2
765a3a27 205%patch11 -p2
268e7766 206%patch12 -p1
03be87a5 207%patch13 -p1
13ed8387 208%patch14 -p1
44be9ed4 209
210%build
983562b1 211cd mozilla
cadfb931
SP
212cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
213cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 214cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 215
fbac75ca 216cat << EOF > .mozconfig
9e7875fc 217mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 218
fac7e24d 219export CFLAGS="%{rpmcflags}"
73d54cb2 220export CXXFLAGS="%{rpmcflags}"
765a3a27
ER
221
222%if %{with crashreporter}
223export MOZ_DEBUG_SYMBOLS=1
224%endif
225
59c5a0e8 226# Options for 'configure' (same as command-line options).
44be9ed4 227ac_add_options --prefix=%{_prefix}
228ac_add_options --exec-prefix=%{_exec_prefix}
229ac_add_options --bindir=%{_bindir}
230ac_add_options --sbindir=%{_sbindir}
231ac_add_options --sysconfdir=%{_sysconfdir}
232ac_add_options --datadir=%{_datadir}
233ac_add_options --includedir=%{_includedir}
234ac_add_options --libdir=%{_libdir}
235ac_add_options --libexecdir=%{_libexecdir}
236ac_add_options --localstatedir=%{_localstatedir}
237ac_add_options --sharedstatedir=%{_sharedstatedir}
238ac_add_options --mandir=%{_mandir}
239ac_add_options --infodir=%{_infodir}
240%if %{?debug:1}0
59c5a0e8 241ac_add_options --disable-optimize
44be9ed4 242ac_add_options --enable-debug
243ac_add_options --enable-debug-modules
59c5a0e8
SP
244ac_add_options --enable-debugger-info-modules
245ac_add_options --enable-crash-on-assert
44be9ed4 246%else
247ac_add_options --disable-debug
248ac_add_options --disable-debug-modules
59c5a0e8
SP
249ac_add_options --disable-logging
250ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 251%endif
88149483
ER
252ac_add_options --disable-strip
253ac_add_options --disable-strip-libs
44be9ed4 254%if %{with tests}
255ac_add_options --enable-tests
256%else
257ac_add_options --disable-tests
258%endif
6458b220 259ac_add_options --enable-gio
44be9ed4 260%if %{with gnomeui}
261ac_add_options --enable-gnomeui
262%else
263ac_add_options --disable-gnomeui
264%endif
44be9ed4 265ac_add_options --disable-gnomevfs
44be9ed4 266%if %{with ldap}
267ac_add_options --enable-ldap
9a743685 268ac_add_options --with-system-ldap
44be9ed4 269%else
270ac_add_options --disable-ldap
271%endif
765a3a27
ER
272%if %{with crashreporter}
273ac_add_options --enable-crashreporter
274%else
59c5a0e8 275ac_add_options --disable-crashreporter
765a3a27 276%endif
59c5a0e8 277ac_add_options --disable-xterm-updates
59c5a0e8 278ac_add_options --enable-postscript
d076d93e 279%if %{with lightning}
cb0e4412 280ac_add_options --enable-calendar
d076d93e
SP
281%else
282ac_add_options --disable-calendar
283%endif
44be9ed4 284ac_add_options --disable-installer
88149483 285ac_add_options --disable-updater
44be9ed4 286ac_add_options --disable-xprint
cadfb931
SP
287ac_add_options --disable-permissions
288ac_add_options --disable-pref-extensions
44be9ed4 289ac_add_options --enable-canvas
290ac_add_options --enable-crypto
44be9ed4 291ac_add_options --enable-mathml
44be9ed4 292ac_add_options --enable-pango
293ac_add_options --enable-reorder
88149483
ER
294ac_add_options --enable-startup-notification
295ac_add_options --enable-svg
44be9ed4 296ac_add_options --enable-system-cairo
5e9bb798 297ac_add_options --enable-system-hunspell
7d981f69 298ac_add_options --enable-system-sqlite
44be9ed4 299ac_add_options --enable-xft
cadfb931
SP
300ac_add_options --enable-application=mail
301ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 302ac_add_options --enable-xinerama
88149483
ER
303ac_add_options --with-distribution-id=org.pld-linux
304ac_add_options --with-branding=icedove/branding
305%if %{with xulrunner}
fac7e24d
JB
306ac_add_options --enable-shared-js
307ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
f4114a7f 308ac_add_options --with-system-libxul
88149483
ER
309%endif
310ac_add_options --with-pthreads
311ac_add_options --with-system-bz2
44be9ed4 312ac_add_options --with-system-jpeg
313ac_add_options --with-system-nspr
314ac_add_options --with-system-nss
315ac_add_options --with-system-png
316ac_add_options --with-system-zlib
44be9ed4 317ac_add_options --enable-single-profile
318ac_add_options --disable-profilesharing
44be9ed4 319ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
320EOF
321
90e998ba 322%{__make} -j1 -f client.mk build \
d076d93e 323 STRIP="/bin/true" \
765a3a27 324 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
de09c00d 325 XLIBS="-lX11 -lXt" \
d076d93e 326 CC="%{__cc}" \
44be9ed4 327 CXX="%{__cxx}"
328
765a3a27
ER
329%if %{with crashreporter}
330# create debuginfo for crash-stats.mozilla.com
331%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
332%endif
333
44be9ed4 334%if %{with enigmail}
59c5a0e8 335cd mailnews/extensions/enigmail
9e7875fc
ER
336./makemake -r -o %{objdir}
337%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
338 STRIP="/bin/true" \
339 CC="%{__cc}" \
340 CXX="%{__cxx}"
916d4050
JR
341
342%{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
343 STRIP="/bin/true" \
344 CC="%{__cc}" \
345 CXX="%{__cxx}"
44be9ed4 346%endif
347
348%install
349rm -rf $RPM_BUILD_ROOT
765a3a27 350install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 351
9e7875fc 352cd %{objdir}
ecf04393 353%{__make} -C mail/installer stage-package \
44be9ed4 354 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 355 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 356 PKG_SKIP_STRIP=1
357
9b40a2c3
JB
358%if %{with xulrunner}
359# needed to find mozilla runtime
360ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
361%endif
362
363# Enable crash reporter for Thunderbird application
765a3a27
ER
364%if %{with crashreporter}
365%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
366
367# Add debuginfo for crash-stats.mozilla.com
51a3b6db 368install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
369cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
370%endif
371
ecf04393
ER
372# copy manually lightning files, somewhy they are not installed by make
373cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
374 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
375 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
376
44be9ed4 377# move arch independant ones to datadir
378mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
379mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 380mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 381mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
eca54e0f 382mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 383ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
384ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 385ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 386ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
eca54e0f 387ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
73d54cb2
JB
388%if %{without xulrunner}
389mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
390ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
391%endif
44be9ed4 392
c6ec3c1c
ER
393# dir for arch independant extensions besides arch dependant extensions
394# see mozilla/xpcom/build/nsXULAppAPI.h
395# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
396install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
397
73d54cb2 398%if %{without xulrunner}
63d8f5c3 399%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 400ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
e6bc19b3
ER
401%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
402ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
73d54cb2 403%endif
e6bc19b3 404
0889474f
JR
405%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
406 -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
407 %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
408
44be9ed4 409%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
410ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
411ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
412
52f5507d
ER
413cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
414cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 415
e8f4ba81 416# files created by regxpcom -register in post
52fc61e6
ER
417touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
418touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
419cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
420#!/bin/sh
421umask 022
422# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
423# dangerous if you run this with sudo with keep_env += HOME
424# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
425t=$(mktemp -d)
d50a2a28 426%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
427TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
428rm -rf $t
429EOF
430chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 431
44be9ed4 432%if %{with enigmail}
283702b9 433ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
916d4050 434install -d $ext_dir/{chrome,components,defaults/preferences,modules}
52fc61e6 435cd mozilla/dist/bin
916d4050 436cp -rfLp chrome/enigmail.jar $ext_dir/chrome
52fc61e6
ER
437cp -rfLp components/enig* $ext_dir/components
438cp -rfLp components/libenigmime.so $ext_dir/components
52fc61e6 439cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
de09c00d 440cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
916d4050 441cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
52fc61e6 442cd -
52f5507d
ER
443cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
444cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 445%endif
446
9cdc8923
ER
447# never package these. always remove
448# nss
449%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
450# nspr
451%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 452# mozldap
9cdc8923 453%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
3815090b
ER
454# testpilot quiz
455%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
283702b9 456
44be9ed4 457%clean
458rm -rf $RPM_BUILD_ROOT
459
460%pretrans
461if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
462 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
463fi
eca54e0f 464for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 465 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
466 install -d %{_datadir}/%{name}
467 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
468 fi
469done
470exit 0
471
e8f4ba81
ER
472%post
473%{_libdir}/%{name}/register || :
474
44be9ed4 475%files
476%defattr(644,root,root,755)
477%attr(755,root,root) %{_bindir}/icedove
478%attr(755,root,root) %{_bindir}/mozilla-thunderbird
479%attr(755,root,root) %{_bindir}/thunderbird
480%dir %{_libdir}/%{name}
765a3a27 481%{_libdir}/%{name}/application.ini
6b327de6
JB
482%{_libdir}/%{name}/blocklist.xml
483%{_libdir}/%{name}/chrome.manifest
44be9ed4 484%dir %{_libdir}/%{name}/components
44be9ed4 485%{_libdir}/%{name}/components/*.js
486%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
487%{_libdir}/%{name}/components/components.manifest
488%{_libdir}/%{name}/components/interfaces.manifest
73d54cb2
JB
489%attr(755,root,root) %{_libdir}/%{name}/*.sh
490%attr(755,root,root) %{_libdir}/%{name}/*-bin
491%attr(755,root,root) %{_libdir}/%{name}/icedove
492%attr(755,root,root) %{_libdir}/%{name}/register
493%if %{without xulrunner}
494%{_libdir}/%{name}/platform.ini
495%{_libdir}/%{name}/greprefs.js
496%attr(755,root,root) %{_libdir}/%{name}/components/*.so
0516fc42 497%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 498%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 499%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 500%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
cf62736e 501%attr(755,root,root) %{_libdir}/%{name}/plugin-container
73d54cb2 502%endif
44be9ed4 503
504# symlinks
505%{_libdir}/%{name}/chrome
506%{_libdir}/%{name}/defaults
44be9ed4 507%{_libdir}/%{name}/isp
9e097178 508%{_libdir}/%{name}/modules
eca54e0f 509%{_libdir}/%{name}/searchplugins
9b40a2c3
JB
510%if %{with xulrunner}
511%{_libdir}/%{name}/xulrunner
512%else
73d54cb2
JB
513%{_libdir}/%{name}/dictionaries
514%{_libdir}/%{name}/hyphenation
515%{_libdir}/%{name}/res
516%endif
44be9ed4 517
224cf96a
JB
518%{_pixmapsdir}/icedove.png
519%{_desktopdir}/icedove.desktop
44be9ed4 520
521%dir %{_datadir}/%{name}
522%{_datadir}/%{name}/chrome
523%{_datadir}/%{name}/defaults
eca54e0f 524%{_datadir}/%{name}/extensions
44be9ed4 525%{_datadir}/%{name}/isp
9e097178 526%{_datadir}/%{name}/modules
916d4050
JR
527%if %{with enigmail}
528%exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
529%exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
530%exclude %{_datadir}/%{name}/modules/keyManagement.jsm
531%exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
916d4050
JR
532%exclude %{_datadir}/%{name}/modules/subprocess.jsm
533%exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
534%exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
535%endif
eca54e0f 536%{_datadir}/%{name}/searchplugins
73d54cb2
JB
537%if %{without xulrunner}
538%{_datadir}/%{name}/res
539%endif
44be9ed4 540
765a3a27
ER
541%if %{with crashreporter}
542%attr(755,root,root) %{_libdir}/%{name}/crashreporter
543%{_libdir}/%{name}/crashreporter.ini
544%{_libdir}/%{name}/Throbber-small.gif
545%endif
546
44be9ed4 547%dir %{_libdir}/%{name}/extensions
548%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 549
52fc61e6
ER
550# files created by regxpcom -register
551%ghost %{_libdir}/%{name}/components/compreg.dat
552%ghost %{_libdir}/%{name}/components/xpti.dat
553
6578c165 554%if %{with lightning}
555%files addon-lightning
556%defattr(644,root,root,755)
f3b6d696 557%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 558%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
559%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
560%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 561%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
562%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
563%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
564%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 565%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
566%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
567%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
568%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
569%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
570%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 571%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
572%endif
44be9ed4 573
574%if %{with enigmail}
575%files addon-enigmail
576%defattr(644,root,root,755)
f6a43e2f
ER
577%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
578%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
579%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
580%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
581%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
582%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
583%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
584%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
585%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
916d4050
JR
586%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
587%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
588%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
44be9ed4 589%endif
This page took 0.226783 seconds and 4 git commands to generate.