]> git.pld-linux.org Git - packages/icedove.git/blame - icedove.spec
- added missing release 1.1 to changelog
[packages/icedove.git] / icedove.spec
CommitLineData
44be9ed4 1# TODO:
2# - CHECK all features of enigmail
3# - separate spec for enigmail
4#
5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
8%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
9%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
10%bcond_without ldap # disable e-mail address lookups in LDAP directories
11#
12%if %{without gnome}
13%undefine with_gnomeui
14%undefine with_gnomevfs
15%endif
16%define enigmail_ver 0.95.6
17%define thunderbird_ver 2.0.0.14
18
19Summary: Icedove - email client
20Summary(pl.UTF-8): Icedove - klient poczty
21Name: icedove
22Version: %{thunderbird_ver}
23Release: 1
24License: MPL 1.1 or GPL v2+ or LGPL v2.1+
25Group: Applications/Networking
26Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}-source.tar.bz2
27# Source0-md5: e304510d08f7e226bbfff8e7e549232f
28Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
29# Source1-md5: cfbe6ff77f80a349b396829757ad952a
30Source2: %{name}-branding.tar.bz2
31# Source2-md5: e775b8cb658de32f30b403bc9b7950bf
32Source3: %{name}-rm_nonfree.sh
33Source4: %{name}.desktop
34Source5: %{name}.sh
35Source6: %{name}-enigmail.manifest
36Patch0: %{name}-branding.patch
37Patch1: %{name}-lib_path.patch
38Patch2: %{name}-enigmail-shared.patch
39Patch3: %{name}-gcc.patch
40Patch4: %{name}-fonts.patch
41Patch5: %{name}-install.patch
42Patch6: %{name}-myspell.patch
43Patch7: %{name}-regionNames.patch
44URL: http://www.mozilla.org/projects/thunderbird/
45%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
46BuildRequires: automake
47BuildRequires: freetype-devel >= 1:2.1.8
48%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
49BuildRequires: gtk+2-devel >= 1:2.0.0
50BuildRequires: libIDL-devel >= 0.8.0
51%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
52%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
53BuildRequires: libjpeg-devel >= 6b
54BuildRequires: libpng-devel >= 1.2.0
55BuildRequires: libstdc++-devel
56BuildRequires: myspell-devel
57BuildRequires: nspr-devel >= 1:4.6.1
58BuildRequires: nss-devel >= 1:3.11.3
59BuildRequires: pango-devel >= 1:1.1.0
60BuildRequires: sed >= 4.0
61BuildRequires: xorg-lib-libXext-devel
62BuildRequires: xorg-lib-libXft-devel >= 2.1
63BuildRequires: xorg-lib-libXinerama-devel
64BuildRequires: xorg-lib-libXp-devel
65BuildRequires: xorg-lib-libXt-devel
66Requires: myspell-common
67Requires: nspr >= 1:4.6.1
68Requires: nss >= 1:3.11.3
69Obsoletes: mozilla-thunderbird
70Obsoletes: mozilla-thunderbird-dictionary-en-US
71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73# iceweasel/icedove/iceape provide their own versions
74%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
75%define _noautoprovfiles %{_libdir}/%{name}/components
76# we don't want these to satisfy xulrunner-devel
77%define _noautoprov libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
78# and as we don't provide them, don't require either
79%define _noautoreq libgtkembedmoz.so libldap50.so libmozjs.so libprldap50.so libssldap50.so libxpcom.so libxul.so
80
81%description
82Icedove is an open-source,fast and portable email client.
83
84%description -l pl.UTF-8
85Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
86
87%package addon-enigmail
88Summary: Extension for the authentication and encryption features provided by GnuPG
89Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
90License: MPL/LGPL
91Group: Applications/Networking
92URL: http://enigmail.mozdev.org/
93Requires: %{name} = %{thunderbird_ver}-%{release}
94
95%description addon-enigmail
c5e06599 96Enigmail is an extension to the Icedove mail client which allows users
97to access the authentication and encryption features provided by
98GnuPG.
44be9ed4 99
100Main Features:
101- Encrypt/sign mail when sending, decrypt/authenticate received mail
102- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
103- Per-Account based encryption and signing defaults
104- Per-Recipient rules for automated key selection, and
105 enabling/disabling encryption and signing
106- OpenPGP key management interface
107
108%description addon-enigmail -l pl.UTF-8
c5e06599 109Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
110użytkownikom na dostęp do uwierzytelniania i szyfrowania
44be9ed4 111zapewnianego przez GnuPG.
112
113Główne możliwości:
114- szyfrowanie/podpisywanie poczty przy wysyłaniu,
115 odszyfrowywanie/uwierzytelnianie poczty odebranej
116- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
117- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
118- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
119 podpisywania dla każdego adresata
120- interfejs do zarządzania kluczami OpenPGP
121
122%prep
123%setup -q -c
124tar xvfj %{SOURCE2}
125cd mozilla
126%{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
127/bin/sh %{SOURCE3}
128%patch0 -p1
129%patch1 -p1
130%{?with_enigmail:%patch2 -p1}
131%patch3 -p1
132%patch4 -p1
133%patch5 -p1
134%patch6 -p1
135%patch7 -p1
136
137:> config/gcc_hidden.h
138
139%build
140cd mozilla
141export CFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
142export CXXFLAGS="%{rpmcflags} `%{_bindir}/pkg-config mozilla-nspr --cflags-only-I`"
143
144cp -f %{_datadir}/automake/config.* build/autoconf
145cp -f %{_datadir}/automake/config.* nsprpub/build/autoconf
146cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
147
148cat << 'EOF' > .mozconfig
149. $topsrcdir/mail/config/mozconfig
150
151ac_add_options --prefix=%{_prefix}
152ac_add_options --exec-prefix=%{_exec_prefix}
153ac_add_options --bindir=%{_bindir}
154ac_add_options --sbindir=%{_sbindir}
155ac_add_options --sysconfdir=%{_sysconfdir}
156ac_add_options --datadir=%{_datadir}
157ac_add_options --includedir=%{_includedir}
158ac_add_options --libdir=%{_libdir}
159ac_add_options --libexecdir=%{_libexecdir}
160ac_add_options --localstatedir=%{_localstatedir}
161ac_add_options --sharedstatedir=%{_sharedstatedir}
162ac_add_options --mandir=%{_mandir}
163ac_add_options --infodir=%{_infodir}
164%if %{?debug:1}0
165ac_add_options --enable-debug
166ac_add_options --enable-debug-modules
167%else
168ac_add_options --disable-debug
169ac_add_options --disable-debug-modules
170%endif
171%if %{with tests}
172ac_add_options --enable-tests
173%else
174ac_add_options --disable-tests
175%endif
176%if %{with gnomeui}
177ac_add_options --enable-gnomeui
178%else
179ac_add_options --disable-gnomeui
180%endif
181%if %{with gnomevfs}
182ac_add_options --enable-gnomevfs
183%else
184ac_add_options --disable-gnomevfs
185%endif
186%if %{with ldap}
187ac_add_options --enable-ldap
188%else
189ac_add_options --disable-ldap
190%endif
191ac_add_options --disable-installer
192ac_add_options --disable-jsd
193ac_add_options --disable-xprint
194ac_add_options --enable-canvas
195ac_add_options --enable-crypto
196ac_add_options --enable-default-toolkit="gtk2"
197ac_add_options --enable-extensions="pref,cookie,wallet,spellcheck"
198ac_add_options --enable-mathml
199ac_add_options --enable-optimize="%{rpmcflags}"
200ac_add_options --enable-pango
201ac_add_options --enable-reorder
202ac_add_options --disable-strip
203ac_add_options --disable-strip-libs
204ac_add_options --enable-system-cairo
205ac_add_options --enable-system-myspell
206ac_add_options --enable-svg
207ac_add_options --enable-xft
208ac_add_options --enable-xinerama
209ac_add_options --with-system-jpeg
210ac_add_options --with-system-nspr
211ac_add_options --with-system-nss
212ac_add_options --with-system-png
213ac_add_options --with-system-zlib
214ac_add_options --with-pthreads
215ac_add_options --enable-single-profile
216ac_add_options --disable-profilesharing
217ac_add_options --with-branding=icedove/branding
218ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
219EOF
220
221%{__make} -j1 -f client.mk build_all \
222 CC="%{__cc}" \
223 CXX="%{__cxx}"
224
225%if %{with enigmail}
226 cd mailnews/extensions/enigmail
227 ./makemake -r
228 %{__make}
229%endif
230
231%install
232rm -rf $RPM_BUILD_ROOT
233install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}} \
234 $RPM_BUILD_ROOT%{_datadir}/%{name}
235
236cd mozilla
237%{__make} -C xpinstall/packager stage-package \
238 DESTDIR=$RPM_BUILD_ROOT \
239 MOZ_PKG_APPDIR=%{_libdir}/%{name} \
240 PKG_SKIP_STRIP=1
241
242# move arch independant ones to datadir
243mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
244mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
245mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
246mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
247mv $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d $RPM_BUILD_ROOT%{_datadir}/%{name}/init.d
248mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
249mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
250ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
251ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
252ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
253ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
254ln -s ../../share/%{name}/init.d $RPM_BUILD_ROOT%{_libdir}/%{name}/init.d
255ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
256ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
257
258rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
259ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
260
261%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
262ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
263ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
264
265install %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
266
267%if %{with enigmail}
268_enig_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
269install -d $_enig_dir/chrome
270install -d $_enig_dir/components
271install -d $_enig_dir/defaults/preferences
272mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail.jar $_enig_dir/chrome
273mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin-tbird.jar $_enig_dir/chrome
274mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig* $_enig_dir/components
275mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so $_enig_dir/components
276mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt $_enig_dir/components
277mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences/enigmail.js $_enig_dir/defaults/preferences
278cp -f mailnews/extensions/enigmail/package/install.rdf $_enig_dir
279rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults/preferences
280rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-en-US.jar
281rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmail-skin.jar
282rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome/enigmime.jar
283rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/components/enig*
284rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/libenigmime.so
285rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/ipc.xpt
286cp -f %{SOURCE6} $_enig_dir/chrome.manifest
287cp -f icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/icedove.png
288%endif
289
290# win32 stuff
291rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/dirver
292
293%clean
294rm -rf $RPM_BUILD_ROOT
295
296%pretrans
297if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
298 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
299fi
300for d in chrome defaults greprefs icons init.d isp res; do
301 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
302 install -d %{_datadir}/%{name}
303 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
304 fi
305done
306exit 0
307
308%files
309%defattr(644,root,root,755)
310%attr(755,root,root) %{_bindir}/icedove
311%attr(755,root,root) %{_bindir}/mozilla-thunderbird
312%attr(755,root,root) %{_bindir}/thunderbird
313%dir %{_libdir}/%{name}
314%dir %{_libdir}/%{name}/components
315%attr(755,root,root) %{_libdir}/%{name}/components/*.so
316%{_libdir}/%{name}/components/*.js
317%{_libdir}/%{name}/components/*.xpt
318%attr(755,root,root) %{_libdir}/%{name}/*.so
319%attr(755,root,root) %{_libdir}/%{name}/*.sh
320%attr(755,root,root) %{_libdir}/%{name}/*-bin
321%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
322%attr(755,root,root) %{_libdir}/%{name}/reg*
323%attr(755,root,root) %{_libdir}/%{name}/icedove
324%{_libdir}/%{name}/*.txt
325%attr(755,root,root) %{_libdir}/%{name}/x*
326
327# symlinks
328%{_libdir}/%{name}/chrome
329%{_libdir}/%{name}/defaults
330%{_libdir}/%{name}/dictionaries
331%{_libdir}/%{name}/greprefs
332%{_libdir}/%{name}/icons
333%{_libdir}/%{name}/init.d
334%{_libdir}/%{name}/isp
335%{_libdir}/%{name}/res
336
337%{_libdir}/%{name}/dependentlibs.list
338%{_libdir}/%{name}/updater
339%{_libdir}/%{name}/updater.ini
340%{_pixmapsdir}/*.png
341%{_desktopdir}/*.desktop
342
343%dir %{_datadir}/%{name}
344%{_datadir}/%{name}/chrome
345%{_datadir}/%{name}/defaults
346%{_datadir}/%{name}/greprefs
347%{_datadir}/%{name}/icons
348%{_datadir}/%{name}/init.d
349%{_datadir}/%{name}/isp
350%{_datadir}/%{name}/res
351
352%dir %{_libdir}/%{name}/extensions
353%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
354
355%if %{with enigmail}
356%files addon-enigmail
357%defattr(644,root,root,755)
358%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
359%endif
This page took 0.106341 seconds and 4 git commands to generate.