]> git.pld-linux.org Git - packages/gtkmm3.git/blame - gtkmm3.spec
- up to 3.2.0
[packages/gtkmm3.git] / gtkmm3.spec
CommitLineData
33bee831
AF
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4#
e34bbb24 5%define glibmm_ver 2.30.0
33bee831
AF
6Summary: A C++ interface for the GTK+ (a GUI library for X)
7Summary(pl.UTF-8): Wrapper C++ dla GTK+
8Name: gtkmm3
e34bbb24 9Version: 3.2.0
33bee831
AF
10Release: 1
11License: LGPL v2+
12Group: X11/Libraries
e34bbb24
AF
13Source0: http://ftp.gnome.org/pub/GNOME/sources/gtkmm/3.2/gtkmm-%{version}.tar.xz
14# Source0-md5: 4d68a8c59efd9727f5d7c9d0d7aaacca
33bee831 15URL: http://www.gtkmm.org/
31a8d119 16BuildRequires: atkmm-devel >= 2.22.2
33bee831 17BuildRequires: autoconf >= 2.59
31a8d119 18BuildRequires: automake >= 1:1.11
33bee831 19BuildRequires: cairomm-devel >= 1.9.2
4b35a8ba 20BuildRequires: gdk-pixbuf2-devel >= 2.22.1
e34bbb24
AF
21BuildRequires: glibmm-devel >= %{glibmm_ver}
22BuildRequires: gtk+3-devel >= 3.2.0
33bee831
AF
23BuildRequires: libsigc++-devel
24BuildRequires: libstdc++-devel >= 5:3.3.1
25BuildRequires: libtool >= 2:1.4d-3
31a8d119
AF
26BuildRequires: mm-common >= 0.9.3
27BuildRequires: pangomm-devel >= 2.28.0
33bee831
AF
28BuildRequires: perl-base >= 1:5.6.0
29BuildRequires: pkgconfig
31a8d119 30Requires: atkmm >= 2.22.2
33bee831 31Requires: cairomm >= 1.9.2
e34bbb24 32Requires: glibmm >= %{glibmm_ver}
31a8d119 33Requires: pangomm >= 2.28.0
33bee831
AF
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
38library. The interface provides a convenient interface for C++
39programmers to create GUIs with GTK+'s flexible object-oriented
40framework. Features include type safe callbacks, widgets that are
41extensible using inheritance and over 110 classes that can be freely
42combined to quickly create complex user interfaces.
43
44%description -l pl.UTF-8
45gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
46służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
47także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
48
49%package devel
50Summary: gtkmm and gdkmm header files
51Summary(pl.UTF-8): Pliki nagłówkowe gtkmm i gdkmm
52Group: X11/Development/Libraries
53Requires: %{name} = %{version}-%{release}
31a8d119 54Requires: atkmm-devel >= 2.22.2
e34bbb24
AF
55Requires: glibmm-devel >= %{glibmm_ver}
56Requires: gtk+3-devel >= 3.2.0
31a8d119 57Requires: pangomm-devel >= 2.28.0
33bee831
AF
58
59%description devel
60Header files for gtkmm library.
61
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki gtkmm.
64
65%package static
66Summary: gtkmm and gdkmm static libraries
67Summary(pl.UTF-8): Biblioteki statyczne gtkmm i gdkmm
68Group: X11/Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72gtkmm and gdkmm static libraries.
73
74%description static -l pl.UTF-8
75Biblioteki statyczne gtkmm i gdkmm.
76
77%package apidocs
78Summary: Reference documentation for gtkmm and gdkmm
79Summary(pl.UTF-8): Szczegółowa dokumentacja gtkmm i gdkmm
80Group: Documentation
81Requires: devhelp
82
83%description apidocs
84Reference documentation for gtkmm and gdkmm.
85
86%description apidocs -l pl.UTF-8
87Szczegółowa dokumentacja gtkmm i gdkmm.
88
89%prep
90%setup -q -n gtkmm-%{version}
91
92%build
93%{__libtoolize}
94%{__aclocal} -I build
95%{__autoconf}
96%{__autoheader}
97%{__automake}
98%configure \
99 %{?with_static_libs:--enable-static}
100
101%{__make}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%{__make} install \
107 DESTDIR=$RPM_BUILD_ROOT
108
109%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(644,root,root,755)
119%doc AUTHORS ChangeLog NEWS PORTING README
120%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
122%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
123%attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
124
125%files devel
126%defattr(644,root,root,755)
127%attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
128%attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
129%{_libdir}/gdkmm-3.0
130%{_libdir}/gtkmm-3.0
131%{_includedir}/gdkmm-3.0
132%{_includedir}/gtkmm-3.0
133%{_pkgconfigdir}/gdkmm-3.0.pc
134%{_pkgconfigdir}/gtkmm-3.0.pc
135
136%if %{with static_libs}
137%files static
138%defattr(644,root,root,755)
139%{_libdir}/libgdkmm-3.0.a
140%{_libdir}/libgtkmm-3.0.a
141%endif
142
143%files apidocs
144%defattr(644,root,root,755)
145%{_docdir}/gtkmm-3.0
146%{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.116652 seconds and 4 git commands to generate.