]> git.pld-linux.org Git - packages/gtk-webkit4.git/blame - gtk-webkit4.spec
- updated options and webkit bcond logic
[packages/gtk-webkit4.git] / gtk-webkit4.spec
CommitLineData
91c1decc 1# TODO: review configure options:
e761a49a 2# - BATTERY_STATUS (BR: upower-devel)
5e4ace1a 3# - FTL_JIT on !x86_64?
9a76c25d 4# - MEDIA_STREAM (BR: openwebrtc)
f8e56294
AF
5#
6# Conditional build:
816ef86e 7%bcond_without gtk2 # WebKitPluginProcess2 to load GTK+ 2.x based plugins
f8e56294 8%bcond_without introspection # disable introspection
5e4ace1a 9%bcond_with cairogl # accelerated 2D canvas using cairo-gl
e761a49a 10%bcond_with seccomp # seccomp filters (broken as of 2.6.5)
5e4ace1a 11%bcond_without wayland # Wayland target (requires GTK+ wayland target)
f8e56294 12#
4bb10dff
JR
13# it's not possible to build this with debuginfo on 32bit archs due to
14# memory constraints during linking
15%ifarch %{ix86} x32
16%define _enable_debug_packages 0
17%endif
97c9d259
JB
18Summary: Port of WebKit embeddable web component to GTK+ 3
19Summary(pl.UTF-8): Port osadzalnego komponentu WWW WebKit do GTK+ 3
e761a49a 20Name: gtk-webkit4
6514e20b
JB
21Version: 2.12.2
22Release: 1
f8e56294
AF
23License: BSD-like
24Group: X11/Libraries
9130be70 25Source0: http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
6514e20b 26# Source0-md5: 41e018d651413fdbcd4b6480ab1fbd7b
72628bc4 27Patch0: x32.patch
f8e56294 28URL: http://webkitgtk.org/
8f69f015 29BuildRequires: /usr/bin/ld.gold
e3d059d0
JB
30BuildRequires: EGL-devel
31BuildRequires: OpenGL-GLX-devel
0df10670 32BuildRequires: OpenGLESv2-devel
bbd2fab2 33BuildRequires: at-spi2-core-devel >= 2.6.0
e761a49a
JB
34BuildRequires: atk-devel
35BuildRequires: bison >= 2.3
36BuildRequires: cairo-devel >= 1.10.2
9a76c25d 37BuildRequires: cmake >= 2.8.12
0df10670 38BuildRequires: docbook-dtd412-xml
f8e56294 39BuildRequires: enchant-devel >= 0.22
e761a49a
JB
40BuildRequires: flex >= 2.5.34
41BuildRequires: fontconfig-devel >= 2.8.0
42BuildRequires: freetype-devel >= 1:2.4.2
9a76c25d 43BuildRequires: gcc-c++ >= 6:4.9
b19bf66f 44BuildRequires: geoclue2-devel >= 2.1.5
e761a49a 45BuildRequires: gettext-devel
bbd2fab2 46BuildRequires: glib2-devel >= 1:2.36.0
f8e56294 47BuildRequires: glibc-misc
bbd2fab2 48%{?with_introspection:BuildRequires: gobject-introspection-devel >= 1.32.0}
e761a49a 49BuildRequires: gperf >= 3.0.1
bbd2fab2 50BuildRequires: gstreamer-devel >= 1.0.3
0df10670 51BuildRequires: gstreamer-plugins-bad-devel >= 1.6.0
bbd2fab2 52BuildRequires: gstreamer-plugins-base-devel >= 1.0.3
816ef86e 53%{?with_gtk2:BuildRequires: gtk+2-devel >= 2:2.24.10}
e761a49a 54BuildRequires: gtk+3-devel >= 3.12.0
f8e56294 55BuildRequires: gtk-doc >= 1.10
bbd2fab2 56BuildRequires: harfbuzz-devel >= 0.9.7
333087b6 57BuildRequires: harfbuzz-icu-devel >= 0.9.7
9a76c25d 58BuildRequires: hyphen-devel
f8e56294
AF
59BuildRequires: libicu-devel >= 4.2.1
60BuildRequires: libjpeg-devel
ad56e591 61BuildRequires: libnotify-devel
f8e56294 62BuildRequires: libpng-devel
bbd2fab2
MB
63BuildRequires: libsecret-devel
64BuildRequires: libsoup-devel >= 2.42.0
9a76c25d 65BuildRequires: libstdc++-devel >= 6:4.9
bbd2fab2 66BuildRequires: libwebp-devel
e761a49a 67BuildRequires: libxml2-devel >= 1:2.8.0
f8e56294 68BuildRequires: libxslt-devel >= 1.1.7
bbd2fab2 69BuildRequires: pango-devel >= 1:1.32.0
e761a49a 70BuildRequires: perl-base >= 1:5.10.0
f8e56294 71BuildRequires: pkgconfig
5e4ace1a
JB
72%if %{with cairogl}
73BuildRequires: pkgconfig(cairo-egl)
74BuildRequires: pkgconfig(cairo-gl)
75BuildRequires: pkgconfig(cairo-glx)
76%endif
ad56e591 77BuildRequires: python >= 1:2.7.0
01e3a259 78BuildRequires: rpmbuild(macros) >= 1.699
0df10670
ER
79BuildRequires: ruby >= 1:1.9
80BuildRequires: ruby-modules >= 1:1.9
333087b6 81BuildRequires: sqlite3-devel >= 3
09aa776b 82BuildRequires: tar >= 1:1.22
e9e9ae8f 83BuildRequires: xorg-lib-libXcomposite-devel
e3d059d0 84BuildRequires: xorg-lib-libXdamage-devel
cf9395dc 85BuildRequires: xorg-lib-libXrender-devel
09ca9f01 86BuildRequires: xorg-lib-libXt-devel
09aa776b 87BuildRequires: xz
09ca9f01 88BuildRequires: zlib-devel
e761a49a 89Requires: cairo >= 1.10.2
f8e56294 90Requires: enchant >= 0.22
e761a49a
JB
91Requires: fontconfig-libs >= 2.8.0
92Requires: freetype >= 1:2.4.2
bbd2fab2
MB
93Requires: glib2 >= 1:2.36.0
94Requires: gstreamer >= 1.0.3
95Requires: gstreamer-plugins-base >= 1.0.3
816ef86e 96%{?with_gtk2:Requires: gtk+2 >= 2:2.24.10}
e761a49a 97Requires: gtk+3 >= 3.12.0
e3d059d0 98Requires: harfbuzz >= 0.9.7
bbd2fab2 99Requires: libsoup >= 2.42.0
e761a49a 100Requires: libxml2 >= 1:2.8.0
f8e56294 101Requires: libxslt >= 1.1.7
bbd2fab2 102Requires: pango >= 1:1.32.0
f8e56294 103%{?with_introspection:Conflicts: gir-repository < 0.6.5-7}
5e4ace1a
JB
104# Source/JavaScriptCore/CMakeLists.txt /WTF_CPU_
105ExclusiveArch: %{ix86} %{x8664} x32 arm aarch64 hppa mips ppc ppc64 s390 s390x sh4
f8e56294
AF
106BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
b19bf66f 108# __once_call, __once_called non-function symbols from libstdc++
3e7920f5 109%define skip_post_check_so lib.*gtk-4.0.*
b19bf66f 110
f8e56294 111%description
3e7920f5 112gtk-webkit4 is a port of the WebKit embeddable web component to GTK+
b19bf66f 1133.
f8e56294
AF
114
115%description -l pl.UTF-8
3e7920f5 116gtk-webkit4 to port osadzalnego komponentu WWW WebKit do GTK+ 3.
f8e56294
AF
117
118%package devel
97c9d259
JB
119Summary: Development files for WebKit for GTK+ 3
120Summary(pl.UTF-8): Pliki programistyczne komponentu WebKit dla GTK+ 3
f8e56294
AF
121Group: X11/Development/Libraries
122Requires: %{name} = %{version}-%{release}
bbd2fab2 123Requires: glib2-devel >= 1:2.36.0
e761a49a 124Requires: gtk+3-devel >= 3.12.0
bbd2fab2 125Requires: libsoup-devel >= 2.42.0
9a76c25d 126Requires: libstdc++-devel >= 6:4.9
f8e56294
AF
127
128%description devel
97c9d259 129Development files for WebKit for GTK+ 3.
f8e56294
AF
130
131%description devel -l pl.UTF-8
97c9d259 132Pliki programistyczne komponentu WebKit dla GTK+ 3.
f8e56294 133
09ca9f01
MB
134%package apidocs
135Summary: WebKit API documentation
136Summary(pl.UTF-8): Dokumentacja API WebKita
137Group: Documentation
138Requires: gtk-doc-common
8f69f015
ER
139%if "%{_rpmversion}" >= "5"
140BuildArch: noarch
141%endif
09ca9f01
MB
142
143%description apidocs
144WebKit API documentation.
145
146%description apidocs -l pl.UTF-8
147Dokumentacja API WebKita.
148
f8e56294 149%prep
9130be70 150%setup -q -n webkitgtk-%{version}
72628bc4 151%patch0 -p1
97c9d259 152
f8e56294 153%build
e761a49a
JB
154install -d build
155cd build
156%cmake .. \
5e4ace1a 157 %{?with_cairogl:-DENABLE_ACCELERATED_2D_CANVAS=ON} \
e761a49a
JB
158 -DENABLE_CREDENTIAL_STORAGE=ON \
159 -DENABLE_GEOLOCATION=ON \
160 -DENABLE_GTKDOC=ON \
816ef86e
JB
161 %{!?with_introspection:-DENABLE_INTROSPECTION=OFF} \
162 %{!?with_gtk2:-DENABLE_PLUGIN_PROCESS_GTK2=OFF} \
e761a49a 163 %{?with_seccomp:-DENABLE_SECCOMP_FILTERS=ON} \
5e4ace1a 164 %{!?with_wayland:-DENABLE_WAYLAND_TARGET=OFF} \
72628bc4
JR
165%ifarch x32
166 -DENABLE_JIT=OFF \
167%endif
e761a49a
JB
168 -DENABLE_VIDEO=ON \
169 -DENABLE_WEB_AUDIO=ON \
170 -DENABLE_WEBGL=ON \
171 -DPORT=GTK \
172 -DSHOULD_INSTALL_JS_SHELL=ON
173
e761a49a 174%{__make}
f8e56294
AF
175
176%install
177rm -rf $RPM_BUILD_ROOT
178
e761a49a 179%{__make} -C build install \
f8e56294
AF
180 DESTDIR=$RPM_BUILD_ROOT
181
3e7920f5
JB
182%if "%{_gtkdocdir}" != "%{_datadir}/gtk-doc/html"
183install -d $RPM_BUILD_ROOT%{_gtkdocdir}
184%{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
185%endif
186
187%find_lang WebKit2GTK-4.0
f8e56294
AF
188
189%clean
190rm -rf $RPM_BUILD_ROOT
191
09aa776b
JB
192%post -p /sbin/ldconfig
193%postun -p /sbin/ldconfig
f8e56294 194
3e7920f5 195%files -f WebKit2GTK-4.0.lang
f8e56294 196%defattr(644,root,root,755)
e761a49a
JB
197%doc NEWS
198%attr(755,root,root) %{_bindir}/jsc
199%attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so.*.*.*
200%attr(755,root,root) %ghost %{_libdir}/libwebkit2gtk-4.0.so.37
201%attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so.*.*.*
202%attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-4.0.so.18
f8e56294 203%if %{with introspection}
e761a49a
JB
204%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
205%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
206%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
f8e56294 207%endif
e761a49a 208%dir %{_libdir}/webkit2gtk-4.0
9a76c25d 209%attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitDatabaseProcess
e761a49a
JB
210%attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitNetworkProcess
211%attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess
212%attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitPluginProcess2
213%attr(755,root,root) %{_libdir}/webkit2gtk-4.0/WebKitWebProcess
214%dir %{_libdir}/webkit2gtk-4.0/injected-bundle
215%attr(755,root,root) %{_libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so
f8e56294
AF
216
217%files devel
218%defattr(644,root,root,755)
e761a49a
JB
219%attr(755,root,root) %{_libdir}/libwebkit2gtk-4.0.so
220%attr(755,root,root) %{_libdir}/libjavascriptcoregtk-4.0.so
f8e56294 221%if %{with introspection}
e761a49a
JB
222%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
223%{_datadir}/gir-1.0/WebKit2-4.0.gir
224%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
f8e56294 225%endif
e761a49a
JB
226%{_includedir}/webkitgtk-4.0
227%{_pkgconfigdir}/javascriptcoregtk-4.0.pc
228%{_pkgconfigdir}/webkit2gtk-4.0.pc
229%{_pkgconfigdir}/webkit2gtk-web-extension-4.0.pc
09ca9f01
MB
230
231%files apidocs
232%defattr(644,root,root,755)
e761a49a
JB
233%{_gtkdocdir}/webkit2gtk-4.0
234%{_gtkdocdir}/webkitdomgtk-4.0
This page took 0.087814 seconds and 4 git commands to generate.