]> git.pld-linux.org Git - packages/grub2.git/blame - grub2.spec
x86_64 build fixes
[packages/grub2.git] / grub2.spec
CommitLineData
f97cafb4 1# TODO
dc6928bc 2# - reap out which in probe scripts and drop R: which
f97cafb4 3# - subpackages? e.g. modules and utils
bcd6a47e 4# - check where is that locale path: /boot/grub/locale and fix it or change it
8fcee4aa
ER
5# - grubemu notes
6# --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7# - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8# - put grub-emu to subpackage if it is fixed
659f8cfc 9# - warning: Installed (but unpackaged) file(s) found:
1536aaf2
JK
10# /sbin/grub-sparc64-setup
11# /usr/share/man/man8/grub-sparc64-setup.8.gz
12
659f8cfc
ER
13# /boot/grub/config.h
14# /etc/bash_completion.d/grub
7615a862
JK
15# /sbin/grub-sparc64-setup
16# /boot/grub/gdb_grub
17# /boot/grub/gmodule.pl
18# /sbin/grub-sparc64-setup
f97cafb4 19#
90feddde 20# Conditional build:
1536aaf2 21%bcond_with grubemu # build grub-emu debugging utility
b06c130d 22%bcond_without efiemu # build efiemu runtimes
1536aaf2
JK
23%bcond_without pc # do not build for PC BIOS platform
24%bcond_without efi # do not build for EFI platform
b06c130d
ER
25
26%if "%{cc_version}" < "3.4"
27# cc does not support:
28# cc1: sorry, unimplemented: code model `large' not supported yet
29%undefine with_efiemu
30%endif
31
2d8da575
AM
32%ifnarch %{x8664}
33# non-x86_64 arch doesn't support this
34%undefine with_efiemu
35%endif
36
1536aaf2
JK
37%ifarch %{ix86}
38%define target_cpu i386
39%endif
40%ifarch %{x8664}
41%define target_cpu x86_64
42%endif
43
44# the 'most natural' platform should go last
45%define platforms %{?with_efi:efi} %{?with_pc:pc}
46
afe8504a 47Summary: GRand Unified Bootloader
c8155f7f 48Summary(de.UTF-8): GRUB2 - ein Bootloader für x86 und ppc
f97cafb4 49Summary(hu.UTF-8): GRUB2 - rendszerbetöltő x86 és ppc gépekhez
c8155f7f
ER
50Summary(pl.UTF-8): GRUB2 - bootloader dla x86 i ppc
51Summary(pt_BR.UTF-8): Gerenciador de inicialização GRUB2
afe8504a 52Name: grub2
7615a862
JK
53Version: 2.00
54Release: 0.1
2e4bec6f 55License: GPL v2
afe8504a 56Group: Base
f951fcbe 57Source0: http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
7615a862 58# Source0-md5: a1043102fbc7bcedbf53e7ee3d17ab91
22909ca1
ER
59Source1: update-grub
60Source2: update-grub.8
b46589aa 61Source3: grub.sysconfig
e2964b87 62Source4: grub-custom.cfg
695ab3a5 63URL: http://www.gnu.org/software/grub/
5028d8c9 64Patch0: pld-initrd.patch
b46589aa 65Patch1: pld-sysconfdir.patch
872700b0 66Patch2: grub-garbage.patch
78785d3a 67Patch3: grub-shelllib.patch
1536aaf2
JK
68Patch4: grub-lvmdevice.patch
69Patch5: pld-mkconfigdir.patch
70Patch6: grub-mkconfig-diagnostics.patch
71Patch7: ppc.patch
72Patch8: %{name}-awk.patch
73Patch9: posix.patch
74Patch10: %{name}-gets.patch
27550907
ER
75BuildRequires: autoconf >= 2.53
76BuildRequires: automake >= 1:1.11.1-1
8b781299 77BuildRequires: bison
06df59fd 78BuildRequires: device-mapper-devel
013b927c 79BuildRequires: freetype-devel
12fd19f5 80BuildRequires: gawk
63e45785 81BuildRequires: gettext-devel
1349ebb8 82BuildRequires: help2man
afe8504a 83BuildRequires: libtool
81a7e0ba 84BuildRequires: texinfo
c668211a
ER
85%ifarch %{x8664}
86BuildRequires: /usr/lib/libc.so
8905dae4
ER
87%if "%{pld_release}" == "ac"
88BuildRequires: libgcc32
89%else
797addca 90BuildRequires: gcc-multilib
c668211a 91%endif
dee0d6f5 92%endif
6b675158 93BuildRequires: glibc-static
565fe2e3 94BuildRequires: ncurses-devel
8905dae4 95BuildRequires: rpm >= 4.4.9-56
403e7b01 96BuildRequires: rpmbuild(macros) >= 1.213
565fe2e3 97BuildRequires: sed >= 4.0
dc6928bc 98Requires: which
190cc685 99Suggests: cdrkit-mkisofs
97ee543c 100Suggests: os-prober
afe8504a 101Provides: bootloader
fc835b5e 102Conflicts: grub
1536aaf2
JK
103Suggests: %{name}-pc
104Suggests: %{name}-efi
58a823d7 105ExclusiveArch: %{ix86} %{x8664} ppc sparc64
afe8504a
SP
106BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108%define _sbindir /sbin
4a00f3b7 109%define _bindir %{_sbindir}
1536aaf2 110%define _libdir /lib
26e757db 111%define _libexecdir %{_libdir}/grub
1536aaf2 112%define _grubdir /boot/grub
9d44d75e 113
0e2cbb94
JK
114# part of grub code is not relocable (these are not Linux libs)
115# stack protector also breaks non-Linux binaries
116%define filterout_c -fPIC -fstack-protector
117
afe8504a
SP
118%description
119GRUB is a GPLed bootloader intended to unify bootloading across x86
120operating systems. In addition to loading the Linux and *BSD kernels,
121it implements the Multiboot standard, which allows for flexible
122loading of multiple boot images (needed for modular kernels such as
123the GNU Hurd).
124
211df1ed
ER
125GRUB 2 is derived from PUPA which was a research project to
126investigate the next generation of GRUB. GRUB 2 has been rewritten
127from scratch to clean up everything for modularity and portability.
128
129GRUB 2 targets at the following goals:
130- Scripting support, such as conditionals, loops, variables and
131 functions.
132- Graphical interface.
133- Dynamic loading of modules in order to extend itself at the run time
134 rather than at the build time.
135- Portability for various architectures.
136- Internationalization. This includes support for non-ASCII character
137 code, message catalogs like gettext, fonts, graphics console, and so
138 on.
139- Real memory management, to make GNU GRUB more extensible.
140- Modular, hierarchical, object-oriented framework for file systems,
141 files, devices, drives, terminals, commands, partition tables and OS
142 loaders.
143- Cross-platform installation which allows for installing GRUB from a
144 different architecture.
145- Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
146- Fix design mistakes in GRUB Legacy, which could not be solved for
147 backward-compatibility, such as the way of numbering partitions.
148
6b0aefbf 149%description -l de.UTF-8
afe8504a
SP
150GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
151Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
6b0aefbf 152läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
afe8504a
SP
153
154GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
6b0aefbf
JR
155und wird unter der GPL vertrieben. Aufgrund seiner höheren
156Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
afe8504a
SP
157traditionellen Boot-Loader LILO.
158
f97cafb4
ZU
159%description -l hu.UTF-8
160GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
161betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
162teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
163GNU Hurd).
164
165GRUB2 céljai a következők:
166- szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
167 függvények.
168- grafikus felület
169- modulok dinamikus betöltése futási időben
170- hordozhatóság több architektúrára
171- többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
172 mint gettext, betűtípusok, grafikus konzolon, és így tovább
173- valós memória kezelés, amellyel még bővíthetőbbé tehetjük
174- moduláris, hierarchikus, objektum-orientált keretrendszer
175 fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
176 terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
177
6b0aefbf
JR
178%description -l es.UTF-8
179Éste es GRUB - Grand Unified Boot Loader - un administrador de
180inicialización capaz de entrar en la mayoría de los sistemas
afe8504a 181operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
6b0aefbf 182también en la mayoría de los sistemas operacionales comerciales para
afe8504a
SP
183PC.
184
185El administrador GRUB puede ser una buena alternativa a LILO, para
6b0aefbf
JR
186usuarios conmás experiencia y que deseen obtener más recursos de su
187cargador de inicialización (boot loader).
afe8504a 188
6b0aefbf
JR
189%description -l pl.UTF-8
190GRUB jest bootloaderem na licencji GNU, mającym na celu unifikację
191procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
192Linuksa i *BSD: posiada również implementacje standardu Multiboot,
193który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
194(czego wymagają modułowe jądra, takie jak GNU Hurd).
afe8504a 195
6b0aefbf
JR
196%description -l pt_BR.UTF-8
197Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
afe8504a
SP
198capaz de entrar na maioria dos sistemas operacionais livres - Linux,
199FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
200operacionais comerciais para PC.
201
6b0aefbf
JR
202O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
203avançados e que querem mais recursos de seu boot loader.
afe8504a 204
565fe2e3
ER
205%package -n bash-completion-%{name}
206Summary: bash-completion for GRUB
207Summary(pl.UTF-8): bashowe uzupełnianie nazw dla GRUB
208Group: Applications/Shells
209Requires: bash-completion
210
211%description -n bash-completion-%{name}
212This package provides bash-completion for GRUB.
213
214%description -n bash-completion-%{name} -l pl.UTF-8
215Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB.
216
1536aaf2
JK
217%package pc
218Summary: PC BIOS platform support for GRUB
219Group: Base
220Requires: %{name} = %{version}-%{release}
221
222%description pc
223PC BIOS platform support for GRUB.
224
225%package efi
226Summary: (U)EFI platform support for GRUB
227Group: Base
228Requires: %{name} = %{version}-%{release}
229
230%description efi
231(U)EFI platform support for GRUB.
232
7615a862
JK
233%package mkfont
234Summary: GRUB font files converter
235Group: Base
236
237%description mkfont
238Converts common font file formats into PF2.
239
afe8504a 240%prep
f951fcbe 241%setup -q -n grub-%{version}
5028d8c9 242%patch0 -p1
b46589aa 243%patch1 -p1
872700b0 244%patch2 -p1
f951fcbe 245%patch3 -p1
aec70abd 246%patch4 -p1
f7ae30d0 247%patch5 -p1
e2964b87 248%patch6 -p1
449dde54 249%patch7 -p1
61d105fa 250%patch8 -p1
4c7bb96e 251%patch9 -p1
03e3686b 252%patch10 -p1
afe8504a 253
71c933c0 254%if "%{cc_version}" < "3.4"
dea0c850
ER
255grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
256%{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
71c933c0
ER
257%endif
258
afe8504a 259%build
928eb9c1
AM
260# if gold is used then grub doesn't even boot
261install -d our-ld
262ln -s /usr/bin/ld.bfd our-ld/ld
263export PATH=$(pwd)/our-ld:$PATH
264
3ff87e8a 265cp -f /usr/share/automake/config.sub .
afe8504a 266%{__libtoolize}
e9d73181 267%{__aclocal} -I m4
afe8504a 268%{__autoheader}
b1a4846d 269echo timestamp > stamp-h.in
afe8504a 270%{__autoconf}
53c50f89 271export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
12fd19f5 272
1536aaf2
JK
273for platform in %{platforms} ; do
274 install -d build-%{target_cpu}-${platform}
275 cd build-%{target_cpu}-${platform}
0e2cbb94
JK
276
277 if [ "$platform" != "efi" ] ; then
278 platform_opts="--%{!?with_efiemu:dis}%{?with_efiemu:en}able-efiemu"
279 else
280 platform_opts=""
281 fi
282
1536aaf2
JK
283 ln -s ../configure .
284 # mawk stalls at ./genmoddep.awk, so force gawk
285 AWK=gawk \
286 %configure \
287 --with-platform=${platform} \
288 --disable-werror \
289 %if %{with grubemu}
290 --enable-grub-emu-usb \
291 --enable-grub-emu-sdl \
292 --enable-grub-emu-pci \
293 %endif
0e2cbb94 294 $platform_opts \
1536aaf2
JK
295 TARGET_LDFLAGS=-static
296
297 %{__make}
298 cd ..
299done
0fb8b1a5 300
afe8504a
SP
301%install
302rm -rf $RPM_BUILD_ROOT
afe8504a 303
1536aaf2
JK
304for platform in %{platforms} ; do
305 cd build-%{target_cpu}-${platform}
306 %{__make} install \
307 pkgdatadir=%{_libexecdir} \
308 pkglibdir=%{_libexecdir} \
309 DESTDIR=$RPM_BUILD_ROOT
310 cd ..
311done
afe8504a 312
7615a862
JK
313# not in Th (?)
314%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
315%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
316
f951fcbe
AM
317%find_lang grub
318
bcd6a47e
ER
319# this must be after 'make install'
320install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
321
1536aaf2
JK
322install -d $RPM_BUILD_ROOT%{_grubdir}
323cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
324
7b6caae9 325# grub.d/41_custom
1536aaf2 326cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
7b6caae9
ER
327%{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
328
22909ca1 329install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
7b6caae9
ER
330cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
331
332install -d $RPM_BUILD_ROOT/etc/sysconfig
333cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
334
335# rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
47069130 336rm -f $RPM_BUILD_ROOT%{_infodir}/dir
e2964b87 337
cbd79801 338# core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
1536aaf2
JK
339touch $RPM_BUILD_ROOT%{_grubdir}/core.img
340touch $RPM_BUILD_ROOT%{_grubdir}/device.map
cbd79801 341
8b5c394b
ER
342# needs to be exactly 1KiB
343# but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
1536aaf2 344dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
8b5c394b 345
afe8504a
SP
346%clean
347rm -rf $RPM_BUILD_ROOT
348
5028d8c9 349%post -p %{_sbindir}/postshell
fc58858a 350-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 351
5028d8c9 352%postun -p %{_sbindir}/postshell
fc58858a 353-/usr/sbin/fix-info-dir -c %{_infodir}
f4604ef8 354
92904505 355%triggerpostun -- %{name} < %{version}-0
a7bef3b9 356# Note this trigger on version upgrade
92904505
ER
357# don't do anything on --downgrade
358if [ $1 -le 1 ]; then
359 exit 0
360fi
361echo "Grub was upgraded, trying to setup it to boot sector"
362/sbin/grub-install '(hd0)' || :
363
7b6caae9
ER
364%triggerpostun -- %{name} < 1.99-7.3
365# migrate /etc/grub.d/custom.cfg.rpmsave -> /boot/grub/custom.cfg
366if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
1536aaf2
JK
367 cp -f %{_grubdir}/custom.cfg{,.rpmnew}
368 mv -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
7b6caae9
ER
369fi
370
f951fcbe 371%files -f grub.lang
afe8504a 372%defattr(644,root,root,755)
2e4bec6f 373%doc AUTHORS ChangeLog NEWS README THANKS TODO
aec70abd 374%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
7615a862 375%attr(755,root,root) %{_sbindir}/grub-bios-setup
71c933c0 376%attr(755,root,root) %{_sbindir}/grub-editenv
3ea0c40e 377%attr(755,root,root) %{_sbindir}/grub-fstest
e9d73181 378%attr(755,root,root) %{_sbindir}/grub-kbdcomp
fc835b5e 379%attr(755,root,root) %{_sbindir}/grub-install
e9d73181 380%attr(755,root,root) %{_sbindir}/grub-menulst2cfg
fc835b5e 381%attr(755,root,root) %{_sbindir}/grub-mkconfig
e9d73181
AM
382%attr(755,root,root) %{_sbindir}/grub-mklayout
383%attr(755,root,root) %{_sbindir}/grub-mknetdir
71c933c0
ER
384%attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
385%attr(755,root,root) %{_sbindir}/grub-mkrelpath
386%attr(755,root,root) %{_sbindir}/grub-mkrescue
7615a862
JK
387%attr(755,root,root) %{_sbindir}/grub-mkstandalone
388%attr(755,root,root) %{_sbindir}/grub-mount
389%attr(755,root,root) %{_sbindir}/grub-ofpathname
71c933c0
ER
390%attr(755,root,root) %{_sbindir}/grub-reboot
391%attr(755,root,root) %{_sbindir}/grub-script-check
392%attr(755,root,root) %{_sbindir}/grub-set-default
22909ca1 393%attr(755,root,root) %{_sbindir}/update-grub
76be4c4a
AM
394%ifarch %{ix86} %{x8664}
395%attr(755,root,root) %{_sbindir}/grub-mkimage
fc835b5e 396%{_mandir}/man1/grub-mkimage.1*
76be4c4a
AM
397%else
398%attr(755,root,root) %{_sbindir}/grub-probe
76be4c4a 399%{_mandir}/man8/grub-probe.8*
76be4c4a 400%endif
71c933c0 401%{_mandir}/man1/grub-editenv.1*
3ea0c40e 402%{_mandir}/man1/grub-fstest.1*
7615a862 403%{_mandir}/man1/grub-kbdcomp.1*
e9d73181 404%{_mandir}/man1/grub-menulst2cfg.1*
e9d73181 405%{_mandir}/man1/grub-mklayout.1*
71c933c0 406%{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
03b9d04b 407%{_mandir}/man1/grub-mkrelpath.1*
71c933c0 408%{_mandir}/man1/grub-mkrescue.1*
7615a862
JK
409%{_mandir}/man1/grub-mkstandalone.1*
410%{_mandir}/man1/grub-mount.1*
71c933c0 411%{_mandir}/man1/grub-script-check.1*
7615a862 412%{_mandir}/man8/grub-bios-setup.8*
71c933c0 413%{_mandir}/man8/grub-install.8*
fc835b5e 414%{_mandir}/man8/grub-mkconfig.8*
e9d73181 415%{_mandir}/man8/grub-mknetdir.8*
7615a862 416%{_mandir}/man8/grub-ofpathname.8*
71c933c0
ER
417%{_mandir}/man8/grub-reboot.8*
418%{_mandir}/man8/grub-set-default.8*
22909ca1 419%{_mandir}/man8/update-grub.8*
797addca 420%if %{with grubemu}
8fcee4aa
ER
421%attr(755,root,root) %{_sbindir}/grub-emu
422%{_mandir}/man8/grub-emu.8*
797addca 423%endif
bc6e6053 424/lib/grub-mkconfig_lib
aec70abd 425
1536aaf2 426%dir %{_grubdir}
26e757db 427%dir %{_libexecdir}
bcd6a47e 428# XXX: check this locale dir location and if it is neccesaary to exist on /boot
565fe2e3 429
bcd6a47e 430%dir %{_libexecdir}/locale
1536aaf2
JK
431%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
432%config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
aec70abd 433
cbd79801 434# generated by grub at runtime
1536aaf2
JK
435%ghost %{_grubdir}/device.map
436%ghost %{_grubdir}/core.img
437%ghost %{_grubdir}/grubenv
cbd79801 438
e2964b87
ER
439%dir /lib/grub.d
440%doc /lib/grub.d/README
441%attr(755,root,root) /lib/grub.d/00_header
442%attr(755,root,root) /lib/grub.d/10_linux
e9d73181 443%attr(755,root,root) /lib/grub.d/20_linux_xen
e2964b87 444%attr(755,root,root) /lib/grub.d/30_os-prober
e9d73181 445%attr(755,root,root) /lib/grub.d/41_custom
e2964b87 446
1e58ef6c 447%ifarch %{ix86} %{x8664}
1ffaf1f6 448%attr(755,root,root) %{_sbindir}/grub-probe
fc835b5e 449%{_mandir}/man8/grub-probe.8*
4a00f3b7 450%endif
aec70abd 451
f4604ef8 452%{_infodir}/grub*.info*
565fe2e3 453
1536aaf2
JK
454%if %{with pc}
455%files pc
456%defattr(644,root,root,755)
457%dir %{_libexecdir}/*-pc
458%{_libexecdir}/*-pc/modinfo.sh
459%{_libexecdir}/*-pc/*.exec
460%{_libexecdir}/*-pc/*.image
461%{_libexecdir}/*-pc/*.lst
462%{_libexecdir}/*-pc/*.mod
463%{_libexecdir}/*-pc/*.module
464%{_libexecdir}/*-pc/lzma_decompress.img
465%{_libexecdir}/*-pc/config.h
466%{_libexecdir}/*-pc/gdb_grub
467%{_libexecdir}/*-pc/gmodule.pl
468%if %{with efiemu}
469%ifarch %{x8664}
470%{_libexecdir}/*-pc/efiemu*.o
471%endif
472%endif
473%{_libexecdir}/*-pc/kernel.img
474%ifarch %{ix86} %{x8664} sparc sparc64
475%{_libexecdir}/*-pc/boot.img
476%{_libexecdir}/*-pc/cdboot.img
477%{_libexecdir}/*-pc/diskboot.img
478%{_libexecdir}/*-pc/lnxboot.img
479%{_libexecdir}/*-pc/pxeboot.img
480%endif
481%endif
482
483%if %{with efi}
484%files efi
485%defattr(644,root,root,755)
486%dir %{_libexecdir}/*-efi
487%{_libexecdir}/*-efi/modinfo.sh
488%{_libexecdir}/*-efi/*.exec
489%{_libexecdir}/*-efi/*.lst
490%{_libexecdir}/*-efi/*.mod
491%{_libexecdir}/*-efi/*.module
492%{_libexecdir}/*-efi/config.h
493%{_libexecdir}/*-efi/gdb_grub
494%{_libexecdir}/*-efi/gmodule.pl
1536aaf2
JK
495%{_libexecdir}/*-efi/kernel.img
496%endif
497
7615a862
JK
498%files mkfont
499%defattr(644,root,root,755)
500%{_mandir}/man1/grub-mkfont.1*
501%attr(755,root,root) %{_sbindir}/grub-mkfont
502
565fe2e3
ER
503%files -n bash-completion-%{name}
504%defattr(644,root,root,755)
505/etc/bash_completion.d/grub
This page took 0.130353 seconds and 4 git commands to generate.