]> git.pld-linux.org Git - packages/gnustep-gui.git/blame - gnustep-gui.spec
- release 3
[packages/gnustep-gui.git] / gnustep-gui.spec
CommitLineData
5717de99
JB
1#
2# Conditional build:
3%bcond_without cups # GSCUPS bundle
4%bcond_without portaudio # gsnd tool
5#
829d10ca 6Summary: GNUstep GUI library package
fb1f7b25 7Summary(pl.UTF-8): Biblioteka GNUstep GUI
829d10ca 8Name: gnustep-gui
8bc301c9 9%define ver 0.16
472da72b 10Version: %{ver}.0
f209d90d 11Release: 3
f6967d0c 12License: LGPL/GPL
4b35d086 13Group: Libraries
829d10ca 14Source0: ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
8bc301c9 15# Source0-md5: 464b80094e438fe0cc8e6ae691b3384c
b63fcf5e 16Patch0: %{name}-themes.patch
0f8149d4
JB
17Patch1: %{name}-nocompressdocs.patch
18Patch2: %{name}-segv.patch
19Patch3: %{name}-doc.patch
aa92dd8e 20URL: http://www.gnustep.org/
c3847b61 21BuildRequires: aspell-devel
f6967d0c 22BuildRequires: audiofile-devel
5717de99 23%{?with_cups:BuildRequires: cups-devel}
f6967d0c 24BuildRequires: gcc-objc
5717de99
JB
25BuildRequires: giflib-devel
26BuildRequires: gnustep-base-devel >= 1.13.0
f6967d0c 27BuildRequires: libjpeg-devel
5717de99 28BuildRequires: libpng-devel
f6967d0c 29BuildRequires: libtiff-devel
5717de99 30%{?with_portaudio:BuildRequires: portaudio-devel >= 19}
f6967d0c 31BuildRequires: zlib-devel
5717de99 32Requires: gnustep-base >= 1.13.0
f6967d0c
JB
33Conflicts: gnustep-core
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
aa92dd8e 36%description
829d10ca 37It is a library of graphical user interface classes written completely
38in the Objective-C language; the classes are based upon the OpenStep
39specification as release by NeXT Software, Inc. The library does not
40completely conform to the specification and has been enhanced in a
41number of ways to take advantage of the GNU system. These classes
aa92dd8e 42include graphical objects such as buttons, text fields, popup lists,
43browser lists, and windows; there are also many associated classes for
44handling events, colors, fonts, pasteboards and images.
45
c261d120
JR
46%description -l pl.UTF-8
47To jest biblioteka klas graficznego interfejsu użytkownika napisana w
48Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
49NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
50została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
51zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
52rozwijane, listy przewijane i okienka; jest także wiele klas do
53obsługi zdarzeń, kolorów, fontów i obrazków.
e0359688 54
aa92dd8e 55%package devel
e0359688 56Summary: GNUstep GUI headers and libs
fb1f7b25 57Summary(pl.UTF-8): Pliki nagłówkowe GNUstep GUI
829d10ca 58Group: Development/Libraries
40ce32db 59Requires: %{name} = %{version}-%{release}
f6967d0c 60Requires: audiofile-devel
5717de99 61Requires: gnustep-base-devel >= 1.13.0
f6967d0c
JB
62Requires: libjpeg-devel
63Requires: libtiff-devel
829d10ca 64Conflicts: gnustep-core
aa92dd8e 65
66%description devel
829d10ca 67Header files required to build applications against the GNUstep GUI
f6967d0c 68library.
aa92dd8e 69
c261d120
JR
70%description devel -l pl.UTF-8
71Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
e0359688
JB
72biblioteki GNUstep GUI.
73
aa92dd8e 74%prep
f6967d0c 75%setup -q
41dc2ea6 76%patch0 -p1
0f8149d4 77%patch1 -p1
7c623ec7 78%patch2 -p1
2ee3e930 79%patch3 -p1
aa92dd8e 80
81%build
f669a675 82export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
5717de99 83export GNUSTEP_FLATTENED=yes
120e1cac
JB
84# disable gsnd - not ready for current portaudio
85%configure \
5717de99
JB
86 %{!?with_cups:--disable-cups} \
87 %{!?with_portaudio:--disable-gsnd}
aa92dd8e 88
d4d24605
SS
89# with __make -jN we can got non-deterministic errors
90%{__make} -j1 \
f6967d0c 91 messages=yes
aa92dd8e 92
f6967d0c
JB
93%install
94rm -rf $RPM_BUILD_ROOT
f669a675 95export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
8bc301c9 96export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
5717de99 97export GNUSTEP_FLATTENED=yes
aa92dd8e 98
f6967d0c 99%{__make} install \
f669a675
JR
100 DESTDIR=$RPM_BUILD_ROOT
101
0bd255f5 102%{__make} install -C Documentation \
f669a675 103 DESTDIR=$RPM_BUILD_ROOT
aa92dd8e 104
f669a675 105find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
3e8a68a7 106 -type f -name .cvsignore | xargs rm -f
aa92dd8e 107
f669a675
JR
108# not (yet?) supported by rpm-compress-doc
109find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
110 -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
c387a5cc 111
aa92dd8e 112%clean
113rm -rf $RPM_BUILD_ROOT
114
e0359688
JB
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
f6967d0c 118%files
829d10ca 119%defattr(644,root,root,755)
f6967d0c 120%doc ChangeLog
f669a675
JR
121%docdir %{_datadir}/GNUstep/Documentation
122%dir %{_datadir}/GNUstep/Documentation/Developer
123%dir %{_datadir}/GNUstep/Documentation/Developer/Gui
124%{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
125%{_datadir}/GNUstep/Documentation/User
126
127%{_mandir}/man1/*
f6967d0c 128
f669a675
JR
129%attr(755,root,root) %{_bindir}/*
130%attr(755,root,root) %{_libdir}/libgnustep-gui.so.*
f6967d0c 131
b10e018b 132%dir %{_libdir}/GNUstep/Bundles
f669a675
JR
133%dir %{_libdir}/GNUstep/Bundles/GSPrinting
134%dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
135%{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
136%{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
5717de99
JB
137%if %{with cups}
138# R: cups-lib - separate?
f669a675
JR
139%dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
140%{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
141%{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
5717de99 142%endif
f669a675
JR
143
144%dir %{_libdir}/GNUstep/Bundles/TextConverters
145%dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
146%{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
147%attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
148%dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
149%{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
150%attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
151
152%dir %{_libdir}/GNUstep/ColorPickers
153%dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
154%{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
155%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
156%dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
157%dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
158%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
159%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
160%{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
161%lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
162%lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
163%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
164%dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
165%{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
166%attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
167
b10e018b
JR
168%{_libdir}/GNUstep/Images
169%{_libdir}/GNUstep/KeyBindings
f669a675
JR
170
171%dir %{_libdir}/GNUstep/Libraries/gnustep-gui
172%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
173%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
174%dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
175%{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
176%{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
177%lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
178%lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
179%lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
180%lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
181
182%dir %{_libdir}/GNUstep/PostScript
183%{_libdir}/GNUstep/PostScript/GSProlog.ps
184%dir %{_libdir}/GNUstep/PostScript/PPD
185%{_libdir}/GNUstep/PostScript/PPD/English.lproj
b10e018b 186%dir %{_libdir}/GNUstep/Services
f669a675
JR
187%dir %{_libdir}/GNUstep/Services/GSspell.service
188%{_libdir}/GNUstep/Services/GSspell.service/Resources
189%attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
f6967d0c
JB
190
191%files devel
829d10ca 192%defattr(644,root,root,755)
f669a675
JR
193%docdir %{_datadir}/GNUstep/Documentation
194%{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
195%{_datadir}/GNUstep/Documentation/Developer/Gui/General
196%{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
197%{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
198%{_infodir}/*.info*
199
200%{_includedir}/AppKit
201%{_includedir}/Cocoa
202%{_includedir}/GNUstepGUI
203%{_includedir}/gnustep/gui
204
205%attr(755,root,root) %{_libdir}/libgnustep-gui.so
206%{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.132913 seconds and 4 git commands to generate.