]> git.pld-linux.org Git - packages/ghc-snap-server.git/blame - ghc-snap-server.spec
- sane deps
[packages/ghc-snap-server.git] / ghc-snap-server.spec
CommitLineData
aff86967
JR
1%define pkgname snap-server
2Summary: A fast, iteratee-based, epoll-enabled web server for the Snap Framework
3Name: ghc-%{pkgname}
56b647ce
JR
4Version: 0.9.4.0
5Release: 1
aff86967
JR
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
56b647ce 9# Source0-md5: 4ee81486fcaf568a9f6ae58a4df1e28a
aff86967
JR
10URL: http://hackage.haskell.org/package/snap-server/
11BuildRequires: ghc >= 6.12.3
12BuildRequires: ghc-prof
13f24aa4
JR
13BuildRequires: ghc-attoparsec
14BuildRequires: ghc-attoparsec-prof
aff86967 15BuildRequires: ghc-attoparsec-enumerator
13f24aa4 16BuildRequires: ghc-attoparsec-enumerator-prof
aff86967 17BuildRequires: ghc-blaze-builder >= 0.2.1.4
13f24aa4 18BuildRequires: ghc-blaze-builder-prof >= 0.2.1.4
aff86967 19BuildRequires: ghc-blaze-builder-enumerator >= 0.2.0
13f24aa4 20BuildRequires: ghc-blaze-builder-enumerator-prof >= 0.2.0
aff86967 21BuildRequires: ghc-enumerator >= 0.4.15
13f24aa4 22BuildRequires: ghc-enumerator-prof >= 0.4.15
aff86967 23BuildRequires: ghc-MonadCatchIO-transformers >= 0.2.1
13f24aa4 24BuildRequires: ghc-MonadCatchIO-transformers-prof >= 0.2.1
aff86967 25BuildRequires: ghc-snap-core >= 0.9.3
13f24aa4 26BuildRequires: ghc-snap-core-prof >= 0.9.3
aff86967 27BuildRequires: ghc-unix-compat >= 0.2
13f24aa4 28BuildRequires: ghc-unix-compat-prof >= 0.2
aff86967 29BuildRequires: rpmbuild(macros) >= 1.608
0b425514 30%requires_eq ghc
aff86967
JR
31Requires(post,postun): /usr/bin/ghc-pkg
32Requires: ghc-attoparsec-enumerator
33Requires: ghc-blaze-builder >= 0.2.1.4
34Requires: ghc-blaze-builder-enumerator >= 0.2.0
35Requires: ghc-enumerator >= 0.4.15
36Requires: ghc-MonadCatchIO-transformers >= 0.2.1
52232f01 37%requires_eq ghc-snap-core
aff86967
JR
38Requires: ghc-unix-compat >= 0.2
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41# debuginfo is not useful for ghc
42%define _enable_debug_packages 0
43
44# don't compress haddoc files
45%define _noautocompressdoc *.haddock
46
47%description
48Snap is a simple and fast web development framework and server written
49in Haskell. For more information or to download the latest version,
50you can visit the Snap project website at http://snapframework.com/.
51
52The Snap HTTP server is a high performance, epoll-enabled,
53iteratee-based web server library written in Haskell. Together with
54the snap-core library upon which it depends, it provides a clean and
55efficient Haskell programming interface to the HTTP protocol.
56
57%package prof
58Summary: Profiling %{pkgname} library for GHC
59Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
13f24aa4
JR
62BuildRequires: ghc-attoparsec-prof
63BuildRequires: ghc-attoparsec-enumerator-prof
64BuildRequires: ghc-blaze-builder-prof
65BuildRequires: ghc-blaze-builder-enumerator-prof
66BuildRequires: ghc-enumerator-prof
67BuildRequires: ghc-MonadCatchIO-transformers-prof
68BuildRequires: ghc-snap-core-prof
69BuildRequires: ghc-unix-compat-prof
aff86967
JR
70
71%description prof
72Profiling %{pkgname} library for GHC. Should be installed when
73GHC's profiling subsystem is needed.
74
75%description prof -l pl.UTF-8
76Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
77kiedy potrzebujemy systemu profilującego z GHC.
78
79%prep
80%setup -q -n %{pkgname}-%{version}
81
82%build
83runhaskell Setup.hs configure -v2 --enable-library-profiling \
84 --prefix=%{_prefix} \
85 --libdir=%{_libdir} \
86 --libexecdir=%{_libexecdir} \
87 --docdir=%{_docdir}/%{name}-%{version}
88
89runhaskell Setup.hs build
90runhaskell Setup.hs haddock --executables
91
92%install
93rm -rf $RPM_BUILD_ROOT
94install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
95
96runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
97
98# work around automatic haddock docs installation
99%{__rm} -rf %{name}-%{version}-doc
100cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
101%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
102
103runhaskell Setup.hs register \
104 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%post
110%ghc_pkg_recache
111
112%postun
113%ghc_pkg_recache
114
115%files
116%defattr(644,root,root,755)
13f24aa4 117%doc CONTRIBUTORS README*
aff86967
JR
118%doc %{name}-%{version}-doc/*
119%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
120%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
121%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.o
122%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
13f24aa4 123%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
aff86967
JR
124%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
125
13f24aa4
JR
126%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap
127%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Http
128%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Http/*.hi
129%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Http/Server
130%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Http/Server/*.hi
131%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal
132%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Http
133%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Http/*.hi
134%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Http/Server
135%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Http/Server/*.hi
136%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System
137%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/*.hi
138%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/SendFile
139%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/SendFile/*.hi
aff86967
JR
140
141%files prof
142%defattr(644,root,root,755)
143%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
13f24aa4
JR
144%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
145%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Http/*.p_hi
146%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Http/Server/*.p_hi
147%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Http/*.p_hi
148%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Snap/Internal/Http/Server/*.p_hi
149%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/*.p_hi
150%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/System/SendFile/*.p_hi
This page took 0.057054 seconds and 4 git commands to generate.