]> git.pld-linux.org Git - projects/template-specs.git/blame - ghc-package.spec
- fixed post
[projects/template-specs.git] / ghc-package.spec
CommitLineData
33f247fc
JR
1%define pkgname NAME
2Summary: Hashed file storage support code
3Name: haskell-%{pkgname}
4Version: VERSION
5Release: 0.1
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9# Source0-md5: -
10URL: http://hackage.haskell.org/package/%{pkgname}/
11BuildRequires: ghc
12#BuildRequires: haskell-binary
13#BuildRequires: haskell-dataenc
14#BuildRequires: haskell-mmap
15#BuildRequires: haskell-zlib
16ExclusiveArch: %{ix86} %{x8664}
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%define libsubdir ghc-%(/usr/bin/ghc --numeric-version)/%{pkgname}-%{version}
20
21%description
22
23%prep
24%setup -q -n %{pkgname}-%{version}
25
26%build
27runhaskell Setup.hs configure -v3 \
28 --prefix=%{_prefix} \
29 --libdir=%{_libdir} \
30 --libexecdir=%{_libexecdir} \
31 --libsubdir=%{libsubdir}
32
33runhaskell Setup.hs build
34
35%install
36rm -rf $RPM_BUILD_ROOT
37runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
38
39runhaskell Setup.hs register \
40 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{libsubdir}/%{pkgname}.conf
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%post
596f7a27 46/usr/bin/ghc-pkg update %{_libdir}/%{libsubdir}/%{pkgname}.conf
33f247fc
JR
47
48%postun
49/usr/bin/ghc-pkg unregister %{pkgname}-%{version}
50
51
52%files
53%defattr(644,root,root,755)
54%doc NEWS
55%{_libdir}/%{libsubdir}
This page took 0.063417 seconds and 4 git commands to generate.