]> git.pld-linux.org Git - projects/template-specs.git/blame - ghc-package.spec
one more package type
[projects/template-specs.git] / ghc-package.spec
CommitLineData
c21b0a6d 1%define pkgname PACKAGE_NAME
8b1e5bb7
JR
2Summary: -
3Name: ghc-%{pkgname}
4Version: -
33f247fc 5Release: 0.1
8b1e5bb7 6License: - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
33f247fc
JR
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9# Source0-md5: -
c21b0a6d 10URL: http://hackage.haskell.org/package/PACKAGE_NAME/
4cc44b9e 11BuildRequires: ghc >= 6.12.3
e6e67c39 12#BuildRequires: ghc-prof
3454a91a 13#BuildRequires: ghc-OTHERMODULE
1239e613 14BuildRequires: rpmbuild(macros) >= 1.608
175c26ee 15%requires_releq ghc
3ea9522f 16Requires(post,postun): /usr/bin/ghc-pkg
cbca2db5 17#Requires: ghc-OTHERMODULE
33f247fc
JR
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
da37dde1
ER
20# debuginfo is not useful for ghc
21%define _enable_debug_packages 0
22
d2d5700e
JR
23# don't compress haddoc files
24%define _noautocompressdoc *.haddock
25
33f247fc
JR
26%description
27
bcbb32c6
JR
28%package prof
29Summary: Profiling %{pkgname} library for GHC
30Summary(pl.UTF-8): Biblioteka profilująca %{pkgname} dla GHC.
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33
34%description prof
35Profiling %{pkgname} library for GHC. Should be installed when
36GHC's profiling subsystem is needed.
37
38%description prof -l pl.UTF-8
39Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
40kiedy potrzebujemy systemu profilującego z GHC.
41
33f247fc
JR
42%prep
43%setup -q -n %{pkgname}-%{version}
44
45%build
e6e67c39 46runhaskell Setup.lhs configure -v2 --enable-library-profiling \
33f247fc
JR
47 --prefix=%{_prefix} \
48 --libdir=%{_libdir} \
49 --libexecdir=%{_libexecdir} \
78afb22b 50 --docdir=%{_docdir}/%{name}-%{version}
33f247fc 51
e6e67c39
JR
52runhaskell Setup.lhs build
53runhaskell Setup.lhs haddock --executables
33f247fc
JR
54
55%install
56rm -rf $RPM_BUILD_ROOT
4cc44b9e
JR
57install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
58
e6e67c39 59runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
33f247fc 60
41e08a97 61# work around automatic haddock docs installation
24441f42 62rm -rf %{name}-%{version}-doc
d2d5700e 63cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
41e08a97 64
e6e67c39 65runhaskell Setup.lhs register \
4cc44b9e 66 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
33f247fc
JR
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post
1239e613 72%ghc_pkg_recache
33f247fc
JR
73
74%postun
1239e613 75%ghc_pkg_recache
33f247fc
JR
76
77%files
78%defattr(644,root,root,755)
79%doc NEWS
d2d5700e 80%doc %{name}-%{version}-doc/*
4cc44b9e 81%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
bcbb32c6
JR
82%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
83%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.o
84%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
85%exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
86
87%dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE
88%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.hi
89
90%files prof
91%defattr(644,root,root,755)
92%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
93%{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.p_hi
This page took 0.045476 seconds and 4 git commands to generate.