]> git.pld-linux.org Git - packages/ghc-dbus.git/blame - ghc-dbus.spec
- rel 2
[packages/ghc-dbus.git] / ghc-dbus.spec
CommitLineData
f588e68b
JP
1%define pkgname dbus
2Summary: A Haskell binding to the dbus graphics library
3Name: ghc-%{pkgname}
4Version: 0.10.4
aed4cd1e 5Release: 2
f588e68b
JP
6License: BSD
7Group: Development/Languages
8Source0: http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9# Source0-md5: 37d7c18abd7a4b397265e90eed035e92
10URL: http://hackage.haskell.org/package/dbus/
11BuildRequires: ghc >= 6.12.3
12BuildRequires: ghc-cereal < 0.4
13BuildRequires: ghc-cereal >= 0.3.4
14BuildRequires: ghc-libxml-sax >= 0.7
15BuildRequires: ghc-network >= 2.2.3
16BuildRequires: ghc-parsec < 3.2
17BuildRequires: ghc-parsec >= 2.0
18BuildRequires: ghc-random >= 1.0
19BuildRequires: ghc-text < 0.12
20BuildRequires: ghc-text >= 0.11.1.5
21BuildRequires: ghc-transformers < 0.4
22BuildRequires: ghc-transformers >= 0.2
23BuildRequires: ghc-vector < 0.11
24BuildRequires: ghc-vector >= 0.7
25BuildRequires: ghc-xml-types >= 0.3
26BuildRequires: rpmbuild(macros) >= 1.608
27%requires_eq ghc
28Requires: ghc-cereal < 0.4
29Requires: ghc-cereal >= 0.3.4
30Requires: ghc-libxml-sax >= 0.7
31Requires: ghc-network >= 2.2.3
32Requires: ghc-parsec < 3.2
33Requires: ghc-parsec >= 2.0
34Requires: ghc-random >= 1.0
35Requires: ghc-text < 0.12
36Requires: ghc-text >= 0.11.1.5
37Requires: ghc-transformers < 0.4
38Requires: ghc-transformers >= 0.2
39Requires: ghc-vector < 0.11
40Requires: ghc-vector >= 0.7
41Requires: ghc-xml-types >= 0.3
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44# debuginfo is not useful for ghc
45%define _enable_debug_packages 0
46
47%description
48A Haskell binding to the dbus graphics library.
49
50%package doc
51Summary: HTML documentation for %{pkgname}
52Summary(pl.UTF-8): Dokumentacja w formacie HTML dla %{pkgname}
53Group: Documentation
54
55%description doc
56HTML documentation for %{pkgname}.
57
58%description doc -l pl.UTF-8
59Dokumentacja w formacie HTML dla %{pkgname}.
60
61%prep
62%setup -q -n %{pkgname}-%{version}
63
64%build
65runhaskell Setup.hs configure -v2 \
66 --prefix=%{_prefix} \
67 --libdir=%{_libdir} \
68 --libexecdir=%{_libexecdir} \
69 --docdir=%{_docdir}/%{name}-%{version}
70
71runhaskell Setup.hs build
72runhaskell Setup.hs haddock --executables
73
74%install
75rm -rf $RPM_BUILD_ROOT
76install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
77
78runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
79
80# work around automatic haddock docs installation
81rm -rf %{name}-%{version}-doc
82cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
83%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
84
85runhaskell Setup.hs register \
86 --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post
92%ghc_pkg_recache
93
94%postun
95%ghc_pkg_recache
96
97%files
98%defattr(644,root,root,755)
99%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
100%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
101
102%files doc
103%defattr(644,root,root,755)
104%doc %{name}-%{version}-doc/*
This page took 0.041144 seconds and 4 git commands to generate.