]> git.pld-linux.org Git - packages/geninitrd.git/blame - geninitrd.spec
- 10000.33, fixes rootfs on lvm for current lvm2
[packages/geninitrd.git] / geninitrd.spec
CommitLineData
5bba2f6c 1# TODO:
8d4b3be5
PG
2# - BUG: you can't set in /etc/mdadm.conf:
3# DEVICE partitions containers
4# (which is default BTW if none set). Generation of initrd will fail
5#
70a0ef68 6Summary: Creates an initial ramdisk image for preloading modules
4bd9777f 7Summary(pl.UTF-8): Narzędzie do tworzenia inicjalnego ramdysku używanego przy starcie systemu
70a0ef68 8Name: geninitrd
5bba2f6c
ER
9Version: 10000.33
10Release: 1
70a0ef68 11License: GPL
6e7d5844 12Group: Applications/System
3adc6ee3 13Source0: %{name}-%{version}.tar.gz
5bba2f6c 14# Source0-md5: f302536aa529f794ce491af07f5703ac
929a4239 15Patch0: %{name}-romfs.patch
b05ab846 16Patch1: %{name}-gzip-compressor.patch
5bba2f6c 17#Patch2: %{name}-svn.patch
0dd71c4b 18BuildRequires: xmlto >= 0:0.0.18-1
fe2d4469 19Requires: /usr/bin/ldd
0e068c76 20Requires: awk
43148c51 21Requires: busybox-initrd > 1.00-4
417ef52a 22Requires: coreutils
7b29e9b5 23Requires: cpio
0e068c76 24Requires: fileutils
25Requires: genromfs
87c020ab 26Requires: glibc-misc
0e068c76 27Requires: gzip
16ac31fd 28Requires: mktemp >= 1.5-8
f9ef5006 29Requires: module-init-tools >= 3.2.2-6
0e068c76 30Requires: mount
495990cb 31Requires: pci-database >= 0.4
e018b691 32Requires: rc-scripts >= 0.2.7
0e068c76 33Requires: tar
6f0074bc 34%if "%{pld_release}" == "ti"
35Requires: lvm2-initrd
36Requires: mdadm-initrd >= 1.12.0-1
37%else
55c24912 38# otherwise LVM subsystem is not enabled in geninitrd
f3d68afb 39Suggests: lvm2-initrd
e018b691 40# without this softraid installations of PLD fail
ac7d5e9a 41Suggests: mdadm-initrd >= 1.12.0-1
6f0074bc 42%endif
55c24912
ER
43# suggest for blkid
44%if "%{pld_release}" != "ac"
244b296a 45Suggests: util-linux-initrd
55c24912 46%endif
70a0ef68 47Obsoletes: mkinitrd
fe2d4469
ER
48%if "%{pld_release}" == "ac"
49Conflicts: grubby < 5.0.4-3.1
50%else
429e8b1c 51Conflicts: grubby < 6.0.24-3
fe2d4469 52%endif
f9ef5006 53Conflicts: udev-initrd < 1:104
ba3bd13f 54Conflicts: xz < 4.999.9
cf111fa1 55BuildArch: noarch
70a0ef68
JK
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58%description
570eccb2
ER
59Geninitrd creates filesystem images for use as initial ramdisk
60(initrd) images. These ramdisk images are often used to preload the
61block device modules (SCSI or RAID) needed to access the root
62filesystem.
70a0ef68
JK
63
64In other words, generic kernels can be built without drivers for any
65SCSI adapters which load the SCSI driver as a module. Since the kernel
66needs to read those modules, but in this case it isn't able to address
67the SCSI adapter, an initial ramdisk is used. The initial ramdisk is
68loaded by the operating system loader (normally LILO) and is available
69to the kernel as soon as the ramdisk is loaded. The ramdisk image
70loads the proper SCSI adapter and allows the kernel to mount the root
71filesystem. The geninitrd program creates such a ramdisk using
72information found in the /etc/modules.conf file.
73
54baa167
JR
74%description -l pl.UTF-8
75Geninitrd służy do tworzenia obrazu systemu plikowego używanego jako
76inicjalny ramdysk (initrd), z którego przy starcie systemu są ładowane
77moduły kernela z obsługą urządzeń których obsługa nie jest
78wkompilowana w kernel. Zazwyczaj modułami ładowanymi z inicjalnego
79systemu plikowego są sterowniki SCSI, IDE czy też RAID po to żeby w
80dalszej części inicjacji systemu był możliwy dostęp do głównego
70a0ef68
JK
81systemu plikowego (root fs).
82
54baa167
JR
83Dzięki initrd jest możliwe używanie dystrybucyjnego kernela w którym
84wkompilowana jest minimalna ilość obsługi różnych urządzeń, a reszta
85kodu obsługi sterowników SCSI, IDE czy RAID jest doczytywana w trakcie
70a0ef68 86startu z initrd. Skrypt geninitrd generuje obraz ramdysku na podstawie
54baa167 87bieżących informacji zawartych w /etc/modules.conf.
70a0ef68
JK
88
89%prep
90%setup -q
929a4239 91%if "%{pld_release}" == "ti"
92%patch0 -p1
b05ab846 93%patch1 -p1
929a4239 94%endif
5bba2f6c 95#%patch2 -p0
f2aef47d 96
0dd71c4b 97%build
e0c74de2 98%{__make}
0dd71c4b 99
70a0ef68
JK
100%install
101rm -rf $RPM_BUILD_ROOT
37688ad3 102%{__make} install \
e0c74de2 103 DESTDIR=$RPM_BUILD_ROOT
70a0ef68
JK
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%files
109%defattr(644,root,root,755)
61d0a20b 110%doc ChangeLog
417ef52a 111%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/geninitrd
70a0ef68 112%attr(755,root,root) /sbin/geninitrd
429e8b1c 113%{_mandir}/man8/geninitrd.8*
417ef52a 114
429e8b1c
ER
115%dir /lib/geninitrd
116/lib/geninitrd/functions
117/lib/geninitrd/mod-*.sh
824e8293 118%attr(755,root,root) /lib/geninitrd/extract-ikconfig
This page took 0.07417 seconds and 4 git commands to generate.