]> git.pld-linux.org Git - packages/gcl.git/blame - gcl.spec
- invoke fix-info-dir via /sbin/postshell where possible to avoid extra /bin/sh dep
[packages/gcl.git] / gcl.spec
CommitLineData
53838840 1#
2# Conditional build:
375c5315 3%bcond_without builtin_bfd # use built in bfd instead of system one
53838840 4# (currently does not build with system one from new binutils)
5#
444a6bb2 6Summary: GNU Common Lisp system
68a7060f 7Summary(pl.UTF-8): System GNU Common Lisp
f7b10388 8Name: gcl
ec457178 9Version: 2.6.7
10Release: 1
511dae64 11License: LGPL v2
f7b10388 12Group: Development/Languages
cff490b4 13Source0: ftp://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
ec457178 14# Source0-md5: c0f42e1f391162e5ac90912a70e8ecc3
f7b10388 15Patch0: %{name}-make.patch
cff490b4 16Patch1: %{name}-info.patch
14e8f974 17# It seems this patch doesn't fix what it should: still doesn't build with
18# newer binutils
19#Patch2: %{name}-binutils.patch
4c1392ac 20URL: http://www.gnu.org/software/gcl/
9b7b8579 21BuildRequires: autoconf
16004e02 22BuildRequires: automake
cff490b4
JB
23BuildRequires: gmp-devel >= 4.0
24BuildRequires: readline-devel
2e08fe4e 25BuildRequires: texinfo
cff490b4
JB
26%define _tkline 8.4
27BuildRequires: tk-devel >= %{_tkline}
37557a1a 28BuildRequires: xemacs
f7b10388 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32The GNU Common Lisp system, based on KCL.
33
12ccc44d
JR
34%description -l pl.UTF-8
35System GNU Common Lisp, bazujący na KCL.
f7b10388 36
37%package tk
b893fe57 38Summary: Tcl/Tk bindings for GNU Common Lisp
68a7060f 39Summary(pl.UTF-8): Interfejs Tcl/Tk do GNU Common Lisp
f7b10388 40Group: Development/Languages
cff490b4 41Requires: %{name} = %{version}-%{release}
f7b10388 42
43%description tk
b893fe57 44Tcl/Tk bindings for GNU Common Lisp.
f7b10388 45
12ccc44d 46%description tk -l pl.UTF-8
a400aa1f 47Interfejs Tcl/Tk dla GNU Common Lisp.
f7b10388 48
49%prep
cff490b4 50%setup -q
f7b10388 51%patch0 -p1
52%patch1 -p1
14e8f974 53#%%patch2 -p1
f7b10388 54
55%build
f7463ca7 56%{__aclocal}
7ccfaa0b 57%{__autoconf}
92ced808 58cp -f /usr/share/automake/config.* .
37557a1a 59GCC="%{__cc}"; export GCC
f89ea09c
JB
60# note: full path to xemacs must be passed
61EMACS=/usr/bin/xemacs; export EMACS
511dae64 62%configure \
cff490b4 63 --disable-statsysbfd \
03051c2a 64%ifnarch alpha hppa ia64 mips
53838840 65%if %{with builtin_bfd}
66 --enable-locbfd \
67%else
cff490b4 68 --enable-dynsysbfd \
53838840 69%endif
1752ade1 70%endif
cff490b4 71 --enable-dynsysgmp \
f7b10388 72 --enable-notify=no
1acb6ac9 73
444a6bb2 74%{__make} \
1acb6ac9 75 EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
f7b10388 76
77%install
78rm -rf $RPM_BUILD_ROOT
cff490b4 79install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
1acb6ac9 80
cff490b4
JB
81%{__make} install1 \
82 DESTDIR=$RPM_BUILD_ROOT \
83 INSTALL_LIB_DIR=%{_libdir}/gcl
3be8d08d 84
cff490b4
JB
85mv -f $RPM_BUILD_ROOT%{_libdir}/gcl/info/* $RPM_BUILD_ROOT%{_infodir}
86rmdir $RPM_BUILD_ROOT%{_libdir}/gcl/info
f7b10388 87
cff490b4 88install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
f7b10388 89
90ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
91
92cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
93#!/bin/sh
94exec %{_libdir}/gcl/unixport/saved_gcl \
1acb6ac9 95 -dir {_libdir}/gcl/unixport/ \
96 -libdir %{_libdir}/gcl/ \
97 -eval '(setq si::*allow-gzipped-file* t)' \
98 "$@"
f7b10388 99EOF
100
101cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
102#!/bin/sh
103exec %{_libdir}/gcl/unixport/saved_gcl \
1acb6ac9 104 -dir {_libdir}/gcl/unixport/ \
105 -libdir %{_libdir}/gcl/ \
106 -eval '(setq si::*allow-gzipped-file* t)' \
cff490b4 107 -eval '(setq si::*tk-library* "/usr/lib/tk%{_tkline}")' \
1acb6ac9 108 "$@"
f7b10388 109EOF
110
3c5d3ae9
JB
111%clean
112rm -rf $RPM_BUILD_ROOT
113
0b8192e9
ER
114%post -p /sbin/postshell
115-/usr/sbin/fix-info-dir -c %{_infodir}
f7b10388 116
0b8192e9
ER
117%postun -p /sbin/postshell
118-/usr/sbin/fix-info-dir -c %{_infodir}
f7b10388 119
999262ac
ER
120%post tk -p /sbin/postshell
121-/usr/sbin/fix-info-dir -c %{_infodir}
f7b10388 122
999262ac
ER
123%postun tk -p /sbin/postshell
124-/usr/sbin/fix-info-dir -c %{_infodir}
f7b10388 125
f7b10388 126%files
127%defattr(644,root,root,755)
a2a46def 128%doc readme faq ChangeLog
f7b10388 129%attr(755,root,root) %{_bindir}/gcl
130%attr(755,root,root) %{_bindir}/gcl.exe
444a6bb2 131%dir %{_libdir}/gcl
cff490b4 132%{_libdir}/gcl/clcs
f7b10388 133%{_libdir}/gcl/cmpnew
cff490b4 134%{_libdir}/gcl/h
f7b10388 135%{_libdir}/gcl/lsp
cff490b4 136%{_libdir}/gcl/pcl
444a6bb2 137%dir %{_libdir}/gcl/unixport
f7b10388 138%attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
cff490b4
JB
139%{_libdir}/gcl/unixport/*.lsp
140# to -devel?
141#%{_libdir}/gcl/unixport/*.a
1acb6ac9 142%{_infodir}/gcl-si.info*
143%{_mandir}/man1/*
f7b10388 144
145%files tk
3c5d3ae9 146%defattr(644,root,root,755)
f7b10388 147%attr(755,root,root) %{_bindir}/gcl-tk
90da9ded 148%dir %{_libdir}/gcl/gcl-tk
f1883a5f 149%attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
150%attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
151%{_libdir}/gcl/gcl-tk/*.o
152%{_libdir}/gcl/gcl-tk/*.tcl
37557a1a 153%{_infodir}/gcl-tk.info*
This page took 0.064417 seconds and 4 git commands to generate.