]> git.pld-linux.org Git - packages/gc.git/blame - gc.spec
- converted to UTF-8
[packages/gc.git] / gc.spec
CommitLineData
6ba38cbe 1Summary: The Boehm-Demers-Weiser conservative garbage collector
9973a288 2Summary(pl.UTF-8): Konserwatywny odśmiecacz pamięci Boehma-Demersa-Weisera
79cafb95 3Name: gc
13abb204 4Version: 6.8
1ae6cb20 5Release: 1
aeefcfe2 6License: BSD-like
65885941 7Group: Libraries
79cafb95 8Source0: http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/%{name}%{version}.tar.gz
13abb204 9# Source0-md5: 418d38bd9c66398386a372ec0435250e
79cafb95 10URL: http://www.hpl.hp.com/personal/Hans_Boehm/gc/
65885941 11BuildRequires: autoconf >= 2.53
fba7476c 12BuildRequires: automake
cae00516 13BuildRequires: libtool
79cafb95 14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
65885941
JB
16%define _includedir %{_prefix}/include/gc
17
79cafb95 18%description
19Gc is a conservative garbage collector for C and C++. It is used as a
20replacement for standard malloc() and free(). GC_malloc will attempt
21to reclaim inaccessible space automatically by invoking a conservative
22garbage collector at appropriate points.
23
9973a288
JR
24%description -l pl.UTF-8
25Gc jest konserwatywnym odśmiecaczem pamięci dla C i C++. Jest używany
79cafb95 26jako zamiennik dla standardowych funkcji malloc() i free(). GC_malloc
9973a288
JR
27próbuje odzyskać niedostępna pamięć automatycznie przez wywoływanie
28konserwatywnego odśmiecacza pamięci w odpowiednich miejscach.
79cafb95 29
30%package devel
31Summary: Headers for conservative garbage collector
9973a288 32Summary(pl.UTF-8): Nagłówki dla konserwatywnego odśmiecacza pamięci
79cafb95 33Group: Development/Libraries
a58a5390 34Requires: %{name} = %{version}-%{release}
79cafb95 35
36%description devel
37Headers for conservative garbage collector
38
9973a288
JR
39%description devel -l pl.UTF-8
40Nagłówki dla konserwatywnego odśmiecacza pamięci
79cafb95 41
42%package static
43Summary: Static version of gc library
9973a288 44Summary(pl.UTF-8): Statyczna wersja biblioteki gc
79cafb95 45Group: Development/Libraries
a58a5390 46Requires: %{name}-devel = %{version}-%{release}
79cafb95 47
48%description static
49Static version of gc library
50
9973a288 51%description static -l pl.UTF-8
79cafb95 52Statyczna wersja biblioteki gc
53
54%prep
55%setup -q -n %{name}%{version}
56
65885941 57# kill libtool.m4 inclusion
04f426f7
JB
58%{__perl} -pi -e 's/^sinclude.*//' acinclude.m4
59
65885941
JB
60%{__perl} -pi -e 's/^dist_pkgdata_DATA/EXTRA_DIST/' doc/Makefile.am
61
79cafb95 62%build
cae00516 63%{__libtoolize}
64%{__aclocal}
65%{__autoconf}
66%{__automake}
67%configure \
de3b9f0b 68 CPPFLAGS="-DUSE_LIBC_PRIVATES" \
4b4413f1 69 --enable-threads=posix
79cafb95 70%{__make}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
73312b54 75%{__make} install \
76 DESTDIR=$RPM_BUILD_ROOT
1ae6cb20 77
53ca00b4 78install -d $RPM_BUILD_ROOT%{_includedir}/gc/private
1ae6cb20 79install include/private/* $RPM_BUILD_ROOT%{_includedir}/gc/private
65885941 80install -D doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
79cafb95 81
79cafb95 82%clean
83rm -rf $RPM_BUILD_ROOT
84
04f426f7
JB
85%post -p /sbin/ldconfig
86%postun -p /sbin/ldconfig
87
79cafb95 88%files
89%defattr(644,root,root,755)
32026be9
MM
90%doc README.QUICK doc/README{,.{linux,changes,contributors,environment,macros}}
91%doc doc/*.html
65885941 92%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
79cafb95 93
94%files devel
95%defattr(644,root,root,755)
65885941
JB
96%attr(755,root,root) %{_libdir}/lib*.so
97%{_libdir}/lib*.la
98%{_includedir}
a58a5390 99%{_mandir}/man3/gc.3*
79cafb95 100
101%files static
102%defattr(644,root,root,755)
65885941 103%{_libdir}/lib*.a
This page took 0.166939 seconds and 4 git commands to generate.