]> git.pld-linux.org Git - packages/fwupd.git/blame - fwupd.spec
- updated to 0.1.6
[packages/fwupd.git] / fwupd.spec
CommitLineData
8dceaca0
JB
1#
2# Conditional build:
3%bcond_without colorhug # ColorHug support
4%bcond_without efi # UEFI support
5%bcond_without static_libs # static library
6#
7%ifnarch %{ix86} %{x8664} arm aarch64 ia64
8%undefine with_efi
9%endif
10Summary: System daemon for installing device firmware
11Summary(pl.UTF-8): Demon systemowy do instalowania firmware'u urządzeń
12Name: fwupd
91b560a2 13Version: 0.1.6
8dceaca0
JB
14Release: 1
15License: GPL v2
16Group: Applications/System
17Source0: http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
91b560a2 18# Source0-md5: 81551ee30bc062257583393474f375c4
868d82b7 19Patch0: %{name}-sh.patch
8dceaca0 20URL: https://github.com/hughsie/fwupd
91b560a2 21BuildRequires: appstream-glib-devel >= 0.5.0
868d82b7
JB
22BuildRequires: autoconf >= 2.63
23BuildRequires: automake >= 1:1.9
8dceaca0
JB
24%{?with_colorhug:BuildRequires: colord-devel >= 1.2.9}
25BuildRequires: docbook-utils
26%{?with_efi:BuildRequires: fwupdate-devel}
27BuildRequires: gcab-devel
28BuildRequires: gettext-tools >= 0.17
29BuildRequires: glib2-devel >= 1:2.36.0
30BuildRequires: gobject-introspection-devel >= 0.9.8
868d82b7 31BuildRequires: gpgme-devel
8dceaca0 32BuildRequires: intltool >= 0.35.0
91b560a2 33BuildRequires: libarchive-devel
868d82b7 34BuildRequires: libgpg-error-devel
91b560a2
JB
35BuildRequires: libgusb-devel >= 0.2.2
36BuildRequires: libsoup-devel >= 2.42
868d82b7 37BuildRequires: libtool
8dceaca0
JB
38BuildRequires: libxslt-progs
39BuildRequires: pkgconfig
40BuildRequires: polkit-devel >= 0.103
41BuildRequires: rpmbuild(macros) >= 1.644
42BuildRequires: sqlite3-devel >= 3
43BuildRequires: tar >= 1:1.22
44BuildRequires: udev-glib-devel
45BuildRequires: xz
46Requires: %{name}-libs = %{version}-%{release}
91b560a2 47Requires: appstream-glib >= 0.5.0
8dceaca0 48%{?with_colorhug:Requires: colord-libs >= 1.2.9}
91b560a2 49Requires: libgusb >= 0.2.2
8dceaca0
JB
50Requires: polkit >= 0.103
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54fwupd is a simple daemon to allow session software to update device
55firmware on your local machine. It's designed for desktops, but this
56project is probably quite interesting for phones, tablets and server
57farms.
58
59%description -l pl.UTF-8
60fwupd to prosty demon pozwalający programom sesyjnym na aktualizację
61firmware'u urządzeń na maszynie lokalnej. Jest zaprojektowany dla
62komputerów osobistych, ale może być interesujący także dla telefonów,
63tabletów i farm serwerów.
64
65%package libs
66Summary: Library for fwupd device firmware installing daemon
67Summary(pl.UTF-8): Biblioteka dla demona fwupd instalującego aktualizacje firmware'u
68Group: Libraries
69Requires: glib2-devel >= 1:2.36.0
70
71%description libs
72Library for fwupd device firmware installing daemon.
73
74%description libs -l pl.UTF-8
75Biblioteka dla demona fwupd instalującego aktualizacje firmware'u.
76
77%package devel
78Summary: Header files for fwupd library
79Summary(pl.UTF-8): Pliki nagłówkowe biblioteki fwupd
80Group: Development/Libraries
81Requires: %{name}-libs = %{version}-%{release}
82Requires: glib2-devel >= 1:2.36.0
83
84%description devel
85Header files for fwupd library.
86
87%description devel -l pl.UTF-8
88Pliki nagłówkowe biblioteki fwupd.
89
90%package static
91Summary: Static fwupd library
92Summary(pl.UTF-8): Statyczna biblioteka fwupd
93Group: Development/Libraries
94Requires: %{name}-devel = %{version}-%{release}
95
96%description static
97Static fwupd library.
98
99%description static -l pl.UTF-8
100Statyczna biblioteka fwupd.
101
102%prep
103%setup -q
868d82b7 104%patch0 -p1
8dceaca0
JB
105
106%build
868d82b7
JB
107%{__libtoolize}
108%{__aclocal} -I m4
109%{__autoconf}
110%{__autoheader}
111%{__automake}
8dceaca0 112%configure \
868d82b7 113 --disable-silent-rules \
8dceaca0
JB
114 %{!?with_static_libs:--disable-static} \
115 %{!?with_efi:--disable-uefi} \
116 --with-systemdsystemunitdir=%{systemdunitdir}
117%{__make}
118
119%install
120rm -rf $RPM_BUILD_ROOT
121
122%{__make} install \
123 DESTDIR=$RPM_BUILD_ROOT
124
125# obsoleted by pkg-config
126%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfwupd.la
127
128%{__mv} $RPM_BUILD_ROOT%{_localedir}/{hi_IN,hi}
129
130%find_lang %{name}
131
132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%post libs -p /sbin/ldconfig
136%postun libs -p /sbin/ldconfig
137
138%files -f %{name}.lang
139%defattr(644,root,root,755)
140%doc AUTHORS MAINTAINERS NEWS README.md
141%attr(755,root,root) %{_bindir}/fwupdmgr
142%attr(755,root,root) %{_libexecdir}/fwupd
91b560a2 143%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fwupd.conf
868d82b7
JB
144%dir /etc/pki/fwupd
145/etc/pki/fwupd/GPG-KEY-Hughski-Limited
91b560a2
JB
146/etc/pki/fwupd/GPG-KEY-Linux-Vendor-Firmware-Service
147%dir /etc/pki/fwupd-metadata
148/etc/pki/fwupd-metadata/GPG-KEY-Linux-Vendor-Firmware-Service
8dceaca0 149%{systemdunitdir}/fwupd.service
a557ad5c
JB
150%{systemdunitdir}/fwupd-offline-update.service
151%{systemdunitdir}/system-update.target.wants/fwupd-offline-update.service
91b560a2 152/lib/udev/rules.d/90-fwupd-devices.rules
8dceaca0
JB
153/etc/dbus-1/system.d/org.freedesktop.fwupd.conf
154%{_datadir}/dbus-1/system-services/org.freedesktop.fwupd.service
155%{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
156%{_datadir}/polkit-1/rules.d/org.freedesktop.fwupd.rules
157%dir /var/lib/fwupd
158%{_mandir}/man1/fwupdmgr.1*
159
160%files libs
161%defattr(644,root,root,755)
162%attr(755,root,root) %{_libdir}/libfwupd.so.*.*.*
163%attr(755,root,root) %ghost %{_libdir}/libfwupd.so.1
164%{_libdir}/girepository-1.0/Fwupd-1.0.typelib
165
166%files devel
167%defattr(644,root,root,755)
168%attr(755,root,root) %{_libdir}/libfwupd.so
169%{_includedir}/fwupd-1
170%{_datadir}/gir-1.0/Fwupd-1.0.gir
171%{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
172%{_pkgconfigdir}/fwupd.pc
173
174%if %{with static_libs}
175%files static
176%defattr(644,root,root,755)
177%{_libdir}/libfwupd.a
178%endif
This page took 0.064703 seconds and 4 git commands to generate.