]> git.pld-linux.org Git - packages/femfind.git/blame - femfind.spec
- converted to UTF-8
[packages/femfind.git] / femfind.spec
CommitLineData
55665d2c 1#
1b8e4137 2# TODO:
510207e5 3# - webapps
1b8e4137
PG
4# - include apache configuration to config
5# - pre/post play
5d158baa 6# - logrotate file
55665d2c 7# - fix ownership of the perl_vendorlib/FemFind directory
8#
1b8e4137
PG
9%include /usr/lib/rpm/macros.perl
10Summary: FemFind - crawl your network resources
0d036695 11Summary(pl.UTF-8): FemFind - przeszukiwanie zasobów sieciowych
1b8e4137
PG
12Name: FemFind
13Version: 0.74
55665d2c 14Release: 2
1b8e4137
PG
15License: GPL v2
16Group: Networking/Utilities
17Source0: http://www.codefactory.de/downloads/%{name}-%{version}.tar.gz
00f208f5 18# Source0-md5: 57de716507fb23ddb4fed17cd77cd038
5d158baa 19Patch0: %{name}-config.patch
1b8e4137 20URL: http://femfind.sourceforge.net/
55665d2c 21BuildRequires: rpm-perlprov >= 4.1-13
1b8e4137
PG
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
0df3e734
AA
24%define _wwwsite /home/services/httpd/html/FemFind
25%define _cgisite /home/services/httpd/cgi-bin/femfind
1b8e4137
PG
26
27%description
28FemFind is a crawler for SMB shares which can be found on Windows or
29Unix systems running Samba. Additionally FemFind crawls FTP servers
30and provides a web interface and a Windows client as frontends.
31
0d036695
JR
32%description -l pl.UTF-8
33FemFind jest programem przeszukującym zasoby sieci udostępnione
34poprzez protokół SMB na maszynach windowsowych lub uniksowych z
35działającą Sambą. Dodatkowo FemFind przeszukuje serwery FTP, dostarcza
1872e449 36interfejs WWW oraz klienta windowsowego jako frontend.
1b8e4137
PG
37
38%package -n perl-FemFind-ConfigReader
39Summary: FemFind - crawl your network resources
0d036695 40Summary(pl.UTF-8): FemFind - przeszukiwanie zasobów sieciowych
1b8e4137
PG
41Group: Development/Languages/Perl
42
43%description -n perl-FemFind-ConfigReader
44FemFind::ConfigReader perl module for FemFind.
45
0d036695
JR
46%description -n perl-FemFind-ConfigReader -l pl.UTF-8
47Perlowy moduł FemFind::ConfigReader dla FemFinda.
1b8e4137
PG
48
49%package -n perl-FemFind-Helper
50Summary: FemFind - crawl your network resources
0d036695 51Summary(pl.UTF-8): FemFind - przeszukiwanie zasobów sieciowych
1b8e4137
PG
52Group: Development/Languages/Perl
53
54%description -n perl-FemFind-Helper
55FemFind::Helper perl module for FemFind.
56
0d036695
JR
57%description -n perl-FemFind-Helper -l pl.UTF-8
58Perlowy moduł FemFind::Helper dla FemFinda.
1b8e4137
PG
59
60%package -n FemFind-cgi
61Summary: FemFind - crawl your network resources
0d036695 62Summary(pl.UTF-8): FemFind - przeszukiwanie zasobów sieciowych
1b8e4137
PG
63Group: Networking/Utilities
64
65%description -n FemFind-cgi
66CGI scripts for FemFind frontend.
67
0d036695 68%description -n FemFind-cgi -l pl.UTF-8
1b8e4137
PG
69Skrypty CGI do frontendu FemFinda.
70
71%prep
72%setup -q
5d158baa 73%patch0 -p1
1b8e4137
PG
74
75%build
76cd modules
77cd ConfigReader
55665d2c 78%{__perl} Makefile.PL \
79 INSTALLDIRS=vendor
80%{__make}
1b8e4137
PG
81cd ..
82cd Helper
55665d2c 83%{__perl} Makefile.PL \
84 INSTALLDIRS=vendor
85%{__make}
1b8e4137
PG
86cd ..
87
88%install
89rm -rf $RPM_BUILD_ROOT
56fb704c 90install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{_bindir},%{_sbindir}}
5d158baa 91install -d $RPM_BUILD_ROOT{%{_wwwsite},%{_cgisite}/german,/var/{lib/femfind,log}}
1b8e4137 92
55665d2c 93%{__make} install \
94 -C modules/ConfigReader \
95 DESTDIR=$RPM_BUILD_ROOT
96
97%{__make} install \
98 -C modules/Helper \
99 DESTDIR=$RPM_BUILD_ROOT
1b8e4137
PG
100
101install femfind.conf $RPM_BUILD_ROOT%{_sysconfdir}
102install makedb.pl $RPM_BUILD_ROOT%{_sbindir}
103install crawler.pl $RPM_BUILD_ROOT%{_bindir}
104install german/* $RPM_BUILD_ROOT%{_cgisite}/german
105install cgi-bin/femfind/* $RPM_BUILD_ROOT%{_cgisite}
106install htdocs/femfind/* $RPM_BUILD_ROOT%{_wwwsite}
107
5d158baa
PG
108touch $RPM_BUILD_ROOT/var/log/femfind.log
109
1b8e4137
PG
110%clean
111rm -rf $RPM_BUILD_ROOT
112
5d158baa
PG
113%post
114echo "Remember to init database running %{_sbindir}/makedb.pl"
115
1b8e4137
PG
116%files
117%defattr(644,root,root,755)
118%doc README
5d158baa
PG
119%dir /var/lib/femfind
120%ghost /var/log/femfind.log
7fcd3309 121%config(noreplace) %{_sysconfdir}/femfind.conf
1b8e4137
PG
122%attr(755,root,root) %{_sbindir}/makedb.pl
123%attr(755,root,root) %{_bindir}/crawler.pl
124
125%files -n perl-FemFind-ConfigReader
126%defattr(644,root,root,755)
47a767ab 127# ??? see Helper
55665d2c 128%{perl_vendorlib}/FemFind/*.pm
129%{_mandir}/man3/FemFind::ConfigReader.*
1b8e4137
PG
130
131%files -n perl-FemFind-Helper
132%defattr(644,root,root,755)
47a767ab 133# ??? see ConfigReader
55665d2c 134%{perl_vendorlib}/FemFind/*.pm
135%{_mandir}/man3/FemFind::Helper.*
1b8e4137
PG
136
137%files -n FemFind-cgi
138%defattr(644,root,root,755)
139%dir %{_cgisite}
140%dir %{_wwwsite}
47a767ab 141%dir %{_cgisite}/german
1b8e4137 142%attr(755,root,root) %{_cgisite}/german/*.pl
47a767ab 143%{_cgisite}/german/*.html
1b8e4137 144%attr(755,root,root) %{_cgisite}/*.pl
47a767ab
JB
145%{_cgisite}/*.html
146%{_cgisite}/ftp_list
147%{_wwwsite}/*
This page took 0.076183 seconds and 4 git commands to generate.