]> git.pld-linux.org Git - packages/eric6.git/blame - eric6.spec
Version 17.03.1. Rel 1.
[packages/eric6.git] / eric6.spec
CommitLineData
50968d52 1%bcond_with python2 # Use python2 (NOTE: as for 17.03.1 it has issuses in PLD)
e2cab009
MK
2
3%define module eric6
4Summary: Eric6 - a full featured Python IDE
5Summary(pl.UTF-8): Eric6 - pełnowartościowe IDE dla Pythona
6# Name must match the python module/package name (as on pypi or in 'import' statement)
7Name: eric6
30e23900 8Version: 17.03.1
50968d52 9Release: 1
e2cab009
MK
10License: GPL v3
11Group: Libraries/Python
a9909cc0 12Source0: https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/%{name}-%{version}.tar.gz
30e23900 13# Source0-md5: 4e56a985387cceed981db1ba2579183b
e2cab009
MK
14URL: http://eric-ide.python-projects.org/index.html
15BuildRequires: rpm-pythonprov
50968d52
MK
16BuildRequires: rpmbuild(macros) >= 1.714
17%if %{with python2}
e2cab009
MK
18BuildRequires: python-modules
19BuildRequires: python-setuptools
20# NOTE: As for 6.1.8 eric6 still tries to import PyQt5 while having PyQt4 leading to crash
21# http://die-offenbachs.homelinux.org:48888/issues/issue204
22# for --pyqt=4
e2cab009 23# BuildRequires: python-PyQt4-qscintilla2
5c2f16b8 24# BuildRequires: python-PyQt4-uic
e2cab009
MK
25# for --pyqt=5
26BuildRequires: python-PyQt5-qscintilla2
27BuildRequires: python-PyQt5-uic
2758d547 28Requires: python-PyQt5-qscintilla2
a9909cc0 29Requires: python-modules
50968d52
MK
30Suggests: python-pylint
31%else
32BuildRequires: python3-PyQt5-qscintilla2
33BuildRequires: python3-PyQt5-uic
34BuildRequires: python3-modules
35BuildRequires: python3-setuptools
36Requires: python3-PyQt5-qscintilla2
37Requires: python3-modules
38Suggests: python3-pylint
39%endif
40
e2cab009
MK
41BuildArch: noarch
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
5c2f16b8
MK
45Eric is a Python IDE written using PyQt and QScintilla. It provides
46various features such as any number of open editors, an integrated
47(remote) debugger, project management facilities, unit test,
48refactoring and much more.
e2cab009
MK
49
50%description -l pl.UTF-8
5c2f16b8
MK
51Eric jest pythonowym graficznym środowiskiem programistycznym
52używającym PyQt i QScintilla.
e2cab009
MK
53
54%prep
55%setup -q
56
57%build
58
59%install
60rm -rf $RPM_BUILD_ROOT
50968d52 61%if %{with python2}
e2cab009 62python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT --pyqt=5
50968d52
MK
63%else
64python3 install.py -z -c -b %{_bindir} -d %{py3_sitescriptdir} -i $RPM_BUILD_ROOT --pyqt=5
65%endif
a9909cc0
MK
66mkdir $RPM_BUILD_ROOT%{_datadir}/appdata
67mv $RPM_BUILD_ROOT%{_datadir}/metainfo/eric6.appdata.xml $RPM_BUILD_ROOT%{_datadir}/appdata
e2cab009
MK
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
e2cab009
MK
72%files
73%defattr(644,root,root,755)
74%doc README.rst
50968d52 75%if %{with python2}
e2cab009 76%{py_sitescriptdir}/%{module}
50968d52
MK
77%else
78%{py3_sitescriptdir}/%{module}
79%endif
80
e2cab009
MK
81%attr(755,root,root) %{_bindir}/eric6
82%attr(755,root,root) %{_bindir}/eric6_*
83# for --pyqt=4
5c2f16b8
MK
84# %{_datadir}/qt4/qsci/api/qss/
85# %{_datadir}/qt4/qsci/api/ruby/
d5275b1c 86# NOTE: file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
5c2f16b8
MK
87# %{_datadir}/qt4/qsci/api/python/eric6.*
88# %{_datadir}/qt4/qsci/api/python/zope-*.api
e2cab009
MK
89
90# for --pyqt=5
5c2f16b8
MK
91%{_datadir}/qt5/qsci/api/qss/
92%{_datadir}/qt5/qsci/api/ruby/
93%{_datadir}/qt5/qsci/api/python/eric6.*
94%{_datadir}/qt5/qsci/api/python/zope-*.api
e2cab009 95
5c2f16b8
MK
96%{_pixmapsdir}/eric*.png
97%{_desktopdir}/eric6.desktop
98%{_desktopdir}/eric6_webbrowser.desktop
fd4f94e0 99%{_desktopdir}/eric6_browser.desktop
a9909cc0 100%{_datadir}/appdata/eric6.appdata.xml
50968d52 101%if %{with python2}
5c2f16b8
MK
102%{py_sitescriptdir}/eric6config.py
103%{py_sitescriptdir}/eric6plugins
50968d52
MK
104%else
105%{py3_sitescriptdir}/eric6config.py
106%{py3_sitescriptdir}/eric6plugins
107%endif
This page took 0.109065 seconds and 4 git commands to generate.