]> git.pld-linux.org Git - packages/dssi.git/blame - dssi.spec
- x32 rebuild
[packages/dssi.git] / dssi.spec
CommitLineData
074104ee
JR
1#
2# Conditional build:
3%bcond_without gui # don't build gui examples (require qt4)
4#
65b645a5 5Summary: Disposable Soft Synth Interface specification
57458f0e 6Summary(pl.UTF-8): Specyfikacja Disposable Soft Synth Interface
65b645a5 7Name: dssi
7a58f2d3 8Version: 1.1.1
903ba735 9Release: 2
65b645a5
PS
10License: LGPL v2.1
11Group: Development/Libraries
91c2ee8b 12Source0: http://downloads.sourceforge.net/dssi/%{name}-%{version}.tar.gz
7a58f2d3 13# Source0-md5: 619ab73c883b02dc37ddb37001591f8b
91c2ee8b 14Patch0: %{name}-lib64.patch
074104ee 15Patch1: %{name}-libx32.patch
65b645a5 16URL: http://dssi.sourceforge.net/
074104ee 17%if %{with gui}
7a58f2d3 18BuildRequires: QtCore-devel >= 4.0.1
91c2ee8b 19BuildRequires: QtGui-devel >= 4.0.1
074104ee
JR
20BuildRequires: qt4-build >= 4.0.1
21%endif
0ae4bdb5 22BuildRequires: alsa-lib-devel >= 0.9
dbae6881
JK
23BuildRequires: autoconf
24BuildRequires: automake
7a58f2d3 25BuildRequires: jack-audio-connection-kit-devel >= 0.99.14
0ae4bdb5
JB
26BuildRequires: ladspa-devel >= 1.0
27BuildRequires: liblo-devel >= 0.12
4f4c1293
JK
28BuildRequires: libsamplerate-devel
29BuildRequires: libsndfile-devel
dbae6881 30BuildRequires: libtool
29a653bf 31BuildRequires: pkgconfig
7a58f2d3 32BuildRequires: xorg-lib-libX11-devel
65b645a5
PS
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
36DSSI (pronounced "dizzy") is an API for audio plugins, with particular
37application for software synthesis plugins with native user
38interfaces. DSSI is an open specification developed for use in Linux
39audio applications, although portable to other platforms. It may be
40thought of as LADSPA-for-instruments, or something comparable to VSTi.
41
42DSSI consists of a C language API for use by plugins and hosts, based
43on the LADSPA API, and an OSC (Open Sound Control) API for use in user
44interface to host communications. The DSSI specification consists of
45an RFC which describes the background for the proposal and defines the
46OSC part of the specification, and a documented header file which
47defines the C API.
48
dab913f7
JR
49%description -l pl.UTF-8
50DSSI (wymawiane "dizzy") to API dla wtyczek dźwiękowych z
51zastosowaniem szczególnie dla wtyczek syntezy programowej z natywnymi
52interfejsami użytkownika. DSSI to otwarta specyfikacja stworzona do
53używania w linuksowych aplikacjach dźwiękowych, ale przenośna na inne
54platformy. Można ją określić jako LADSPA dla instrumentów lub coś
55porównywalnego do VSTi.
c3db29b9 56
dab913f7
JR
57DSSI składa się z API języka C do użytku przez wtyczki i hosty, oparte
58o API LADSPA oraz API OSC (Open Sound Control) do użytku w
59interfejsach użytkownika do komunikacji z hostem. Specyfikacja DSSI
60składa się z RFC opisującego tło propozycji i definiującego część OSC
61specyfikacji oraz udokumentowanego pliku nagłówkowego definiującego
c3db29b9
JB
62API C.
63
4f4c1293
JK
64%package devel
65Summary: DSSI development files
66Summary(pl.UTF-8): Pliki nagłówkowe DSSI
67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69Requires: alsa-lib-devel >= 0.9
70Requires: ladspa-devel >= 1.0
71Obsoletes: dssi < 1.0.0
72
73%description devel
74DSSI development files.
75
76%description devel -l pl.UTF-8
77Pliki nagłówkowe DSSI.
78
0ae4bdb5
JB
79%package host-jack
80Summary: A simple JACK/ALSA-sequencer plugin host
57458f0e 81Summary(pl.UTF-8): Prosty host wtyczek sekwencera JACK/ALSA
0ae4bdb5 82Group: Applications/Sound
4f4c1293 83Requires: %{name} = %{version}-%{release}
0ae4bdb5
JB
84Requires: liblo >= 0.12
85
86%description host-jack
87A simple JACK/ALSA-sequencer plugin host.
88
dab913f7 89%description host-jack -l pl.UTF-8
0ae4bdb5
JB
90Prosty host wtyczek sekwencera JACK/ALSA.
91
4f4c1293
JK
92%package examples
93Summary: Example DSSI plugins
94Summary(pl.UTF-8): Przykładowe wtyczki DSSI
95Group: Applications/Sound
96Requires: %{name} = %{version}-%{release}
97
98%description examples
99Example DSSI plugins.
100
101%description examples -l pl.UTF-8
102Przykładowe wtyczki DSSI
103
65b645a5
PS
104%prep
105%setup -q
74eb3d40 106%if "%{_lib}" == "lib64"
91c2ee8b 107%patch0 -p1
74eb3d40 108%endif
074104ee
JR
109%if "%{_lib}" == "libx32"
110%patch1 -p1
111%endif
65b645a5
PS
112
113%build
a72f4010
JK
114%{__libtoolize}
115%{__aclocal}
116%{__autoconf}
117%{__autoheader}
118%{__automake}
119
65b645a5
PS
120%configure
121%{__make}
122
123%install
124rm -rf $RPM_BUILD_ROOT
125
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128
91c2ee8b 129%{__rm} $RPM_BUILD_ROOT%{_libdir}/dssi/*.la
4f4c1293 130
65b645a5
PS
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%files
135%defattr(644,root,root,755)
136%doc ChangeLog README doc/TODO doc/*.txt
91c2ee8b
JB
137%attr(755,root,root) %{_bindir}/dssi_analyse_plugin
138%attr(755,root,root) %{_bindir}/dssi_list_plugins
4f4c1293
JK
139%attr(755,root,root) %{_bindir}/dssi_osc_send
140%attr(755,root,root) %{_bindir}/dssi_osc_update
141%dir %{_libdir}/dssi
91c2ee8b 142%{_mandir}/man1/dssi*.1*
4f4c1293
JK
143
144%files devel
145%defattr(644,root,root,755)
65b645a5
PS
146%{_includedir}/dssi.h
147%{_pkgconfigdir}/dssi.pc
0ae4bdb5
JB
148
149%files host-jack
150%defattr(644,root,root,755)
151%attr(755,root,root) %{_bindir}/jack-dssi-host
91c2ee8b 152%{_mandir}/man1/jack-dssi-host.1*
4f4c1293
JK
153
154%files examples
155%defattr(644,root,root,755)
156%attr(755,root,root) %{_bindir}/karplong
157%attr(755,root,root) %{_bindir}/less_trivial_synth
158%attr(755,root,root) %{_bindir}/trivial_sampler
159%attr(755,root,root) %{_bindir}/trivial_synth
160%attr(755,root,root) %{_libdir}/dssi/*.so
074104ee 161%if %{with gui}
4f4c1293
JK
162%dir %{_libdir}/dssi/less_trivial_synth
163%attr(755,root,root) %{_libdir}/dssi/less_trivial_synth/*_qt
164%dir %{_libdir}/dssi/trivial_sampler
165%attr(755,root,root) %{_libdir}/dssi/trivial_sampler/*_qt
074104ee 166%endif
This page took 0.074024 seconds and 5 git commands to generate.