]> git.pld-linux.org Git - packages/dss.git/blame - dss.spec
- installing files
[packages/dss.git] / dss.spec
CommitLineData
2d53a2fb
ER
1Summary: Darwin Streaming Server
2Name: dss
3Version: 6.0.3
7922b313 4Release: 0.2
2d53a2fb
ER
5License: Apple Public Source License
6Group: Applications
7Source0: http://dss.macosforge.org/downloads/DarwinStreamingSrvr%{version}-Source.tar
8# Source0-md5: ca676691db8417d05121699c0ca3d549
720b962c
ER
9Patch0: %{name}.patch
10Patch1: %{name}-x86_64.patch
c08547c4
ER
11Patch2: optflags.patch
12Patch3: compile.patch
2d53a2fb
ER
13URL: http://dss.macosforge.org/
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17Darwin Streaming Server lets you stream digital video on the Internet
18using industry-standard Internet protocols RTP and RTSP.
19
20Using Darwin Streaming Server you can serve stored files (video on
21demand) or reflect live broadcasts to thousands of QuickTime 4 or
22later users. With its combination of industry-standard streaming
23protocols and cutting-edge compression technologies, QuickTime
24delivers perfectly synchronized audio and video streams ideal for
25Internet video and live events.
26
27%package Proxy
28Summary: Apple's Darwin Streaming Proxy
29Group: Daemons
30
31%description Proxy
32The Darwin Streaming Proxy is an application specific proxy which
33would normally be run in a border zone or perimeter network. It is
34used to give client machines within a protected network access to
35streaming servers outside that network, in the case when the firewall
36blocks RTSP connections or RTP/UDP data flow. The firewall perimeter
37network is usually configured to allow:
38
39- RTSP connections from within the network, as long as the destination
40 is the proxy
41
42- RTSP connections to outside the network, as long as the source is
43 the proxy
44
45- RTP datagrams to and from the proxy to the inner network
46
47- RTP datagrams to and from the proxy to the outside
48
49%package Utils
50Summary: Apple's Darwin Streaming Server Movie inspection utilities
51Group: Daemons
52
53%description Utils
54- QTBroadcaster Requires a target ip address, a source movie, one or
55 more source hint track ids in movie, and an initial port. Every packet
56 referenced by the hint track(s) is broadcasted to the specified ip
57 address.
58
59- QTFileInfo Requires a movie name. Displays each track id, name,
60 create date, and mod date. If the track is a hint track, additional
61 information is displayed: the total rtp bytes and packets, the average
62 bit rate and packet size, and the total header percentage of the
63 stream.
64
65- QTFileTest Requires a movie name. Parses the Movie Header Atom and
66 displays a trace of the output.
67
68- QTRTPFileTest Requires a movie and a hint track id in the movie.
69 Displays the RTP header (TransmitTime, Cookie, SeqNum, and TimeStamp)
70 for each packet.
71
72- QTRTPGen Requires a movie and a hint track id. Displays the number
73 of packets in each hint track sample and writes the RTP packets to
74 file "track.cache"
75
76- QTSampleLister Requires a movie and a track id. Displays track media
77 sample number, media time, Data offset, and sample size for each
78 sample in the track.
79
80- QTSDPGen Requires a list of 1 or more movies. Displays the SDP
81 information for all of the hinted tracks in each movie. Use -f to save
82 the SDP information to the file [movie].sdp in the same directory as
83 the source movie.
84
85- QTTrackInfo Requires a movie, sample table atom type, and track id.
86 Displays the information in the sample table atom of the specified
87 track. Supports "stco", "stsc", "stsz", "stts" as the atom type.
88
89Example: "./QTTrackInfo -T stco /movies/mystery.mov 3" dumps the chunk
90offset sample table in track 3.
91
92- StreamingLoadTool
93
94%package Samples
95Summary: Apple's Darwin Streaming Samples
96Group: Daemons
97
98%description Samples
99Sample files for the Darwin Streaming Server.
100
101%prep
102%setup -q -n DarwinStreamingSrvr%{version}-Source
720b962c
ER
103%patch0 -p1
104%patch1 -p1
c08547c4
ER
105%patch2 -p1
106%patch3 -p1
2d53a2fb
ER
107
108# patch streamingadminserver.pl
7922b313
ER
109%{__sed} -i.bak -e '
110 s|/''usr/local/movies|%{_localstatedir}/lib/%{name}/movies|g
111 s|/''usr/local/sbin/StreamingServerModules|%{_libdir}/%{name}/|g
112 s|/''usr/local/|%{_prefix}/|g
113 s|/etc/streaming|%{_sysconfdir}/%{name}|g
114 s|/var/streaming/logs/|%{_localstatedir}/log/%{name}/|g
115 s|/var/streaming/|%{_localstatedir}/lib/%{name}/|g
116' DSS_MakeRoot streamingserver.xml-POSIX \
117 WebAdmin/src/streamingadminserver.pl \
118 WebAdmin/WebAdminHtml/adminprotocol-lib.pl
2d53a2fb
ER
119
120# patch manpages
7922b313
ER
121%{__sed} -i -e '
122 s|/Library/QuickTimeStreaming/Config/|%{_sysconfdir}/%{name}/|g
123 s|/Library/QuickTimeStreaming/Modules|%{_libdir}/%{name}|g
124 s|/Library/QuickTimeStreaming/Movies|%{_localstatedir}/lib/%{name}/movies|g
125 s|/Library/QuickTimeStreaming/Playlists|%{_localstatedir}/lib/%{name}/playlists|g
126 s|/Library/QuickTimeStreaming/Logs|%{_localstatedir}/log/%{name}|g
127 s|/Library/QuickTimeStreaming/Docs|%{_docdir}/%{name}-%{version}|g
128 s|QuickTimeStreamingServer|DarwinStreamingServer|g
129' Documentation/man/qtss/*
130
131cat > defaultPaths.h << 'EOF'
2d53a2fb 132#define DEFAULTPATHS_DIRECTORY_SEPARATOR "/"
7922b313
ER
133#define DEFAULTPATHS_ROOT_DIR "%{_localstatedir}/lib/%{name}/"
134#define DEFAULTPATHS_ETC_DIR "%{_sysconfdir}/%{name}/"
2d53a2fb 135#define DEFAULTPATHS_ETC_DIR_OLD "%{_sysconfdir}/"
7922b313
ER
136#define DEFAULTPATHS_SSM_DIR "%{_libdir}/%{name}/"
137#define DEFAULTPATHS_LOG_DIR "%{_localstatedir}/log/%{name}/"
2d53a2fb 138#define DEFAULTPATHS_PID_DIR "%{_localstatedir}/run/"
7922b313 139#define DEFAULTPATHS_MOVIES_DIR "%{_localstatedir}/lib/%{name}/movies/"
2d53a2fb
ER
140EOF
141
142%build
143export RPM_OPT_FLAGS="%{rpmcflags}"
144export ARCH="%{_target_cpu}"
145export CC="%{__cc}"
146export CXX="%{__cxx}"
147
148jobs=$(echo %{_smp_mflags} | cut -dj -f2)
149./Buildit ${jobs:+--jobs=$jobs}
150
151%install
152rm -rf $RPM_BUILD_ROOT
153./DSS_MakeRoot \
154 $RPM_BUILD_ROOT
155
7922b313
ER
156# Create our default admin user and remove Apple's
157# Default login is root/pld -- please change it!
158qtpasswd="\
159$RPM_BUILD_ROOT%{_bindir}/qtpasswd \
160-f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/qtusers
161-g $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/qtgroups"
162$qtpasswd root -p pld -A admin
163$qtpasswd -F -d 'aGFja21l'
164
165mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/relayconfig.xml{-Sample,}
166rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/streamingserver.xml-sample
167
168rm $RPM_BUILD_ROOT/var/lib/%{name}/3rdPartyAcknowledgements.rtf
169rm $RPM_BUILD_ROOT/var/lib/%{name}/readme.txt
170
2d53a2fb
ER
171%clean
172rm -rf $RPM_BUILD_ROOT
173
174%files
175%defattr(644,root,root,755)
176%doc APPLE_LICENSE ReleaseNotes.txt
7922b313
ER
177%doc Documentation/3rdPartyAcknowledgements.rtf
178%doc Documentation/AboutQTFileTools.html
179%doc Documentation/AboutTheSource.html
180%doc Documentation/admin-protocol-README.txt
181%doc Documentation/CachingProxyProtocol-README.txt
182%doc Documentation/DevNotes.html
183%doc Documentation/draft-serenyi-avt-rtp-meta-00.txt
184%doc Documentation/DSS_QT_Logo_License.pdf
185%doc Documentation/License.rtf
186%doc Documentation/QTSSAPIDocs.pdf
187%doc Documentation/ReadMe.rtf
188%doc Documentation/readme.txt
189%doc Documentation/ReliableRTP_WhitePaper.rtf
190%doc Documentation/RTSP_Over_HTTP.pdf
191
192%dir %{_sysconfdir}/%{name}
193%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/qtgroups
194%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/qtusers
195%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/relayconfig.xml
196%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/streamingloadtool.conf
197%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/streamingserver.xml
198
199%attr(755,root,root) %{_bindir}/MP3Broadcaster
200%attr(755,root,root) %{_bindir}/PlaylistBroadcaster
201%attr(755,root,root) %{_bindir}/StreamingLoadTool
202%attr(755,root,root) %{_bindir}/createuserstreamingdir
203%attr(755,root,root) %{_bindir}/qtpasswd
204
205%attr(755,root,root) %{_sbindir}/DarwinStreamingServer
206%attr(755,root,root) %{_sbindir}/streamingadminserver.pl
207
208%dir %{_libdir}/%{name}
209%attr(755,root,root) %{_libdir}/%{name}/QTSSHomeDirectoryModule
210%attr(755,root,root) %{_libdir}/%{name}/QTSSRefMovieModule
211
212%dir /var/lib/%{name}
213
214# sample movies
215/var/lib/%{name}/movies
216
217# admin html (subpackage?)
218/var/lib/%{name}/AdminHtml
This page took 0.088807 seconds and 4 git commands to generate.